# Metricbeat elasticsearch-xpack errors

**URL:** <https://discuss.elastic.co/t/metricbeat-elasticsearch-xpack-errors/253758>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [October 29, 2020, 11:36pm UTC](https://discuss.elastic.co/t/metricbeat-elasticsearch-xpack-errors/253758 "2020-10-29T23:36:49Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![rugenl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rugenl/32/12887_2.png) [@rugenl](https://discuss.elastic.co/u/rugenl)\
**Post date:** [October 29, 2020, 11:36pm UTC](https://discuss.elastic.co/t/metricbeat-elasticsearch-xpack-errors/253758/1 "2020-10-29T23:36:49Z")

</div>

After 7.9.2 upgrade I've lost monitoring data on the "indexes" tab. I've found errors like this on metricbeat on the active master node:

> Error fetching data for metricset elasticsearch.index\_summary: HTTP error 400 in : 400 Bad Request

I've seen similar problems that point to "metricset", but adding those options didn't help. Other users have had permission errors but this isn't a production stack and is using a superuser account.

Any ideas?

Thanks

---

<div class="post-metadata">

**Author:** ![rugenl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rugenl/32/12887_2.png) [@rugenl](https://discuss.elastic.co/u/rugenl)\
**Post date:** [November 5, 2020, 12:41pm UTC](https://discuss.elastic.co/t/metricbeat-elasticsearch-xpack-errors/253758/2 "2020-11-05T12:41:40Z")

</div>

This is apparently a bug. If there are closed indices, stats fail. I had one index that was closed and had "index.blocks.read\_only": true. Fixing that index solved the issue.

---

<div class="post-metadata">

**Author:** ![jsoriano](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jsoriano/32/27920_2.png) [@jsoriano](https://discuss.elastic.co/u/jsoriano)\
**Post date:** [November 5, 2020, 6:02pm UTC](https://discuss.elastic.co/t/metricbeat-elasticsearch-xpack-errors/253758/3 "2020-11-05T18:02:01Z")

</div>

Hey @rugenl,

What version of Elasticsearch are you using?

Could you please report the bug with your insights in [https://github.com/elastic/beats/issues/new?template=bug-report.md](https://github.com/elastic/beats/issues/new?template=bug-report.md) ?

Thanks!

---

<div class="post-metadata">

**Author:** ![rugenl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rugenl/32/12887_2.png) [@rugenl](https://discuss.elastic.co/u/rugenl)\
**Post date:** [November 5, 2020, 9:42pm UTC](https://discuss.elastic.co/t/metricbeat-elasticsearch-xpack-errors/253758/4 "2020-11-05T21:42:01Z")

</div>

7.9.2, Elastic support told me it was a known bug, so it's been reported. They just didn't give me any related info on it. Look at case 00628652

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 3, 2020, 11:42pm UTC](https://discuss.elastic.co/t/metricbeat-elasticsearch-xpack-errors/253758/5 "2020-12-03T23:42:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
