# Metricbeat error

**URL:** <https://discuss.elastic.co/t/metricbeat-error/352828>\
**Category:** Elasticsearch\
**Created:** [February 8, 2024, 8:15am UTC](https://discuss.elastic.co/t/metricbeat-error/352828 "2024-02-08T08:15:47Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![miiroslavkardos](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/miiroslavkardos/32/123639_2.png) [@miiroslavkardos](https://discuss.elastic.co/u/miiroslavkardos)\
**Post date:** [February 8, 2024, 8:15am UTC](https://discuss.elastic.co/t/metricbeat-error/352828/1 "2024-02-08T08:15:47Z")

</div>

Hello,

Could anyone please tell me what kind of error is this  
:  
It is in my elasticsearch log /var/log/elasticsearch/elktest01.log.

```auto
[2024-02-08T09:03:07,475][WARN][o.e.x.m.MonitoringService] [testdata01] monitoring execution failed
org.elasticsearch.xpack.monitoring.exporter.ExportException: failed to flush export bulks
        at org.elasticsearch.xpack.monitoring.exporter.ExportBulk$Compound.lambda$doFlush$0(ExportBulk.java:110) [x-pack-monitoring-7.17.17.jar:7.17.17]
        at org.elasticsearch.action.ActionListener$1.onFailure(ActionListener.java:144) [elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.xpack.monitoring.exporter.local.LocalBulk.lambda$doFlush$1(LocalBulk.java:121) [x-pack-monitoring-7.17.17.jar:7.17.17]
        at org.elasticsearch.action.ActionListener$1.onFailure(ActionListener.java:144) [elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.action.support.ContextPreservingActionListener.onFailure(ContextPreservingActionListener.java:38) [elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.action.support.TransportAction$1.onFailure(TransportAction.java:97) [elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.action.ActionListener$Delegating.onFailure(ActionListener.java:66) [elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.action.ActionListener$RunBeforeActionListener.onFailure(ActionListener.java:399) [elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.action.bulk.TransportBulkAction.doInternalExecute(TransportBulkAction.java:247) [elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.action.bulk.TransportBulkAction$1.doRun(TransportBulkAction.java:192) [elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:26) [elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.action.bulk.TransportBulkAction.doExecute(TransportBulkAction.java:200) [elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.action.bulk.TransportBulkAction.doExecute(TransportBulkAction.java:91) [elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.action.support.TransportAction$RequestFilterChain.proceed(TransportAction.java:186) [elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.action.support.TransportAction.execute(TransportAction.java:161) [elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.action.support.TransportAction.execute(TransportAction.java:82) [elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.client.node.NodeClient.executeLocally(NodeClient.java:95) [elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.client.node.NodeClient.doExecute(NodeClient.java:73) [elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.client.support.AbstractClient.execute(AbstractClient.java:407) [elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.client.support.AbstractClient.bulk(AbstractClient.java:492) [elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.xpack.core.ClientHelper.executeAsyncWithOrigin(ClientHelper.java:127) [x-pack-core-7.17.17.jar:7.17.17]
        at org.elasticsearch.xpack.monitoring.exporter.local.LocalBulk.doFlush(LocalBulk.java:111) [x-pack-monitoring-7.17.17.jar:7.17.17]
        at org.elasticsearch.xpack.monitoring.exporter.ExportBulk.flush(ExportBulk.java:64) [x-pack-monitoring-7.17.17.jar:7.17.17]
        at org.elasticsearch.xpack.monitoring.exporter.ExportBulk$Compound.lambda$doFlush$1(ExportBulk.java:108) [x-pack-monitoring-7.17.17.jar:7.17.17]
        at org.elasticsearch.xpack.core.common.IteratingActionListener.run(IteratingActionListener.java:117) [x-pack-core-7.17.17.jar:7.17.17]
        at org.elasticsearch.xpack.monitoring.exporter.ExportBulk$Compound.doFlush(ExportBulk.java:127) [x-pack-monitoring-7.17.17.jar:7.17.17]
        at org.elasticsearch.xpack.monitoring.exporter.ExportBulk.flush(ExportBulk.java:64) [x-pack-monitoring-7.17.17.jar:7.17.17]
        at org.elasticsearch.xpack.monitoring.exporter.Exporters.doExport(Exporters.java:296) [x-pack-monitoring-7.17.17.jar:7.17.17]
        at org.elasticsearch.xpack.monitoring.exporter.Exporters.lambda$export$3(Exporters.java:271) [x-pack-monitoring-7.17.17.jar:7.17.17]
        at org.elasticsearch.action.ActionListener$1.onResponse(ActionListener.java:136) [elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.xpack.monitoring.exporter.Exporters$AccumulatingExportBulkActionListener.delegateIfComplete(Exporters.java:380) [x-pack-monitoring-7.17.17.jar:7.17.17]
        at org.elasticsearch.xpack.monitoring.exporter.Exporters$AccumulatingExportBulkActionListener.onResponse(Exporters.java:359) [x-pack-monitoring-7.17.17.jar:7.17.17]
        at org.elasticsearch.xpack.monitoring.exporter.Exporters$AccumulatingExportBulkActionListener.onResponse(Exporters.java:326) [x-pack-monitoring-7.17.17.jar:7.17.17]
        at org.elasticsearch.xpack.monitoring.exporter.local.LocalExporter.openBulk(LocalExporter.java:246) [x-pack-monitoring-7.17.17.jar:7.17.17]
        at org.elasticsearch.xpack.monitoring.exporter.Exporters.wrapExportBulk(Exporters.java:256) [x-pack-monitoring-7.17.17.jar:7.17.17]
        at org.elasticsearch.xpack.monitoring.exporter.Exporters.export(Exporters.java:269) [x-pack-monitoring-7.17.17.jar:7.17.17]
        at org.elasticsearch.xpack.monitoring.MonitoringService$MonitoringExecution$1.doRun(MonitoringService.java:284) [x-pack-monitoring-7.17.17.jar:7.17.17]
        at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:26) [elasticsearch-7.17.17.jar:7.17.17]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:572) [?:?]
        at java.util.concurrent.FutureTask.run(FutureTask.java:317) [?:?]
        at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingRunnable.run(ThreadContext.java:718) [elasticsearch-7.17.17.jar:7.17.17]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1144) [?:?]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:642) [?:?]
        at java.lang.Thread.run(Thread.java:1583) [?:?]
Caused by: org.elasticsearch.xpack.monitoring.exporter.ExportException: failed to flush export bulk [default_local]
        ... 42 more
Caused by: java.lang.IllegalStateException: There are no ingest nodes in this cluster, unable to forward request to an ingest node.
        at org.elasticsearch.action.ingest.IngestActionForwarder.randomIngestNode(IngestActionForwarder.java:52) ~[elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.action.ingest.IngestActionForwarder.forwardIngestRequest(IngestActionForwarder.java:42) ~[elasticsearch-7.17.17.jar:7.17.17]
        at org.elasticsearch.action.bulk.TransportBulkAction.doInternalExecute(TransportBulkAction.java:244) ~[elasticsearch-7.17.17.jar:7.17.17]
        ... 35 more

```

I installed metricbeat to monitor cluster health.

it is working fine for some time like this :  
 ![2024-02-08 09 06 55](https://us1.discourse-cdn.com/elastic/original/3X/8/8/883afd3635a60d839f3ec58468b476942948234c.png)

And after while i got this error:

 ![995983b0c5062d8dbb1451f9ceff726792aafd68](https://us1.discourse-cdn.com/elastic/original/3X/7/2/72e5e00107f00c9224ad9655e4a9559937628c66.png)

When i change node.roles: [node,master,ingest] , error dissapear and also error [Unable to find the cluster in the selected time range] dissapear. than i have monitoring ok. like in the 1st picture, when i remove ingest role. it will happen again after while.

---

<div class="post-metadata">

**Author:** ![miiroslavkardos](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/miiroslavkardos/32/123639_2.png) [@miiroslavkardos](https://discuss.elastic.co/u/miiroslavkardos)\
**Post date:** [February 8, 2024, 8:58am UTC](https://discuss.elastic.co/t/metricbeat-error/352828/2 "2024-02-08T08:58:11Z")

</div>

[quote="miiroslavkardos, post:1, topic:352828"]

While i was configuring mestmaster02 with metricbeat which seems OK, others nodes in cluster chnages ststuas to yellow saying Some nodes use only self monitoring.

 ![2024-02-08 09 55 16](https://us1.discourse-cdn.com/elastic/original/3X/2/1/21763e13d4fa75db79c97b86cb93af1cbf2d4e5a.png)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 7, 2024, 8:58am UTC](https://discuss.elastic.co/t/metricbeat-error/352828/3 "2024-03-07T08:58:52Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
