# Metricbeat fail with the error: failed to process cluster event (put-lifecycle-metricbeat-7.2.0) within 30s

**URL:** <https://discuss.elastic.co/t/metricbeat-fail-with-the-error-failed-to-process-cluster-event-put-lifecycle-metricbeat-7-2-0-within-30s/192340>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [July 26, 2019, 12:47am UTC](https://discuss.elastic.co/t/metricbeat-fail-with-the-error-failed-to-process-cluster-event-put-lifecycle-metricbeat-7-2-0-within-30s/192340 "2019-07-26T00:47:34Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Flaviu](https://avatars.discourse-cdn.com/v4/letter/f/94ad74/32.png) [@Flaviu](https://discuss.elastic.co/u/Flaviu)\
**Post date:** [July 26, 2019, 12:47am UTC](https://discuss.elastic.co/t/metricbeat-fail-with-the-error-failed-to-process-cluster-event-put-lifecycle-metricbeat-7-2-0-within-30s/192340/1 "2019-07-26T00:47:34Z")

</div>

I am getting the following error, and after a few hours of reasearch and configuration changes I could not find a solution.

Jul 26 00:31:05 am01 metricbeat: {"level":"error","timestamp":"2019-07-26T00:31:05.712Z","caller":"pipeline/output.go:100","message":"Failed to connect to backoff(elasticsearch([https://elasticsearch-url](https://elasticsearch-url):elasticsearchport)): Connection marked as failed because the onConnect callback failed: 503 Service Unavailable: {"error":{"root\_cause":[{"type":"process\_cluster\_event\_timeout\_exception","reason":"failed to process cluster event (put-lifecycle-metricbeat-7.2.0) within 30s"}],"type":"process\_cluster\_event\_timeout\_exception","reason":"failed to process cluster event (put-lifecycle-metricbeat-7.2.0) within 30s"},"status":503}"}

the error suggest that the metricbeat cannot connect to elasticsearch/kibana, but if I try from the same host a wget to that url I get the following response:

{  
"name" : "elasticsearch-server-hostname",  
"cluster\_name" : "logging-prod",  
"cluster\_uuid" : "dJpkSiwlTj-QN2KGIcaTpQ",  
"version" : {  
"number" : "7.2.0",  
"build\_flavor" : "default",  
"build\_type" : "rpm",  
"build\_hash" : "508c38a",  
"build\_date" : "2019-06-20T15:54:18.811730Z",  
"build\_snapshot" : false,  
"lucene\_version" : "8.0.0",  
"minimum\_wire\_compatibility\_version" : "6.8.0",  
"minimum\_index\_compatibility\_version" : "6.0.0-beta1"  
},  
"tagline" : "You Know, for Search"  
}

What could be the problem?

Thank you

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 23, 2019, 12:47am UTC](https://discuss.elastic.co/t/metricbeat-fail-with-the-error-failed-to-process-cluster-event-put-lifecycle-metricbeat-7-2-0-within-30s/192340/2 "2019-08-23T00:47:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
