# Metricbeat failed to start on linux

**URL:** https://discuss.elastic.co/t/metricbeat-failed-to-start-on-linux/127410
**Category:** Beats
**Tags:** metricbeat
**Created:** [April 10, 2018, 3:30am UTC](https://discuss.elastic.co/t/metricbeat-failed-to-start-on-linux/127410 "2018-04-10T03:30:12Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Timotius\_Pamungkas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timotius_pamungkas/32/42522_2.png) [@Timotius\_Pamungkas](https://discuss.elastic.co/u/Timotius_Pamungkas)
#### Post date: [April 10, 2018, 3:30am UTC](https://discuss.elastic.co/t/metricbeat-failed-to-start-on-linux/127410/1 "2018-04-10T03:30:12Z")

</div>

I can's start metricbeat service on linux. I'm following the guides on [https://www.elastic.co/guide/en/beats/metricbeat/current/metricbeat-starting.html](https://www.elastic.co/guide/en/beats/metricbeat/current/metricbeat-starting.html)  
But when starting metricbeat, it shows following error:

```auto
$ sudo service metricbeat start
Starting metricbeat (via systemctl): [OK]
$ sudo service metricbeat status
● metricbeat.service - metricbeat
   Loaded: loaded (/usr/lib/systemd/system/metricbeat.service; disabled; vendor preset: disabled)
   Active: failed (Result: start-limit) since Tue 2018-04-10 10:13:47 WIB; 2s ago
     Docs: https://www.elastic.co/guide/en/beats/metricbeat/current/index.html
  Process: 2512 ExecStart=/usr/share/metricbeat/bin/metricbeat -c /etc/metricbeat/metricbeat.yml -path.home /usr/share/metricbeat -path.config /etc/metricbeat -path.data /var/lib/metricbeat -path.logs /var/log/metricbeat (code=exited, status=1/FAILURE)
 Main PID: 2512 (code=exited, status=1/FAILURE)

Apr 10 10:13:47 consul3.xyz.co.id systemd[1]: metricbeat.service: main proce...E
Apr 10 10:13:47 consul3.xyz.co.id systemd[1]: Unit metricbeat.service entere....
Apr 10 10:13:47 consul3.xyz.co.id systemd[1]: metricbeat.service failed.
Apr 10 10:13:47 consul3.xyz.co.id systemd[1]: metricbeat.service holdoff tim....
Apr 10 10:13:47 consul3.xyz.co.id systemd[1]: start request repeated too qui...e
Apr 10 10:13:47 consul3.xyz.co.id systemd[1]: Failed to start metricbeat.
Apr 10 10:13:47 consul3.xyz.co.id systemd[1]: Unit metricbeat.service entere....
Apr 10 10:13:47 consul3.xyz.co.id systemd[1]: metricbeat.service failed.
Hint: Some lines were ellipsized, use -l to show in full.

```

This is my metricbeat.yml

```auto
metricbeat.config.modules:
  path: ${path.config}/modules.d/*.yml
  reload.enabled: false

setup.template.settings:
  index.number_of_shards: 1
  index.codec: best_compression

metricbeat.modules:
- module: system
  metricsets:
    - cpu
    - filesystem
    - memory
    - network
    - process
    - uptime
  enabled: true
  period: 10s
  processes: ['.*']
  cpu_ticks: false

setup.kibana:
  host: "172.16.16.109:5601"

output.elasticsearch:
  hosts: ["172.16.16.109:9200"]

```

I can't find any error log on /etc/metricbeat. Maybe this is also related to file permission? I'm using debian 9

```auto
$ ls -altr
total 328
-rw-r--r--. 1 root root 47612 Mar 13 16:56 metricbeat.reference.yml
-rw-r--r--. 1 root root 254722 Mar 13 16:56 fields.yml
drwxr-xr-x. 166 root root 12288 Apr 10 09:48 ..
drwxr-xr-x. 3 root root 95 Apr 10 09:48 .
drwxr-xr-x. 2 root root 4096 Apr 10 09:48 modules.d
-rwxrwxrwx. 1 root root 5539 Apr 10 10:10 metricbeat.yml

```

Elasticsearch & Kibana using version 6.2.2, while metricbeat on 6.2.3, but I don't think that is the problem

Thank you

---

<div class="post-metadata">

### Author: ![Timotius\_Pamungkas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/timotius_pamungkas/32/42522_2.png) [@Timotius\_Pamungkas](https://discuss.elastic.co/u/Timotius_Pamungkas)
#### Post date: [April 10, 2018, 5:35am UTC](https://discuss.elastic.co/t/metricbeat-failed-to-start-on-linux/127410/2 "2018-04-10T05:35:31Z")

</div>

False alarm.... found the cause after do  
`$ sudo journalctl -u metricbeat`

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 8, 2018, 5:36am UTC](https://discuss.elastic.co/t/metricbeat-failed-to-start-on-linux/127410/3 "2018-05-08T05:36:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
