# Metricbeat failing to start - Non-existent WMI Counters

**URL:** <https://discuss.elastic.co/t/metricbeat-failing-to-start-non-existent-wmi-counters/118709>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [February 6, 2018, 8:09pm UTC](https://discuss.elastic.co/t/metricbeat-failing-to-start-non-existent-wmi-counters/118709 "2018-02-06T20:09:49Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![KRasekhi](https://avatars.discourse-cdn.com/v4/letter/k/85e7bf/32.png) [@KRasekhi](https://discuss.elastic.co/u/KRasekhi)\
**Post date:** [February 6, 2018, 8:09pm UTC](https://discuss.elastic.co/t/metricbeat-failing-to-start-non-existent-wmi-counters/118709/1 "2018-02-06T20:09:49Z")

</div>

Hi,

Having issues with the current version of metricbeat stopping/failing to start when a WMI counter defined in the windows.yml does not exist. I noticed in Issue 3828 ([https://github.com/elastic/beats/issues/3828](https://github.com/elastic/beats/issues/3828)) there was an enhancement for 'Add config option to ignore failures for non-existent counters'. Is this still being considered for a future release?

Thanks!

---

<div class="post-metadata">

**Author:** ![kvch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvch/32/72058_2.png) [@kvch](https://discuss.elastic.co/u/kvch)\
**Post date:** [February 7, 2018, 10:21am UTC](https://discuss.elastic.co/t/metricbeat-failing-to-start-non-existent-wmi-counters/118709/2 "2018-02-07T10:21:06Z")

</div>

I am sorry you are facing this known problem. Unfortunately, the fix is not planned to be in the next release. Do you mind commenting on the issue, so we know that multiple users are having this problem?

---

<div class="post-metadata">

**Author:** ![KRasekhi](https://avatars.discourse-cdn.com/v4/letter/k/85e7bf/32.png) [@KRasekhi](https://discuss.elastic.co/u/KRasekhi)\
**Post date:** [February 7, 2018, 7:50pm UTC](https://discuss.elastic.co/t/metricbeat-failing-to-start-non-existent-wmi-counters/118709/3 "2018-02-07T19:50:56Z")

</div>

Thanks! posted a comment on the issue.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 7, 2018, 7:50pm UTC](https://discuss.elastic.co/t/metricbeat-failing-to-start-non-existent-wmi-counters/118709/4 "2018-03-07T19:50:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
