# Metricbeat: Not able to display the data in dashboard

**URL:** <https://discuss.elastic.co/t/metricbeat-not-able-to-display-the-data-in-dashboard/131470>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [May 11, 2018, 11:51am UTC](https://discuss.elastic.co/t/metricbeat-not-able-to-display-the-data-in-dashboard/131470 "2018-05-11T11:51:04Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![rahulnama](https://avatars.discourse-cdn.com/v4/letter/r/8c91f0/32.png) [@rahulnama](https://discuss.elastic.co/u/rahulnama)\
**Post date:** [May 11, 2018, 11:51am UTC](https://discuss.elastic.co/t/metricbeat-not-able-to-display-the-data-in-dashboard/131470/1 "2018-05-11T11:51:04Z")

</div>

Hello Team

on the Immediate requirement, I've installed metricbeat.  
I followed the getting started guide. Everything was fine but I'm not able to visualise the data in the dashboard. you can see below

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/5/e/5eab0f88743063036395ceb65c2928638683d229.png)

Metricbeat.yml file

```
`
metricbeat.config.modules:
  # Glob pattern for configuration loading
  path: ${path.config}/modules.d/*.yml

  # Set to true to enable config reloading
  reload.enabled: false

  # Period on which files under path should be checked for changes
  #reload.period: 10s

#==================== Elasticsearch template setting ==========================

setup.template.settings:
  index.number_of_shards: 1
  index.codec: best_compression
tags: ["service-X", "web-tier"]

# Optional fields that you can specify to add additional information to the
# output.
fields:
  env: staging

#============================== Kibana =====================================

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.
# This requires a Kibana endpoint configuration.
setup.kibana:

  # Kibana Host
  # Scheme and port can be left out and will be set to the default (http and 5601)
  # In case you specify and additional path, the scheme is required: http://localhost:5601/path
  # IPv6 addresses should always be defined as: https://[2001:db8::1]:5601
  host: "localhost:5601"

#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
  # Array of hosts to connect to.
  hosts: ["localhost:9200"]

  # Optional protocol and basic auth credentials.
  #protocol: "https"
  #username: "elastic"
  #password: "changeme"

#================================ Logging =====================================

logging.level: info
logging.to_files: true
logging.files:
  path: /var/log/metricbeat
  name: metricbeat
  keepfiles: 7
  permissions: 0644

# Sets log level. The default log level is info.
# Available log levels are: error, warning, info, debug
logging.level: debug

# At debug level, you can selectively enable logging only for some components.
# To enable all selectors use ["*"]. Examples of other selectors are "beat",
# "publish", "service".
#logging.selectors: ["*"]

#============================== Xpack Monitoring ===============================
# metricbeat can export internal metrics to a central Elasticsearch monitoring
# cluster. This requires xpack monitoring to be enabled in Elasticsearch. The
# reporting is disabled by default.

# Set to true to enable the monitoring reporter.
xpack.monitoring.enabled: true

# Uncomment to send the metrics to Elasticsearch. Most settings from the
# Elasticsearch output are accepted here as well. Any setting that is not set is
# automatically inherited from the Elasticsearch output configuration, so if you
# have the Elasticsearch output configured, you can simply uncomment the
# following line.
xpack.monitoring.elasticsearch:`

```

I'm using metricbeat system module

> ```
> - module: system
> 
> ```
> 
> period: 10s  
> metricsets:  
> - cpu  
> #- load  
> - memory  
> - network  
> - process  
> - process\_summary  
> - core  
> - diskio
> 
> # - socket
> 
> processes: ['.\*']  
> process.include\_top\_n:  
> by\_cpu: 5 # include top 5 processes by CPU  
> by\_memory: 5 # include top 5 processes by memory

I'm not sure where I went wrong. Please do suggest

Thanks for your time as always 🙂

---

<div class="post-metadata">

**Author:** ![kvch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kvch/32/72058_2.png) [@kvch](https://discuss.elastic.co/u/kvch)\
**Post date:** [May 11, 2018, 11:52am UTC](https://discuss.elastic.co/t/metricbeat-not-able-to-display-the-data-in-dashboard/131470/2 "2018-05-11T11:52:16Z")

</div>

Could you please format the configuration and also attach the debug logs of your instance?

---

<div class="post-metadata">

**Author:** ![rahulnama](https://avatars.discourse-cdn.com/v4/letter/r/8c91f0/32.png) [@rahulnama](https://discuss.elastic.co/u/rahulnama)\
**Post date:** [May 11, 2018, 11:55am UTC](https://discuss.elastic.co/t/metricbeat-not-able-to-display-the-data-in-dashboard/131470/3 "2018-05-11T11:55:18Z")

</div>

Hello @kvch

```
  2018-05-11T11:53:13.957Z	INFO	[monitoring]	log/log.go:124	Non-zero metrics in the last 30s	{"monitoring": {"metrics": {"beat":{"cpu":{"system":{"ticks":14218,"time":14218},"total":{"ticks":22936,"time":22936,"value":22936},"user":{"ticks":8718,"time":8718}},"info":{"ephemeral_id":"58ffdbb6-371a-4d93-85e0-641317a37ee7","uptime":{"ms":3660857}},"memstats":{"gc_next":4917760,"memory_alloc":2983400,"memory_total":527969816,"rss":-159744}},"libbeat":{"config":{"module":{"running":1}},"output":{"events":{"acked":54,"batches":9,"total":54},"read":{"bytes":3375},"write":{"bytes":50860}},"pipeline":{"clients":2,"events":{"active":1,"published":54,"total":54},"queue":{"acked":54}}},"metricbeat":{"system":{"core":{"events":6,"success":6},"cpu":{"events":3,"success":3},"diskio":{"events":3,"success":3},"memory":{"events":3,"success":3},"network":{"events":12,"success":12},"process":{"events":24,"success":24},"process_summary":{"events":3,"success":3}}},"xpack":{"monitoring":{"pipeline":{"events":{"published":3,"total":3},"queue":{"acked":3}}}}}}}
    2018-05-11T11:53:13.961Z	DEBUG	[publish]	pipeline/processor.go:275	Publish event: {
      "@timestamp": "2018-05-11T11:53:13.961Z",
      "@metadata": {
        "beat": "metricbeat",
        "type": "doc",
        "version": "6.2.4"
      },
      "beat": {
        "uuid": "ca7b8936-2449-470d-87ac-89772ed1fb12",
        "type": "metricbeat",
        "version": "6.2.4",
        "name": "EC2AMAZ-1763048",
        "host": "EC2AMAZ-1763048"
      },
      "metrics": {
        "libbeat": {
          "pipeline": {
            "events": {
              "failed": 0,
              "dropped": 0,
              "retry": 9,
              "active": 1,
              "total": 6538,
              "filtered": 0,
              "published": 6538
            },
            "queue": {
              "acked": 6537
            },
            "clients": 2
          },
          "config": {
            "module": {
              "running": 1,
              "starts": 1,
              "stops": 0
            },
            "reloads": 1
          },
          "output": {
            "read": {
              "bytes": 408625,
              "errors": 0
            },
            "type": "elasticsearch",
            "events": {
              "duplicates": 0,
              "active": 0,
              "batches": 1085,
              "total": 6537,
              "acked": 6537,
              "failed": 0,
              "dropped": 0
            },
            "write": {
              "bytes": 6039758,
              "errors": 0
            }
          }
        },
        "system": {
          "cpu": {
            "cores": 2
          }
        },
        "beat": {
          "cpu": {
            "user": {
              "time": 8718,
              "ticks": 8718
            },
            "system": {
              "ticks": 14218,
              "time": 14218
            },
            "total": {
              "value": 22936,
              "ticks": 22936,
              "time": 22936
            }
          },
          "info": {
            "uptime": {
              "ms": 3660861
            },
            "ephemeral_id": "58ffdbb6-371a-4d93-85e0-641317a37ee7"
          },
          "memstats": {
            "memory_total": 528033512,
            "memory_alloc": 3047096,
            "gc_next": 4917760,
            "rss": 33067008
          }
        },
        "xpack": {
          "monitoring": {
            "pipeline": {
              "clients": 1,
              "events": {
                "dropped": 0,
                "retry": 1,
                "active": 0,
                "total": 365,
                "filtered": 0,
                "published": 365,
                "failed": 0
              },
              "queue": {
                "acked": 365
              }
            }
          }
        },
        "metricbeat": {
          "system": {
            "cpu": {
              "success": 365,
              "failures": 0,
              "events": 365
            },
            "memory": {
              "success": 365,
              "failures": 0,
              "events": 365
            },
            "network": {
              "success": 1460,
              "failures": 0,
              "events": 1460
            },
            "process": {
              "events": 2889,
              "success": 2889,
              "failures": 0
            },
            "process_summary": {
              "success": 365,
              "failures": 0,
              "events": 365
            },
            "core": {
              "success": 730,
              "failures": 0,
              "events": 730
            },
            "diskio": {
              "events": 364,
              "success": 364,
              "failures": 0
            }
          }
        }
      }
    }
```

---

<div class="post-metadata">

**Author:** ![rahulnama](https://avatars.discourse-cdn.com/v4/letter/r/8c91f0/32.png) [@rahulnama](https://discuss.elastic.co/u/rahulnama)\
**Post date:** [May 14, 2018, 5:01am UTC](https://discuss.elastic.co/t/metricbeat-not-able-to-display-the-data-in-dashboard/131470/4 "2018-05-14T05:01:09Z")

</div>

@kvch  
by any chance, if you have time, can you please look in to this?  
I hope this will help you. This is how I'm seeing data in Discover page of kibana  
**metricset: diskio**

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/6/2/629e0f6d58ebcef873fafacb3d74766f4ed96967.png)  
**metricset: network**  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/d/c/dc7a4f4878a681da74448589bf9bab771284e0f7.png)  
**metricset.name: process\_memory**  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/d/a/da6d394c37dc752b7cdc6638478a6ba742f33da7.png)  
**metricset.name: Memory**  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/c/1/c11bbdfbb054e75f2761f5566bed0e5fc251e085.png)  
**metricset.name: cpu**  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/8/2/8298b59f1294e03c74a5c1d8e15f83459a42daf2.png)

Rahul Nama

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 11, 2018, 5:01am UTC](https://discuss.elastic.co/t/metricbeat-not-able-to-display-the-data-in-dashboard/131470/5 "2018-06-11T05:01:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
