# Metricbeat not able to recognise AWS modules

**URL:** https://discuss.elastic.co/t/metricbeat-not-able-to-recognise-aws-modules/315661
**Category:** Beats
**Tags:** metricbeat
**Created:** [October 3, 2022, 7:34am UTC](https://discuss.elastic.co/t/metricbeat-not-able-to-recognise-aws-modules/315661 "2022-10-03T07:34:16Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![Hasnain\_Raza](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hasnain_raza/32/106225_2.png) [@Hasnain\_Raza](https://discuss.elastic.co/u/Hasnain_Raza)
#### Post date: [October 3, 2022, 7:34am UTC](https://discuss.elastic.co/t/metricbeat-not-able-to-recognise-aws-modules/315661/1 "2022-10-03T07:34:17Z")

</div>

Problem statement: Need to fetch logs from AWS resources ELB, cloudwatch, ecs etc. Need help in understanding the configs and why this error is coming.

Metricbeat returns error

Elastic version: 7.6.2

Exiting: 1 error: metricset 'aws/cloudwatch' not found

/etc/metricbeat/modules.d/aws.yml

```auto
- module: aws
  period: 1m
  metricsets:
    - elb
    - usage

- module: aws
  period: 5m
  metricsets:
    - cloudwatch
  metrics:
    - namespace: AWS/EC2
      #name: ["CPUUtilization", "DiskWriteOps"]
      tags.resource_type_filter: ec2:instance
      #dimensions:
      #statistic: ["Average", "Maximum"]
- module: aws
  period: 5m
  metricsets:
    - ebs
    - ec2
    - sns
    - sqs
    - rds
- module: aws
  period: 12h
  metricsets:
    - billing
  regions:
    - us-east-1
- module: aws
  period: 24h
  metricsets:
    - s3_daily_storage
    - s3_request
~                   

```

---

<div class="post-metadata">

### Author: ![ChrsMark](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chrsmark/32/55858_2.png) [@ChrsMark](https://discuss.elastic.co/u/ChrsMark)
#### Post date: [October 4, 2022, 6:55am UTC](https://discuss.elastic.co/t/metricbeat-not-able-to-recognise-aws-modules/315661/2 "2022-10-04T06:55:09Z")

</div>

Hey! Not sure what could be the issue here but your version is quite old. Could you try to upgrade to `7.17` maybe?

---

<div class="post-metadata">

### Author: ![Hasnain\_Raza](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hasnain_raza/32/106225_2.png) [@Hasnain\_Raza](https://discuss.elastic.co/u/Hasnain_Raza)
#### Post date: [October 4, 2022, 10:12am UTC](https://discuss.elastic.co/t/metricbeat-not-able-to-recognise-aws-modules/315661/3 "2022-10-04T10:12:27Z")

</div>

It's a possibility to upgrade, but how do I debug this? That's bugging me in production.

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [October 4, 2022, 10:34am UTC](https://discuss.elastic.co/t/metricbeat-not-able-to-recognise-aws-modules/315661/4 "2022-10-04T10:34:39Z")

</div>

What happens if you remove the commented out lines?

---

<div class="post-metadata">

### Author: ![ChrsMark](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chrsmark/32/55858_2.png) [@ChrsMark](https://discuss.elastic.co/u/ChrsMark)
#### Post date: [October 5, 2022, 7:17am UTC](https://discuss.elastic.co/t/metricbeat-not-able-to-recognise-aws-modules/315661/5 "2022-10-05T07:17:46Z")

</div>

There is a similar one with a suggestion available: [Metricbeat is getting failed when we enable aws metricbeat moulde - #3 by Kaiyan\_Sheng](https://discuss.elastic.co/t/metricbeat-is-getting-failed-when-we-enable-aws-metricbeat-moulde/315434/3)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [November 2, 2022, 7:18am UTC](https://discuss.elastic.co/t/metricbeat-not-able-to-recognise-aws-modules/315661/6 "2022-11-02T07:18:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
