# Metricbeat not sending data after recreating index

**URL:** <https://discuss.elastic.co/t/metricbeat-not-sending-data-after-recreating-index/257694>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [December 4, 2020, 7:37pm UTC](https://discuss.elastic.co/t/metricbeat-not-sending-data-after-recreating-index/257694 "2020-12-04T19:37:58Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![StilgarBF](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stilgarbf/32/80298_2.png) [@StilgarBF](https://discuss.elastic.co/u/StilgarBF)\
**Post date:** [December 4, 2020, 7:37pm UTC](https://discuss.elastic.co/t/metricbeat-not-sending-data-after-recreating-index/257694/1 "2020-12-04T19:37:58Z")

</div>

Hi,

tldr: I had metricbeats running but after deleting and recreating template and index, I see no data comming in.

I Have a remote host running elasticsearch and kibana in docker.  
Metricbeat with only module system was running smootly on the same host (no other hosts so far)

Then I activated the module docker butt saw no data coming in. (the docker dashboard was empty)  
So I searched and followed a hint here from the forum, to delete template and indices for metricbeat from devtools in kibana.  
I then added setup.template.overwrite: true to my metricbeat.yml, which indeed showed the template and index again in dev-tools.

But I get no data. (No result found) for all of the service-dashboards.  
There seems to be no docker data as well.  
my metricbeat.yml

```auto
  # Glob pattern for configuration loading
  path: ${path.config}/modules.d/*.yml

  # Set to true to enable config reloading
  reload.enabled: false
  
  setup.template.settings:
  index.number_of_shards: 1
  index.codec: best_compression
  #_source.enabled: false

  setup.dashboards.enabled: false
  setup.kibana:

  # Kibana Host
  host: "localhost:5601"

  output.elasticsearch:
  # Array of hosts to connect to.
    hosts: ["localhost:9200"]
  
  processors:
  - add_host_metadata: ~
  - add_cloud_metadata: ~
  - add_docker_metadata: ~
  - add_kubernetes_metadata: ~

```

what did I miss?

My goals would be to get the modules system and docker with their default dashboards to be available.  
Also Understanding what went wrong would be great.

**update**  
disabling module docker again leads to data being delivered again. So its something with the config. Logs do not show anything. - the logfile has no error and syslog shows:

```auto
● metricbeat.service - Metricbeat is a lightweight shipper for metrics.
     Loaded: loaded (/lib/systemd/system/metricbeat.service; disabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Sat 2020-12-05 06:50:21 UTC; 42s ago
       Docs: https://www.elastic.co/products/beats/metricbeat
    Process: 92709 ExecStart=/usr/share/metricbeat/bin/metricbeat --environment systemd $BEAT_LOG_OPTS $BEAT_CONFIG_OPTS $BEAT_PATH_OPTS (code=exited, status=1/FAILURE)
   Main PID: 92709 (code=exited, status=1/FAILURE)

Dec 05 06:50:21 esprimo-q920 systemd[1]: metricbeat.service: Scheduled restart job, restart counter is at 5.
Dec 05 06:50:21 esprimo-q920 systemd[1]: Stopped Metricbeat is a lightweight shipper for metrics..
Dec 05 06:50:21 esprimo-q920 systemd[1]: metricbeat.service: Start request repeated too quickly.
Dec 05 06:50:21 esprimo-q920 systemd[1]: metricbeat.service: Failed with result 'exit-code'.
Dec 05 06:50:21 esprimo-q920 systemd[1]: Failed to start Metricbeat is a lightweight shipper for metrics..

```

which does not really help my

TY  
Stil

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 1, 2021, 9:38pm UTC](https://discuss.elastic.co/t/metricbeat-not-sending-data-after-recreating-index/257694/2 "2021-01-01T21:38:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
