# Metricbeat not working when elasticsearch is upgraded from 7.4.0 to 7.5.0

**URL:** https://discuss.elastic.co/t/metricbeat-not-working-when-elasticsearch-is-upgraded-from-7-4-0-to-7-5-0/210443
**Category:** Beats
**Tags:** metricbeat
**Created:** [December 4, 2019, 1:08am UTC](https://discuss.elastic.co/t/metricbeat-not-working-when-elasticsearch-is-upgraded-from-7-4-0-to-7-5-0/210443 "2019-12-04T01:08:26Z")
**Posts on this page:** 9
**Page:** 1

<div class="post-metadata">

### Author: ![sharmila.dev](https://avatars.discourse-cdn.com/v4/letter/s/c0e974/32.png) [@sharmila.dev](https://discuss.elastic.co/u/sharmila.dev)
#### Post date: [December 4, 2019, 1:08am UTC](https://discuss.elastic.co/t/metricbeat-not-working-when-elasticsearch-is-upgraded-from-7-4-0-to-7-5-0/210443/1 "2019-12-04T01:08:26Z")

</div>

Hi,  
Im unable to set up monitoring for elastic search using metricbeat. It was working with version 7.4.0 but broke when upgraded to 7.5.0. I was sending metrics using metricbeat to separate monitoring cluster. Metricbeat logs are not useful. Is there any place i can check to see why its not working? Below are metric beat configs

```auto
# This file is an example configuration file highlighting only the most common
# options. The metricbeat.reference.yml file from the same directory contains all the
# supported options with more comments. You can use it as a reference.
#
# You can find the full configuration reference here:
# https://www.elastic.co/guide/en/beats/metricbeat/index.html

#========================== Modules configuration ============================

metricbeat.config.modules:
  # Glob pattern for configuration loading
  path: ${path.config}/modules.d/*.yml

  # Set to true to enable config reloading
  reload.enabled: false

  # Period on which files under path should be checked for changes
  #reload.period: 10s

#==================== Elasticsearch template setting ==========================

setup.template.settings:
  index.number_of_shards: 1
  index.codec: best_compression
  #_source.enabled: false

#================================ General =====================================

# The name of the shipper that publishes the network data. It can be used to group
# all the transactions sent by a single shipper in the web interface.
#name:

# The tags of the shipper are included in their own field with each
# transaction published.
#tags: ["service-X", "web-tier"]

# Optional fields that you can specify to add additional information to the
# output.
#fields:
# env: staging

#============================== Dashboards =====================================
# These settings control loading the sample dashboards to the Kibana index. Loading
# the dashboards is disabled by default and can be enabled either by setting the
# options here or by using the `setup` command.
#setup.dashboards.enabled: false

# The URL from where to download the dashboards archive. By default this URL
# has a value which is computed based on the Beat name and version. For released
# versions, this URL points to the dashboard archive on the artifacts.elastic.co
# website.
#setup.dashboards.url:

#============================== Kibana =====================================

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.
# This requires a Kibana endpoint configuration.
setup.kibana:

# Kibana Host
# Scheme and port can be left out and will be set to the default (http and 5601)
# In case you specify and additional path, the scheme is required: http://localhost:5601/path
# IPv6 addresses should always be defined as: https://[2001:db8::1]:5601
#host: "localhost:5601"

# Kibana Space ID
# ID of the Kibana Space into which the dashboards should be loaded. By default,
# the Default Space will be used.
#space.id:

#============================= Elastic Cloud ==================================

# These settings simplify using Metricbeat with the Elastic Cloud (https://cloud.elastic.co/).

# The cloud.id setting overwrites the `output.elasticsearch.hosts` and
# `setup.kibana.host` options.
# You can find the `cloud.id` in the Elastic Cloud web UI.
#cloud.id:

# The cloud.auth setting overwrites the `output.elasticsearch.username` and
# `output.elasticsearch.password` settings. The format is `<user>:<pass>`.
#cloud.auth:

#================================ Outputs =====================================

# Configure what output to use when sending the data collected by the beat.

#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
  # Array of hosts to connect to.
  hosts: ['http://lx1176.mycompany.com', 'http://lx1177.mycompany.com']

  #----------------------------- Logstash output --------------------------------
  #output.logstash:
  # The Logstash hosts
  #hosts: ["localhost:5044"]

  # Optional SSL. By default is off.
  # List of root certificates for HTTPS server verifications

#================================ Processors =====================================

# Configure processors to enhance or manipulate events generated by the beat.

processors:
  - add_host_metadata: ~
  - add_cloud_metadata: ~

#================================ Logging =====================================

# Sets log level. The default log level is info.
# Available log levels are: error, warning, info, debug
#logging.level: debug

# At debug level, you can selectively enable logging only for some components.
# To enable all selectors use ["*"]. Examples of other selectors are "beat",
# "publish", "service".
#logging.selectors: ["*"]

#============================== X-Pack Monitoring ===============================
# metricbeat can export internal metrics to a central Elasticsearch monitoring
# cluster. This requires xpack monitoring to be enabled in Elasticsearch. The
# reporting is disabled by default.

# Set to true to enable the monitoring reporter.
#monitoring.enabled: false

# Sets the UUID of the Elasticsearch cluster under which monitoring data for this
# Metricbeat instance will appear in the Stack Monitoring UI. If output.elasticsearch
# is enabled, the UUID is derived from the Elasticsearch cluster referenced by output.elasticsearch.
#monitoring.cluster_uuid:

# Uncomment to send the metrics to Elasticsearch. Most settings from the
# Elasticsearch output are accepted here as well.
# Note that the settings should point to your Elasticsearch *monitoring* cluster.
# Any setting that is not set is automatically inherited from the Elasticsearch
# output configuration, so if you have the Elasticsearch output configured such
# that it is pointing to your Elasticsearch monitoring cluster, you can simply
# uncomment the following line.
#monitoring.elasticsearch:

#================================= Migration ==================================

# This allows to enable 6.7 migration aliases
#migration.6_to_7.enabled: true

```

```auto
- module: elasticsearch
  metricsets:
    - ccr
    - cluster_stats
    - index
    - index_recovery
    - index_summary
    - ml_job
    - node_stats
    - shard
  period: 10s
  hosts: ["https://localhost:9200"]
  username: "metricbeat_admin"
  password: *********
  xpack.enabled: true
  ssl.verification_mode: 'none'

```

---

<div class="post-metadata">

### Author: ![Kaiyan\_Sheng](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kaiyan_sheng/32/38247_2.png) [@Kaiyan\_Sheng](https://discuss.elastic.co/u/Kaiyan_Sheng)
#### Post date: [December 5, 2019, 5:28am UTC](https://discuss.elastic.co/t/metricbeat-not-working-when-elasticsearch-is-upgraded-from-7-4-0-to-7-5-0/210443/2 "2019-12-05T05:28:37Z")

</div>

Hi! Have you tried enabling debug level logs to see maybe if that will give more information?

```auto
logging.level: debug

```

---

<div class="post-metadata">

### Author: ![sharmila.dev](https://avatars.discourse-cdn.com/v4/letter/s/c0e974/32.png) [@sharmila.dev](https://discuss.elastic.co/u/sharmila.dev)
#### Post date: [December 5, 2019, 3:10pm UTC](https://discuss.elastic.co/t/metricbeat-not-working-when-elasticsearch-is-upgraded-from-7-4-0-to-7-5-0/210443/3 "2019-12-05T15:10:43Z")

</div>

Yes i did and this is what i see in metric beat log  
2019-12-05T09:56:51.100-0600 INFO instance/beat.go:610 Home path: [/usr/share/metricbeat] Config path: [/etc/metricbeat] Data path: [/var/lib/metricbeat] Logs path: [/var/log/metricbeat]  
2019-12-05T09:56:51.101-0600 DEBUG [beat] instance/beat.go:662 Beat metadata path: /var/lib/metricbeat/meta.json  
2019-12-05T09:56:51.102-0600 INFO instance/beat.go:618 Beat ID: 6d10a960-0343-42fd-9c1c-366967b0231c  
2019-12-05T09:56:51.105-0600 DEBUG [filters] add\_cloud\_metadata/providers.go:126 add\_cloud\_metadata: starting to fetch metadata, timeout=3s  
2019-12-05T09:56:51.192-0600 DEBUG [filters] add\_cloud\_metadata/providers.go:162 add\_cloud\_metadata: received disposition for az after 86.61406ms. result=[provider:az, error=failed with http status code 404, metadata={}]  
2019-12-05T09:56:51.199-0600 DEBUG [filters] add\_cloud\_metadata/providers.go:162 add\_cloud\_metadata: received disposition for openstack after 93.876122ms. result=[provider:openstack, error=failed with http status code 404, metadata={}]  
2019-12-05T09:56:51.201-0600 DEBUG [filters] add\_cloud\_metadata/providers.go:162 add\_cloud\_metadata: received disposition for digitalocean after 95.401323ms. result=[provider:digitalocean, error=failed with http status code 404, metadata={}]  
2019-12-05T09:56:51.203-0600 DEBUG [filters] add\_cloud\_metadata/providers.go:162 add\_cloud\_metadata: received disposition for aws after 97.989474ms. result=[provider:aws, error=failed with http status code 404, metadata={}]  
2019-12-05T09:56:52.249-0600 DEBUG [filters] add\_cloud\_metadata/providers.go:162 add\_cloud\_metadata: received disposition for gcp after 1.143497503s. result=[provider:gcp, error=failed with http status code 404, metadata={}]  
2019-12-05T09:56:52.249-0600 DEBUG [filters] add\_cloud\_metadata/providers.go:129 add\_cloud\_metadata: fetchMetadata ran for 1.143588299s  
2019-12-05T09:56:52.249-0600 INFO add\_cloud\_metadata/add\_cloud\_metadata.go:89 add\_cloud\_metadata: hosting provider type not detected.  
2019-12-05T09:56:52.249-0600 DEBUG [processors] processors/processor.go:101 Generated new processors: add\_host\_metadata=[netinfo.enabled=[false], cache.ttl=[5m0s]], add\_cloud\_metadata=null

---

<div class="post-metadata">

### Author: ![sharmila.dev](https://avatars.discourse-cdn.com/v4/letter/s/c0e974/32.png) [@sharmila.dev](https://discuss.elastic.co/u/sharmila.dev)
#### Post date: [December 5, 2019, 3:14pm UTC](https://discuss.elastic.co/t/metricbeat-not-working-when-elasticsearch-is-upgraded-from-7-4-0-to-7-5-0/210443/4 "2019-12-05T15:14:44Z")

</div>

This is what i see when i test the metricbeat config

2019-12-05T10:08:19.829-0600 INFO instance/beat.go:610 Home path: [/usr/share/metricbeat/bin] Config path: [/usr/share/metricbeat/bin] Data path: [/usr/share/metricbeat/bin/data] Logs path: [/usr/share/metricbeat/bin/logs]  
2019-12-05T10:08:19.830-0600 DEBUG [beat] instance/beat.go:662 Beat metadata path: /usr/share/metricbeat/bin/data/meta.json  
2019-12-05T10:08:19.830-0600 INFO instance/beat.go:618 Beat ID: 359b575b-7dbb-43e1-a810-5b2df43d7174  
2019-12-05T10:08:19.833-0600 DEBUG [filters] add\_cloud\_metadata/providers.go:126 add\_cloud\_metadata: starting to fetch metadata, timeout=3s  
2019-12-05T10:08:19.906-0600 DEBUG [filters] add\_cloud\_metadata/providers.go:162 add\_cloud\_metadata: received disposition for digitalocean after 72.814396ms. result=[provider:digitalocean, error=failed with http status code 404, metadata={}]  
2019-12-05T10:08:19.924-0600 DEBUG [filters] add\_cloud\_metadata/providers.go:162 add\_cloud\_metadata: received disposition for gcp after 90.579477ms. result=[provider:gcp, error=failed with http status code 404, metadata={}]  
2019-12-05T10:08:20.901-0600 DEBUG [filters] add\_cloud\_metadata/providers.go:162 add\_cloud\_metadata: received disposition for az after 1.067353419s. result=[provider:az, error=failed with http status code 404, metadata={}]  
2019-12-05T10:08:20.903-0600 DEBUG [filters] add\_cloud\_metadata/providers.go:162 add\_cloud\_metadata: received disposition for openstack after 1.069339639s. result=[provider:openstack, error=failed with http status code 404, metadata={}]  
2019-12-05T10:08:20.904-0600 DEBUG [filters] add\_cloud\_metadata/providers.go:162 add\_cloud\_metadata: received disposition for aws after 1.070892154s. result=[provider:aws, error=failed with http status code 404, metadata={}]  
2019-12-05T10:08:20.904-0600 DEBUG [filters] add\_cloud\_metadata/providers.go:129 add\_cloud\_metadata: fetchMetadata ran for 1.070925886s  
2019-12-05T10:08:20.904-0600 INFO add\_cloud\_metadata/add\_cloud\_metadata.go:89 add\_cloud\_metadata: hosting provider type not detected.  
2019-12-05T10:08:20.904-0600 DEBUG [processors] processors/processor.go:101 Generated new processors: add\_host\_metadata=[netinfo.enabled=[false], cache.ttl=[5m0s]], add\_cloud\_metadata=null  
2019-12-05T10:08:20.904-0600 INFO [beat] instance/beat.go:941 Beat info {"system\_info": {"beat": {"path": {"config": "/usr/share/metricbeat/bin", "data": "/usr/share/metricbeat/bin/data", "home": "/usr/share/metricbeat/bin", "logs": "/usr/share/metricbeat/bin/logs"}, "type": "metricbeat", "uuid": "359b575b-7dbb-43e1-a810-5b2df43d7174"}}}  
2019-12-05T10:08:20.904-0600 INFO [beat] instance/beat.go:950 Build info {"system\_info": {"build": {"commit": "6d0d0ae079e5cb1d4f224801ac6df926dfb1594c", "libbeat": "7.5.0", "time": "2019-11-26T00:09:41.000Z", "version": "7.5.0"}}}  
2019-12-05T10:08:20.904-0600 INFO [beat] instance/beat.go:953 Go runtime info {"system\_info": {"go": {"os":"linux","arch":"amd64","max\_procs":4,"version":"go1.12.12"}}}  
2019-12-05T10:08:20.905-0600 INFO [beat] instance/beat.go:957 Host info {"system\_info": {"host": {"architecture":"x86\_64","boot\_time":"2019-11-27T11:17:14-06:00","containerized":false,"name":"lx1171","ip":["127.0.0.1/8","::1/128","10.58.71.2/19","fe80::250:56ff:fe9f:8e43/64"],"kernel\_version":"3.10.0-1062.4.3.el7.x86\_64","mac":["00:50:56:9f:8e:43"],"os":{"family":"redhat","platform":"centos","name":"CentOS Linux","version":"7 (Core)","major":7,"minor":7,"patch":1908,"codename":"Core"},"timezone":"CST","timezone\_offset\_sec":-21600,"id":"b2774b3f7bbd4451b36d89c0951bc166"}}}  
2019-12-05T10:08:20.906-0600 INFO [beat] instance/beat.go:986 Process info {"system\_info": {"process": {"capabilities": {"inheritable":null,"permitted":["chown","dac\_override","dac\_read\_search","fowner","fsetid","kill","setgid","setuid","setpcap","linux\_immutable","net\_bind\_service","net\_broadcast","net\_admin","net\_raw","ipc\_lock","ipc\_owner","sys\_module","sys\_rawio","sys\_chroot","sys\_ptrace","sys\_pacct","sys\_admin","sys\_boot","sys\_nice","sys\_resource","sys\_time","sys\_tty\_config","mknod","lease","audit\_write","audit\_control","setfcap","mac\_override","mac\_admin","syslog","wake\_alarm","block\_suspend"],"effective":["chown","dac\_override","dac\_read\_search","fowner","fsetid","kill","setgid","setuid","setpcap","linux\_immutable","net\_bind\_service","net\_broadcast","net\_admin","net\_raw","ipc\_lock","ipc\_owner","sys\_module","sys\_rawio","sys\_chroot","sys\_ptrace","sys\_pacct","sys\_admin","sys\_boot","sys\_nice","sys\_resource","sys\_time","sys\_tty\_config","mknod","lease","audit\_write","audit\_control","setfcap","mac\_override","mac\_admin","syslog","wake\_alarm","block\_suspend"],"bounding":["chown","dac\_override","dac\_read\_search","fowner","fsetid","kill","setgid","setuid","setpcap","linux\_immutable","net\_bind\_service","net\_broadcast","net\_admin","net\_raw","ipc\_lock","ipc\_owner","sys\_module","sys\_rawio","sys\_chroot","sys\_ptrace","sys\_pacct","sys\_admin","sys\_boot","sys\_nice","sys\_resource","sys\_time","sys\_tty\_config","mknod","lease","audit\_write","audit\_control","setfcap","mac\_override","mac\_admin","syslog","wake\_alarm","block\_suspend"],"ambient":null}, "cwd": "/usr/share/metricbeat/bin", "exe": "/usr/share/metricbeat/bin/metricbeat", "name": "metricbeat", "pid": 91285, "ppid": 91275, "seccomp": {"mode":"disabled","no\_new\_privs":false}, "start\_time": "2019-12-05T10:08:19.370-0600"}}}  
2019-12-05T10:08:20.906-0600 INFO instance/beat.go:297 Setup Beat: metricbeat; Version: 7.5.0  
2019-12-05T10:08:20.906-0600 DEBUG [beat] instance/beat.go:323 Initializing output plugins  
2019-12-05T10:08:20.906-0600 INFO [index-management] idxmgmt/std.go:182 Set output.elasticsearch.index to 'metricbeat-7.5.0' as ILM is enabled.  
2019-12-05T10:08:20.906-0600 INFO elasticsearch/client.go:171 Elasticsearch url: [http://lx1176.mycompany.com:9200](http://lx1176.mycompany.com:9200)  
2019-12-05T10:08:20.906-0600 INFO elasticsearch/client.go:171 Elasticsearch url: [http://lx1177.mycompany.com:9200](http://lx1177.mycompany.com:9200)  
2019-12-05T10:08:20.906-0600 DEBUG [publisher] pipeline/consumer.go:137 start pipeline event consumer  
2019-12-05T10:08:20.907-0600 INFO [publisher] pipeline/module.go:97 Beat name: lx1171  
2019-12-05T10:08:20.907-0600 DEBUG [modules] beater/metricbeat.go:121 Available modules and metricsets: Register [ModuleFactory:[aws, azure, beat, docker, elasticsearch, kibana, logstash, mongodb, mssql, mysql, oracle, postgresql, system, uwsgi], MetricSetFactory:[aerospike/namespace, apache/status, appsearch/stats, aws/cloudwatch, aws/ec2, aws/rds, aws/s3\_daily\_storage, aws/s3\_request, aws/sqs, azure/compute\_vm, azure/compute\_vm\_scaleset, azure/monitor, beat/state, beat/stats, ceph/cluster\_disk, ceph/cluster\_health, ceph/cluster\_status, ceph/monitor\_health, ceph/osd\_df, ceph/osd\_tree, ceph/pool\_disk, consul/agent, coredns/stats, couchbase/bucket, couchbase/cluster, couchbase/node, couchdb/server, docker/container, docker/cpu, docker/diskio, docker/event, docker/healthcheck, docker/image, docker/info, docker/memory, docker/network, dropwizard/collector, elasticsearch/ccr, elasticsearch/cluster\_stats, elasticsearch/enrich, elasticsearch/index, elasticsearch/index\_recovery, elasticsearch/index\_summary, elasticsearch/ml\_job, elasticsearch/node, elasticsearch/node\_stats, elasticsearch/pending\_tasks, elasticsearch/shard, envoyproxy/server, etcd/leader, etcd/metrics, etcd/self, etcd/store, golang/expvar, golang/heap, graphite/server, haproxy/info, haproxy/stat, http/json, http/server, jolokia/jmx, kafka/consumergroup, kafka/partition, kibana/stats, kibana/status, kubernetes/apiserver, kubernetes/container, kubernetes/controllermanager, kubernetes/event, kubernetes/node, kubernetes/pod, kubernetes/proxy, kubernetes/scheduler, kubernetes/state\_container, kubernetes/state\_cronjob, kubernetes/state\_deployment, kubernetes/state\_node, kubernetes/state\_pod, kubernetes/state\_replicaset, kubernetes/state\_resourcequota, kubernetes/state\_statefulset, kubernetes/system, kubernetes/volume, kvm/dommemstat, logstash/node, logstash/node\_stats, memcached/stats, mongodb/collstats, mongodb/dbstats, mongodb/metrics, mongodb/replstatus, mongodb/status, mssql/performance, mssql/transaction\_log, munin/node, mysql/galera\_status, mysql/status, nats/connections, nats/routes, nats/stats, nats/subscriptions, nginx/stubstatus, oracle/performance, oracle/tablespace, php\_fpm/pool, php\_fpm/process, postgresql/activity, postgresql/bgwriter, postgresql/database, postgresql/statement, prometheus/collector, rabbitmq/connection, rabbitmq/exchange, rabbitmq/node, rabbitmq/queue, redis/info, redis/key, redis/keyspace, statsd/server, system/core, system/cpu, system/diskio, system/entropy, system/filesystem, system/fsstat, system/load, system/memory, system/network, system/process, system/process\_summary, system/raid, system/socket, system/socket\_summary, system/uptime, traefik/health, uwsgi/status, vsphere/datastore, vsphere/host, vsphere/virtualmachine, zookeeper/connection, zookeeper/mntr, zookeeper/server], LightModules:]  
Config OK

---

<div class="post-metadata">

### Author: ![sharmila.dev](https://avatars.discourse-cdn.com/v4/letter/s/c0e974/32.png) [@sharmila.dev](https://discuss.elastic.co/u/sharmila.dev)
#### Post date: [December 10, 2019, 7:29pm UTC](https://discuss.elastic.co/t/metricbeat-not-working-when-elasticsearch-is-upgraded-from-7-4-0-to-7-5-0/210443/5 "2019-12-10T19:29:31Z")

</div>

Hi @Kaiyan_Sheng any thoughts on why metricbeat 7.5 is not collecting metrics? I dont see any errors in the logs. I tried all the troubleshooting steps but still not able to identify. Any help is greatly appreciated. Thanks!

---

<div class="post-metadata">

### Author: ![tahseen\_fatima](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tahseen_fatima/32/67789_2.png) [@tahseen\_fatima](https://discuss.elastic.co/u/tahseen_fatima)
#### Post date: [December 11, 2019, 6:43am UTC](https://discuss.elastic.co/t/metricbeat-not-working-when-elasticsearch-is-upgraded-from-7-4-0-to-7-5-0/210443/6 "2019-12-11T06:43:16Z")

</div>

Hey  
I am getting the same error but in Filebeat. Can some one please guide us.

Thanks,  
Tahseen

---

<div class="post-metadata">

### Author: ![sharmila.dev](https://avatars.discourse-cdn.com/v4/letter/s/c0e974/32.png) [@sharmila.dev](https://discuss.elastic.co/u/sharmila.dev)
#### Post date: [December 11, 2019, 4:11pm UTC](https://discuss.elastic.co/t/metricbeat-not-working-when-elasticsearch-is-upgraded-from-7-4-0-to-7-5-0/210443/7 "2019-12-11T16:11:45Z")

</div>

I finally got this working in case anyone is facing the same issue.The logs obviously didn't print the error i was getting. So i ran the command `journalctl -u metricbeat` and it had the exception  
`Exiting: The elasticsearch module with xpack.enabled: true must have metricsets: [ccr enrich cluster_stats index index_recovery index_summary ml_job node_stats shard]`. I was missing the metric set `enrich` which didn't casue an issue with 7.4 but stopped working when upgraded to 7.5. So adding that metric set did fix the issue.

---

<div class="post-metadata">

### Author: ![tahseen\_fatima](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tahseen_fatima/32/67789_2.png) [@tahseen\_fatima](https://discuss.elastic.co/u/tahseen_fatima)
#### Post date: [December 11, 2019, 4:16pm UTC](https://discuss.elastic.co/t/metricbeat-not-working-when-elasticsearch-is-upgraded-from-7-4-0-to-7-5-0/210443/8 "2019-12-11T16:16:58Z")

</div>

Error Solved.  
I also solved my error.  
It was not giving any logs because system module was not enabled.  
So I enable the system module and run it again. I was able to see the output in kibana.

Thanks,  
Tahseen

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 8, 2020, 4:17pm UTC](https://discuss.elastic.co/t/metricbeat-not-working-when-elasticsearch-is-upgraded-from-7-4-0-to-7-5-0/210443/9 "2020-01-08T16:17:18Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
