# Metricbeat service error : Stopped Metricbeat is a lightweight shipper for metrics

**URL:** <https://discuss.elastic.co/t/metricbeat-service-error-stopped-metricbeat-is-a-lightweight-shipper-for-metrics/193315>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [August 1, 2019, 12:10pm UTC](https://discuss.elastic.co/t/metricbeat-service-error-stopped-metricbeat-is-a-lightweight-shipper-for-metrics/193315 "2019-08-01T12:10:32Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![abhijalan87](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/abhijalan87/32/51424_2.png) [@abhijalan87](https://discuss.elastic.co/u/abhijalan87)\
**Post date:** [August 1, 2019, 12:10pm UTC](https://discuss.elastic.co/t/metricbeat-service-error-stopped-metricbeat-is-a-lightweight-shipper-for-metrics/193315/1 "2019-08-01T12:10:33Z")

</div>

Hello Everyone,

any idea about the below error?  
when I try to start metricbeat service, I am getting below error.

systemctl status metricbeat  
● metricbeat.service - Metricbeat is a lightweight shipper for metrics.  
Loaded: loaded (/usr/lib/systemd/system/metricbeat.service; enabled; vendor preset: disabled)  
Active: failed (Result: start-limit) since Thu 2019-08-01 09:33:46 UTC; 2h 33min ago  
Docs: [https://www.elastic.co/products/beats/metricbeat](https://www.elastic.co/products/beats/metricbeat)  
Process: 14976 ExecStart=/usr/share/metricbeat/bin/metricbeat $BEAT\_LOG\_OPTS $BEAT\_CONFIG\_OPTS $BEAT\_PATH\_OPTS (code=exited, status=1/FAILURE)  
Main PID: 14976 (code=exited, status=1/FAILURE)

Aug 01 09:33:46 stg-logstash01.local systemd[1]: metricbeat.service: main process exited, code=exited, status=1/FAILURE  
Aug 01 09:33:46 stg-logstash01.local systemd[1]: Unit metricbeat.service entered failed state.  
Aug 01 09:33:46 stg-logstash01.local systemd[1]: metricbeat.service failed.  
Aug 01 09:33:46 stg-logstash01.local systemd[1]: metricbeat.service holdoff time over, scheduling restart.  
Aug 01 09:33:46 stg-logstash01.local systemd[1]: Stopped Metricbeat is a lightweight shipper for metrics..  
Aug 01 09:33:46 stg-logstash01.local systemd[1]: start request repeated too quickly for metricbeat.service  
Aug 01 09:33:46 stg-logstash01.local systemd[1]: Failed to start Metricbeat is a lightweight shipper for metrics..  
Aug 01 09:33:46 stg-logstash01.local systemd[1]: Unit metricbeat.service entered failed state.  
Aug 01 09:33:46 stg-logstash01.local systemd[1]: metricbeat.service failed.

[root~]# tail -f /var/log/metricbeat/metricbeat  
2019-08-01T07:44:02.456Z INFO [index-management] idxmgmt/std.go:178 Set output.elasticsearch.index to 'metricbeat-7.3.0' as ILM is enabled.  
2019-08-01T07:44:02.457Z INFO elasticsearch/client.go:170 Elasticsearch url: [http://192.168.0.100:9200](http://192.168.0.100:9200)  
2019-08-01T07:44:02.457Z INFO [publisher] pipeline/module.go:97 Beat name: localhost  
2019-08-01T07:44:02.458Z INFO instance/beat.go:421 metricbeat start running.  
2019-08-01T07:44:02.460Z INFO [monitoring] log/log.go:118 Starting metrics logging every 30s  
2019-08-01T07:44:02.462Z INFO [monitoring] log/log.go:153 Total non-zero metrics {"monitoring": {"metrics": {"beat":{"cpu":{"system":{"ticks":20,"time":{"ms":20}},"total":{"ticks":50,"time":{"ms":56},"value":50},"user":{"ticks":30,"time":{"ms":36}}},"handles":{"limit":{"hard":4096,"soft":1024},"open":13},"info":{"ephemeral\_id":"9b45f6c3-884b-4a02-9f2c-991f289eec4c","uptime":{"ms":111}},"memstats":{"gc\_next":11340288,"memory\_alloc":6642416,"memory\_total":12856872,"rss":31956992},"runtime":{"goroutines":46}},"libbeat":{"config":{"module":{"running":0}},"output":{"type":"elasticsearch"},"pipeline":{"clients":0,"events":{"active":0}}},"system":{"cpu":{"cores":1},"load":{"1":0,"15":0.05,"5":0.02,"norm":{"1":0,"15":0.05,"5":0.02}}}}}}  
2019-08-01T07:44:02.462Z INFO [monitoring] log/log.go:154 Uptime: 111.70384ms  
2019-08-01T07:44:02.462Z INFO [monitoring] log/log.go:131 Stopping metrics logging.  
2019-08-01T07:44:02.462Z INFO instance/beat.go:431 metricbeat stopped.  
2019-08-01T07:44:02.476Z ERROR instance/beat.go:877 Exiting: empty field accessing '0.access\_key\_id' (source:'/etc/metricbeat/modules.d/aws.yml')

---

<div class="post-metadata">

**Author:** ![Alex\_Kristiansen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alex_kristiansen/32/46086_2.png) [@Alex\_Kristiansen](https://discuss.elastic.co/u/Alex_Kristiansen)\
**Post date:** [August 12, 2019, 6:48pm UTC](https://discuss.elastic.co/t/metricbeat-service-error-stopped-metricbeat-is-a-lightweight-shipper-for-metrics/193315/2 "2019-08-12T18:48:32Z")

</div>

It looks like there's a formatting error in your `aws.yml`

> [@abhijalan87](#):
>
> 2019-08-01T07:44:02.476Z ERROR instance/beat.go:877 Exiting: empty field accessing '0.access\_key\_id' (source:'/etc/metricbeat/modules.d/aws.yml')

---

<div class="post-metadata">

**Author:** ![abhijalan87](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/abhijalan87/32/51424_2.png) [@abhijalan87](https://discuss.elastic.co/u/abhijalan87)\
**Post date:** [August 24, 2019, 4:45pm UTC](https://discuss.elastic.co/t/metricbeat-service-error-stopped-metricbeat-is-a-lightweight-shipper-for-metrics/193315/3 "2019-08-24T16:45:59Z")

</div>

yeah I forgot to configure my aws.yml after adding secretkey/accesskey/region den its working fine 🙂 thanks for ur reply 🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 21, 2019, 4:46pm UTC](https://discuss.elastic.co/t/metricbeat-service-error-stopped-metricbeat-is-a-lightweight-shipper-for-metrics/193315/4 "2019-09-21T16:46:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
