# Metricbeat system overview dashboard is throwing a fieldata disabled error

**URL:** <https://discuss.elastic.co/t/metricbeat-system-overview-dashboard-is-throwing-a-fieldata-disabled-error/195805>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [August 19, 2019, 8:28pm UTC](https://discuss.elastic.co/t/metricbeat-system-overview-dashboard-is-throwing-a-fieldata-disabled-error/195805 "2019-08-19T20:28:24Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![zozo6015](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zozo6015/32/12117_2.png) [@zozo6015](https://discuss.elastic.co/u/zozo6015)\
**Post date:** [August 19, 2019, 8:28pm UTC](https://discuss.elastic.co/t/metricbeat-system-overview-dashboard-is-throwing-a-fieldata-disabled-error/195805/1 "2019-08-19T20:28:24Z")

</div>

Hello,

When I am browsing system overview dashboard I am getting the following error message:

[esaggs] \> Request to Elasticsearch failed: {"error":{"root\_cause":[{"type":"illegal\_argument\_exception","reason":"Fielddata is disabled on text fields by default. Set fielddata=true on [host.name] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead."}],"type":"search\_phase\_execution\_exception","reason":"all shards failed","phase":"query","grouped":true,"failed\_shards":[{"shard":0,"index":"metricbeat-7.3.0","node":"L2PyvYSZSw26PVQl0KGuNQ","reason":{"type":"illegal\_argument\_exception","reason":"Fielddata is disabled on text fields by default. Set fielddata=true on [host.name] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead."}}],"caused\_by":{"type":"illegal\_argument\_exception","reason":"Fielddata is disabled on text fields by default. Set fielddata=true on [host.name] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead.","caused\_by":{"type":"illegal\_argument\_exception","reason":"Fielddata is disabled on text fields by default. Set fielddata=true on [host.name] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead."}}},"status":400}

Any idea how to get rid of that? That appeared after I have deleted all the metricbeat 7.2.0 related indices.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 16, 2019, 8:28pm UTC](https://discuss.elastic.co/t/metricbeat-system-overview-dashboard-is-throwing-a-fieldata-disabled-error/195805/2 "2019-09-16T20:28:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
