# Metricbeat unable to import dashboards

**URL:** https://discuss.elastic.co/t/metricbeat-unable-to-import-dashboards/184939
**Category:** Beats
**Tags:** metricbeat
**Created:** [June 10, 2019, 7:37am UTC](https://discuss.elastic.co/t/metricbeat-unable-to-import-dashboards/184939 "2019-06-10T07:37:28Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![zozo6015](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zozo6015/32/12117_2.png) [@zozo6015](https://discuss.elastic.co/u/zozo6015)
#### Post date: [June 10, 2019, 7:37am UTC](https://discuss.elastic.co/t/metricbeat-unable-to-import-dashboards/184939/1 "2019-06-10T07:37:28Z")

</div>

Hello,

I have just installed 7.1.1 with security enabled. I have reconfigured the metricbeat with the credentials but when I am starting it would fail with the following errors:

```
https://pastebin.com/GhD3hH5a

```

The metricbeat.yml looks like this:

```
metricbeat.config.modules:
  # Glob pattern for configuration loading
  path: ${path.config}/modules.d/*.yml
  # Set to true to enable config reloading
  reload.enabled: false

  # Period on which files under path should be checked for changes
  #reload.period: 10s
setup.template.settings:
  index.number_of_shards: 1
  index.codec: best_compression
  #_source.enabled: false
tags: ["logger", "management"]
setup.dashboards.enabled: true
setup.kibana:
  host: "http://localhost:5601"
output.elasticsearch:
  hosts: ["localhost:9200"]
  username: "ingest"
  password: "somepass"
processors:
  - add_host_metadata: ~
  - add_cloud_metadata: ~
logging.level: error
logging.selectors: ["*"]
xpack.monitoring.enabled: true
xpack.monitoring.elasticsearch:
  username: "beat_system"
  password: "some beat encrypted password"
migration.6_to_7.enabled: true

```

Any idea what the problem could be?

---

<div class="post-metadata">

### Author: ![PraveenKT](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/praveenkt/32/35483_2.png) [@PraveenKT](https://discuss.elastic.co/u/PraveenKT)
#### Post date: [June 12, 2019, 1:42pm UTC](https://discuss.elastic.co/t/metricbeat-unable-to-import-dashboards/184939/2 "2019-06-12T13:42:52Z")

</div>

1. In kibana yml set ssl option to false as below.  
server.ssl.enabled: false

2. restart the kibana  
systemctl restart kibana

3. update the kibana secution in metricbeat yml, as below  
setup.kibana:  
host: "[http://username:password@x.x.x.x:5601](http://username:password@x.x.x.x:5601)"

use kibana login username & password and kibana ip address.

1. then run below command where metricbeat installed  
./metricbeat.exe setup --dashboards

2. after exporting dashboards, roll back ssl option to true in kibaya.yml as show in below. and restart kibana.  
server.ssl.enabled: true

😀😃

---

<div class="post-metadata">

### Author: ![zozo6015](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zozo6015/32/12117_2.png) [@zozo6015](https://discuss.elastic.co/u/zozo6015)
#### Post date: [June 12, 2019, 1:56pm UTC](https://discuss.elastic.co/t/metricbeat-unable-to-import-dashboards/184939/3 "2019-06-12T13:56:05Z")

</div>

I have observed that the error is happening only if I run the setup command from local machine to elasticsearch. I was able to import all dashboards properly using a remote machine. Therefore I don't believe that it is related to kibana username/password of ssl enabled or not.

---

<div class="post-metadata">

### Author: ![PraveenKT](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/praveenkt/32/35483_2.png) [@PraveenKT](https://discuss.elastic.co/u/PraveenKT)
#### Post date: [June 12, 2019, 3:28pm UTC](https://discuss.elastic.co/t/metricbeat-unable-to-import-dashboards/184939/4 "2019-06-12T15:28:24Z")

</div>

I didnt get your issue. is metricbeat not sending the data to elasticsearch or other issue ?

---

<div class="post-metadata">

### Author: ![zozo6015](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zozo6015/32/12117_2.png) [@zozo6015](https://discuss.elastic.co/u/zozo6015)
#### Post date: [June 12, 2019, 3:50pm UTC](https://discuss.elastic.co/t/metricbeat-unable-to-import-dashboards/184939/5 "2019-06-12T15:50:30Z")

</div>

I don’t think that the issue is Metricbeat related since the filebeat and heartbeat is having the same behavior.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 10, 2019, 3:50pm UTC](https://discuss.elastic.co/t/metricbeat-unable-to-import-dashboards/184939/6 "2019-07-10T15:50:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
