# Metricbeat unable to load dashboards to kibana cloud due to Client.timeout

**URL:** https://discuss.elastic.co/t/metricbeat-unable-to-load-dashboards-to-kibana-cloud-due-to-client-timeout/202209
**Category:** Beats
**Tags:** metricbeat
**Created:** [October 3, 2019, 3:48pm UTC](https://discuss.elastic.co/t/metricbeat-unable-to-load-dashboards-to-kibana-cloud-due-to-client-timeout/202209 "2019-10-03T15:48:05Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![eswo](https://avatars.discourse-cdn.com/v4/letter/e/ecc23a/32.png) [@eswo](https://discuss.elastic.co/u/eswo)
#### Post date: [October 3, 2019, 3:48pm UTC](https://discuss.elastic.co/t/metricbeat-unable-to-load-dashboards-to-kibana-cloud-due-to-client-timeout/202209/1 "2019-10-03T15:48:05Z")

</div>

Hello Guys,

It is been a full day since i'm on this problem  
I searched everywhere but nothing helps.

I'm trying to install metricbeat, and send some data about apache status.

The installation goes well, i edited the metricbeat config file with the corresponding `cloud.id` and `cloud.auth`, thus it is able to connect to elasticsearch very well.

The problem is when i run the `metricbeat setup` command, it exits on `Loading dashboards (Kibana must be running and reachable)` with the following error message:

```
Exiting: fail to create the Kibana loader: Error creating Kibana client: Error creating Kibana client: fail to get the Kibana version: HTTP GET request to /api/status fails: fail to execute the HTTP GET request: Get https://corresponding-url:443/api/status: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers). Response: .

```

When i try to make `curl -XGET username:password https://corresponding-url:443/api/status -I` it works good, and get all the information about kibana's status.

Also, in the log there is a column `:` at the end of url, i don't know if it is normal ?

My metricbeat config file, is pretty simple, as the only fields changed are cloud values, which i copied from the cloud web interface.

I'm on version 6.8.2 for Elasticsearch, Kibana and Metricbeat.

Thank you very much guys about your help !

Cheers

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 31, 2019, 3:48pm UTC](https://discuss.elastic.co/t/metricbeat-unable-to-load-dashboards-to-kibana-cloud-due-to-client-timeout/202209/2 "2019-10-31T15:48:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
