# \[Metricbeat Windows\] Services ECS dashboard throwing errors

**URL:** https://discuss.elastic.co/t/metricbeat-windows-services-ecs-dashboard-throwing-errors/245173
**Category:** Kibana
**Created:** [August 17, 2020, 3:03am UTC](https://discuss.elastic.co/t/metricbeat-windows-services-ecs-dashboard-throwing-errors/245173 "2020-08-17T03:03:21Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![mudricd](https://avatars.discourse-cdn.com/v4/letter/m/da6949/32.png) [@mudricd](https://discuss.elastic.co/u/mudricd)
#### Post date: [August 17, 2020, 3:03am UTC](https://discuss.elastic.co/t/metricbeat-windows-services-ecs-dashboard-throwing-errors/245173/1 "2020-08-17T03:03:21Z")

</div>

Hi,

I setup Metricbeat on Windows and I use windows module to send info about services to Elasticsearch through Logstash. There are no filters on Logstash server for this pipeline.

Then I loaded Kibana dashboards according to the documentation. But when I go to to [Metricbeat Windows] Services ECS dashboard the following errors pop up:

> `Saved "field" parameter is now invalid. Please select a new field.`

and

> ` [esaggs] > "field" is a required parameter`

I am working with the same versions of ELK Stack and Metricbeat - 7.5.2

I wonder if anybody could shed some light on this please?

Cheers,  
Dragan

---

<div class="post-metadata">

### Author: ![monfera](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/monfera/32/26467_2.png) [@monfera](https://discuss.elastic.co/u/monfera)
#### Post date: [August 20, 2020, 8:49am UTC](https://discuss.elastic.co/t/metricbeat-windows-services-ecs-dashboard-throwing-errors/245173/2 "2020-08-20T08:49:47Z")

</div>

Hello Dragan, if you followed the documentation for your setup and there's no other step, please consider filing a bug report, with the exact sequence of activities stated clear. If it works in some other eg. test setup of yours, it's worth stating in the report. Please also try [this approach](https://discuss.elastic.co/t/saved-field-parameter-is-now-invalid-please-select-a-new-field-visualize-field-is-a-required-parameter/70034) (older version though) for a similar issue to see if it solves your case.

---

<div class="post-metadata">

### Author: ![mudricd](https://avatars.discourse-cdn.com/v4/letter/m/da6949/32.png) [@mudricd](https://discuss.elastic.co/u/mudricd)
#### Post date: [August 20, 2020, 11:21pm UTC](https://discuss.elastic.co/t/metricbeat-windows-services-ecs-dashboard-throwing-errors/245173/3 "2020-08-20T23:21:41Z")

</div>

Thanks @monfera  
It turned out that the problem was related to our environment which is quite complex...

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 17, 2020, 11:21pm UTC](https://discuss.elastic.co/t/metricbeat-windows-services-ecs-dashboard-throwing-errors/245173/4 "2020-09-17T23:21:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
