# Metricbeats and Kibana

**URL:** <https://discuss.elastic.co/t/metricbeats-and-kibana/167537>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [February 7, 2019, 9:31pm UTC](https://discuss.elastic.co/t/metricbeats-and-kibana/167537 "2019-02-07T21:31:05Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![lgwapnitsky](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lgwapnitsky/32/42919_2.png) [@lgwapnitsky](https://discuss.elastic.co/u/lgwapnitsky)\
**Post date:** [February 7, 2019, 9:31pm UTC](https://discuss.elastic.co/t/metricbeats-and-kibana/167537/1 "2019-02-07T21:31:05Z")

</div>

Working with a fresh installation of Kibana and metricbeats. The latter feeds through logstash.

I've gone through setting up the dashboards multiple times, but keep winding up with errors like the following:

```
The request for this panel failed
Fielddata is disabled on text fields by default. Set fielddata=true on [beat.name] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead.

```

and

```
The request for this panel failed

The aggregations key is missing from the response, check your permissions for this request.

```

My logstash config looks like the following:

```
 output {
   elasticsearch {
      hosts => ["localhost:9200"]
      manage_template => false
      index => "%{[@metadata][beat]}-%{[@metadata][version]}-%{+YYYY.MM.dd}"
   }
}

```

metricbeats config looks like the following:

```
#----------------------------- Logstash output --------------------------------
output.logstash:
  # The Logstash hosts
  hosts: ["severname:5046"]

#============================== Dashboards =====================================
setup.dashboards.enabled: true

#setup.dashboards.url:

#============================== Kibana =====================================

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.
# This requires a Kibana endpoint configuration.
setup.kibana:

  host: "http://servername:5601"

```

I've deleted the indices and dashboards multiple times, reloaded, still receiving the same errors in dashboards with multiple fields showing similar errors.

Advice is welcome

---

<div class="post-metadata">

**Author:** ![Mario\_Castro](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mario_castro/32/35107_2.png) [@Mario\_Castro](https://discuss.elastic.co/u/Mario_Castro)\
**Post date:** [February 8, 2019, 10:45am UTC](https://discuss.elastic.co/t/metricbeats-and-kibana/167537/2 "2019-02-08T10:45:14Z")

</div>

Hi @lgwapnitsky 🙂

Can you share the command you are using to setup the dashboards. Also any output might be helpful.

Which version of the stack you are using? Do you have X-Pack Security enabled?

Have you read this related issue? [Elasticsearch problem, search thread pool rejected](https://discuss.elastic.co/t/elasticsearch-problem-search-thread-pool-rejected/114446/2)

---

<div class="post-metadata">

**Author:** ![lgwapnitsky](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lgwapnitsky/32/42919_2.png) [@lgwapnitsky](https://discuss.elastic.co/u/lgwapnitsky)\
**Post date:** [February 8, 2019, 2:18pm UTC](https://discuss.elastic.co/t/metricbeats-and-kibana/167537/3 "2019-02-08T14:18:12Z")

</div>

Mario-

After some digging, I've exported my json objects, and modified a significant number of fields to now point to .keyword. That seems to be working for now.

Thanks for the pointer to the other article, but different issue for now.

Best regards,  
Larry

---

<div class="post-metadata">

**Author:** ![lgwapnitsky](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lgwapnitsky/32/42919_2.png) [@lgwapnitsky](https://discuss.elastic.co/u/lgwapnitsky)\
**Post date:** [February 8, 2019, 3:39pm UTC](https://discuss.elastic.co/t/metricbeats-and-kibana/167537/4 "2019-02-08T15:39:14Z")

</div>

Also, had i followed the instructions, you can't load the templates via logstash. Changed that, too, and it worked 🙂

---

<div class="post-metadata">

**Author:** ![Mario\_Castro](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mario_castro/32/35107_2.png) [@Mario\_Castro](https://discuss.elastic.co/u/Mario_Castro)\
**Post date:** [February 11, 2019, 8:28pm UTC](https://discuss.elastic.co/t/metricbeats-and-kibana/167537/5 "2019-02-11T20:28:43Z")

</div>

Oh, yeah, I didn't realize that you might be trying that. I'm glad that you fixed it!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 11, 2019, 8:33pm UTC](https://discuss.elastic.co/t/metricbeats-and-kibana/167537/6 "2019-03-11T20:33:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
