# Migration errors 0.20.1 to 0.90

**URL:** <https://discuss.elastic.co/t/migration-errors-0-20-1-to-0-90/12039>\
**Category:** Elasticsearch\
**Created:** [May 20, 2013, 2:53pm UTC](https://discuss.elastic.co/t/migration-errors-0-20-1-to-0-90/12039 "2013-05-20T14:53:52Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mte\_Per](https://avatars.discourse-cdn.com/v4/letter/m/58956e/32.png) [@Mte\_Per](https://discuss.elastic.co/u/Mte_Per)\
**Post date:** [May 20, 2013, 2:53pm UTC](https://discuss.elastic.co/t/migration-errors-0-20-1-to-0-90/12039/1 "2013-05-20T14:53:52Z")

</div>

Hi,  
i have problem with importing data into new ElasticSearch version 0.90.  
When i was importing data into ES ver 0.20.1 there was no problem, but when  
i change to ver 0.90 (also upgrade jar files in my Java importer), after  
few (130) documents added i get this error:

Exception in thread "calculations"  
org.elasticsearch.client.transport.NoNodeAvailableException: No node  
available  
at  
org.elasticsearch.client.transport.TransportClientNodesService.execute(TransportClientNodesService.java:202)  
at  
org.elasticsearch.client.transport.support.InternalTransportClient.execute(InternalTransportClient.java:106)  
at  
org.elasticsearch.client.support.AbstractClient.index(AbstractClient.java:84)  
at  
org.elasticsearch.client.transport.TransportClient.index(TransportClient.java:310)  
at  
org.elasticsearch.action.index.IndexRequestBuilder.doExecute(IndexRequestBuilder.java:315)  
at  
org.elasticsearch.action.ActionRequestBuilder.execute(ActionRequestBuilder.java:62)  
at  
org.elasticsearch.action.ActionRequestBuilder.execute(ActionRequestBuilder.java:57)  
at com.pureholidayhomes.lib.es.ESConnector.send(ESConnector.java:30)  
at com.pureholidayhomes.lib.es.Calculations.run(Calculations.java:398)

also ElasticSearch print:

[2013-05-20 16:24:50,735][INFO][monitor.jvm] [Exterminator]  
[gc][ConcurrentMarkSweep][473][30] duration [9s], collections [1]  
/[9.9s], total [9s]/[26.5s], memory [1.4gb]-\>[1gb]/[1.9gb], all\_pools  
{[Code Cache] [5.2mb]-\>[5.2mb]/[48mb]}{[Par Eden Space] [323.2mb]-\>[6.  
1mb]/[532.5mb]}{[Par Survivor Space] [57.1mb]-\>[0b]/[66.5mb]}{[CMS Old Gen]  
[1gb]-\>[1gb]/[1.3gb]}{[CMS Perm Gen] [31.9mb]-\>[31.9mb]/[82mb]}

First ElasticSearch runs on 1g ram, and this error occurred after I import  
about 60 documents.  
Second ElasticSearch with 2g ram, and this error occurred after I import  
about 130 documents.

What should i do?  
Is it known issue?

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![jprante](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jprante/32/44941_2.png) [@jprante](https://discuss.elastic.co/u/jprante)\
**Post date:** [May 20, 2013, 4:01pm UTC](https://discuss.elastic.co/t/migration-errors-0-20-1-to-0-90/12039/2 "2013-05-20T16:01:06Z")

</div>

This has nothing to do with migration errors. Your JVM performs a very  
long GC of 9 seconds which exceeds the default ping timeout of 5  
seconds, so ES dropped the connection ,assuming your JVM is just too  
busy. Try again if you can reproduce it. If yes, increase the timeout to  
something like 10 seconds, or consider to update your Java version.

Jörg

Am 20.05.13 16:53, schrieb Mte Per:

> Hi,  
> i have problem with importing data into new Elasticsearch version 0.90.  
> When i was importing data into ES ver 0.20.1 there was no problem, but  
> when i change to ver 0.90 (also upgrade jar files in my Java  
> importer), after few (130) documents added i get this error:
> 
> Exception in thread "calculations"  
> org.elasticsearch.client.transport.NoNodeAvailableException: No node  
> available  
> at  
> org.elasticsearch.client.transport.TransportClientNodesService.execute(TransportClientNodesService.java:202)  
> at  
> org.elasticsearch.client.transport.support.InternalTransportClient.execute(InternalTransportClient.java:106)  
> at  
> org.elasticsearch.client.support.AbstractClient.index(AbstractClient.java:84)  
> at  
> org.elasticsearch.client.transport.TransportClient.index(TransportClient.java:310)  
> at  
> org.elasticsearch.action.index.IndexRequestBuilder.doExecute(IndexRequestBuilder.java:315)  
> at  
> org.elasticsearch.action.ActionRequestBuilder.execute(ActionRequestBuilder.java:62)  
> at  
> org.elasticsearch.action.ActionRequestBuilder.execute(ActionRequestBuilder.java:57)  
> at com.pureholidayhomes.lib.es.ESConnector.send(ESConnector.java:30)  
> at com.pureholidayhomes.lib.es.Calculations.run(Calculations.java:398)
> 
> also Elasticsearch print:
> 
> [2013-05-20 16:24:50,735][INFO][monitor.jvm]  
> [Exterminator] [gc][ConcurrentMarkSweep][473][30] duration [9s],  
> collections [1]  
> /[9.9s], total [9s]/[26.5s], memory [1.4gb]-\>[1gb]/[1.9gb], all\_pools  
> {[Code Cache] [5.2mb]-\>[5.2mb]/[48mb]}{[Par Eden Space] [323.2mb]-\>[6.  
> 1mb]/[532.5mb]}{[Par Survivor Space] [57.1mb]-\>[0b]/[66.5mb]}{[CMS Old  
> Gen] [1gb]-\>[1gb]/[1.3gb]}{[CMS Perm Gen] [31.9mb]-\>[31.9mb]/[82mb]}
> 
> First Elasticsearch runs on 1g ram, and this error occurred after I  
> import about 60 documents.  
> Second Elasticsearch with 2g ram, and this error occurred after I  
> import about 130 documents.
> 
> What should i do?  
> Is it known issue?
> 
> --  
> You received this message because you are subscribed to the Google  
> Groups "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send  
> an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![Mte\_Per](https://avatars.discourse-cdn.com/v4/letter/m/58956e/32.png) [@Mte\_Per](https://discuss.elastic.co/u/Mte_Per)\
**Post date:** [May 21, 2013, 11:56am UTC](https://discuss.elastic.co/t/migration-errors-0-20-1-to-0-90/12039/3 "2013-05-21T11:56:59Z")

</div>

I've updated jvm to x64 7 u21, and nothing changed.

W dniu poniedziałek, 20 maja 2013 18:01:06 UTC+2 użytkownik Jörg Prante  
napisał:

> This has nothing to do with migration errors. Your JVM performs a very  
> long GC of 9 seconds which exceeds the default ping timeout of 5  
> seconds, so ES dropped the connection ,assuming your JVM is just too  
> busy. Try again if you can reproduce it. If yes, increase the timeout to  
> something like 10 seconds, or consider to update your Java version.
> 
> Jörg
> 
> Am 20.05.13 16:53, schrieb Mte Per:
> 
> > Hi,  
> > i have problem with importing data into new Elasticsearch version 0.90.  
> > When i was importing data into ES ver 0.20.1 there was no problem, but  
> > when i change to ver 0.90 (also upgrade jar files in my Java  
> > importer), after few (130) documents added i get this error:
> > 
> > Exception in thread "calculations"  
> > org.elasticsearch.client.transport.NoNodeAvailableException: No node  
> > available  
> > at
> 
> org.elasticsearch.client.transport.TransportClientNodesService.execute(TransportClientNodesService.java:202)
> 
> > ```
> > at 
> > 
> > ```
> 
> org.elasticsearch.client.transport.support.InternalTransportClient.execute(InternalTransportClient.java:106)
> 
> > ```
> > at 
> > 
> > ```
> 
> org.elasticsearch.client.support.AbstractClient.index(AbstractClient.java:84)
> 
> > ```
> > at 
> > 
> > ```
> 
> org.elasticsearch.client.transport.TransportClient.index(TransportClient.java:310)
> 
> > ```
> > at 
> > 
> > ```
> 
> org.elasticsearch.action.index.IndexRequestBuilder.doExecute(IndexRequestBuilder.java:315)
> 
> > ```
> > at 
> > 
> > ```
> 
> org.elasticsearch.action.ActionRequestBuilder.execute(ActionRequestBuilder.java:62)
> 
> > ```
> > at 
> > 
> > ```
> 
> org.elasticsearch.action.ActionRequestBuilder.execute(ActionRequestBuilder.java:57)
> 
> > ```
> > at com.pureholidayhomes.lib.es.ESConnector.send(ESConnector.java:30) 
> > at 
> > 
> > ```
> 
> com.pureholidayhomes.lib.es.Calculations.run(Calculations.java:398)
> 
> > also Elasticsearch print:
> > 
> > [2013-05-20 16:24:50,735][INFO][monitor.jvm]  
> > [Exterminator] [gc][ConcurrentMarkSweep][473][30] duration [9s],  
> > collections [1]  
> > /[9.9s], total [9s]/[26.5s], memory [1.4gb]-\>[1gb]/[1.9gb], all\_pools  
> > {[Code Cache] [5.2mb]-\>[5.2mb]/[48mb]}{[Par Eden Space] [323.2mb]-\>[6.  
> > 1mb]/[532.5mb]}{[Par Survivor Space] [57.1mb]-\>[0b]/[66.5mb]}{[CMS Old  
> > Gen] [1gb]-\>[1gb]/[1.3gb]}{[CMS Perm Gen] [31.9mb]-\>[31.9mb]/[82mb]}
> > 
> > First Elasticsearch runs on 1g ram, and this error occurred after I  
> > import about 60 documents.  
> > Second Elasticsearch with 2g ram, and this error occurred after I  
> > import about 130 documents.
> > 
> > What should i do?  
> > Is it known issue?
> > 
> > --  
> > You received this message because you are subscribed to the Google  
> > Groups "elasticsearch" group.  
> > To unsubscribe from this group and stop receiving emails from it, send  
> > an email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com) \<javascript:\>.  
> > For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![Bruce\_Ritchie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bruce_ritchie/32/9370_2.png) [@Bruce\_Ritchie](https://discuss.elastic.co/u/Bruce_Ritchie)\
**Post date:** [May 21, 2013, 1:38pm UTC](https://discuss.elastic.co/t/migration-errors-0-20-1-to-0-90/12039/4 "2013-05-21T13:38:02Z")

</div>

CMS pauses that long usually are caused by one of two things. The first is  
that the heap is fragmented enough (or too full) for the CMS collector to  
work effectively so it'll do a full stop the world collection. Often this  
either means you're not allocating enough memory to the JVM for ES to run  
but it can also point to a memory leak. The second cause is if you're  
running ES inside of a virtual environment where the VM that ES is running  
within is being starved of CPU cycles - in other words the host machine is  
overallocated.

My guess is that something isn't releasing resources that should be  
released ... 130 docs doesn't seem like much unless they're really, really  
large documents.

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 2:35am UTC](https://discuss.elastic.co/t/migration-errors-0-20-1-to-0-90/12039/5 "2017-07-06T02:35:32Z")

</div>


