# Migration Problem 6.0

**URL:** <https://discuss.elastic.co/t/migration-problem-6-0/108891>\
**Category:** Elasticsearch\
**Created:** [November 23, 2017, 1:07pm UTC](https://discuss.elastic.co/t/migration-problem-6-0/108891 "2017-11-23T13:07:48Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Rob\_Schwerdtner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rob_schwerdtner/32/14810_2.png) [@Rob\_Schwerdtner](https://discuss.elastic.co/u/Rob_Schwerdtner)\
**Post date:** [November 23, 2017, 1:07pm UTC](https://discuss.elastic.co/t/migration-problem-6-0/108891/1 "2017-11-23T13:07:49Z")

</div>

After trying to migrate from 5.3 (via 5.6) to 6.0 i have to face sharding errors.  
My Indecies seemed to be looked and i can not revert from this status.

My setting looks like this and read\_only is set to false and write as well...  
{  
".kibana-6": {  
"settings": {  
"index": {  
"number\_of\_shards": "1",  
"blocks": {  
"read\_only\_allow\_delete": "true",  
**"read\_only": "false",**  
\*\* "write": "false"\*\*  
},  
"provided\_name": ".kibana-6",  
"mapper": {  
"dynamic": "false"  
},  
"creation\_date": "1511359816799",  
"number\_of\_replicas": "1",  
"uuid": "wOw0PHNGSZuWNIB-a8Yhjw",  
"version": {  
"created": "5060099",  
"upgraded": "6000099"  
}  
}  
}  
}  
}

Trying to set write to true leads me to this error message

{  
"error": {  
"root\_cause": [  
{  
"type": "cluster\_block\_exception",  
"reason": "blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];"  
}  
],  
"type": "cluster\_block\_exception",  
"reason": "blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];"  
},  
"status": 403  
}

This is the same error i see when I'm at the discovermode on certain indicies

Error: blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];: [cluster\_block\_exception] blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];  
at [http://localhost:5601/bundles/kibana.bundle.js?v=16070:27:28530](http://localhost:5601/bundles/kibana.bundle.js?v=16070:27:28530)  
at processQueue ([http://localhost:5601/bundles/commons.bundle.js?v=16070:39:9912](http://localhost:5601/bundles/commons.bundle.js?v=16070:39:9912))  
at [http://localhost:5601/bundles/commons.bundle.js?v=16070:39:10805](http://localhost:5601/bundles/commons.bundle.js?v=16070:39:10805)  
at Scope.$digest ([http://localhost:5601/bundles/commons.bundle.js?v=16070:39:21741](http://localhost:5601/bundles/commons.bundle.js?v=16070:39:21741))  
at Scope.$apply ([http://localhost:5601/bundles/commons.bundle.js?v=16070:39:24520](http://localhost:5601/bundles/commons.bundle.js?v=16070:39:24520))  
at done ([http://localhost:5601/bundles/commons.bundle.js?v=16070:38:9495](http://localhost:5601/bundles/commons.bundle.js?v=16070:38:9495))  
at completeRequest ([http://localhost:5601/bundles/commons.bundle.js?v=16070:38:13952](http://localhost:5601/bundles/commons.bundle.js?v=16070:38:13952))  
at XMLHttpRequest.xhr.onload ([http://localhost:5601/bundles/commons.bundle.js?v=16070:38:14690](http://localhost:5601/bundles/commons.bundle.js?v=16070:38:14690))

I also see at other indecies sharding errors  
Courier Fetch: 1 of 5 shards failed.

Could anyone help me on this  
?

---

<div class="post-metadata">

**Author:** ![sujeetKumar](https://avatars.discourse-cdn.com/v4/letter/s/6de8d8/32.png) [@sujeetKumar](https://discuss.elastic.co/u/sujeetKumar)\
**Post date:** [November 27, 2017, 11:23am UTC](https://discuss.elastic.co/t/migration-problem-6-0/108891/2 "2017-11-27T11:23:16Z")

</div>

> [@Rob\_Schwerdtner](#):
>
> "blocks": {
> 
> "read\_only\_allow\_delete": "true",
> 
> "read\_only": "false",
> 
> \*\* "write": "false"\*\*
> 
> }

TRY Using below command :

PUT your\_index/\_settings  
{  
"index": {  
"blocks": {  
"read\_only\_allow\_delete": "false"  
}  
}  
}

---

<div class="post-metadata">

**Author:** ![fernandowiek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fernandowiek/32/24836_2.png) [@fernandowiek](https://discuss.elastic.co/u/fernandowiek)\
**Post date:** [November 29, 2017, 8:37pm UTC](https://discuss.elastic.co/t/migration-problem-6-0/108891/3 "2017-11-29T20:37:05Z")

</div>

Thank you, sujeetKumar!

---

<div class="post-metadata">

**Author:** ![hippie](https://avatars.discourse-cdn.com/v4/letter/h/ac8455/32.png) [@hippie](https://discuss.elastic.co/u/hippie)\
**Post date:** [December 8, 2017, 11:50am UTC](https://discuss.elastic.co/t/migration-problem-6-0/108891/4 "2017-12-08T11:50:36Z")

</div>

Thank you very much for your post.  
That was very helpful

---

<div class="post-metadata">

**Author:** ![hippie](https://avatars.discourse-cdn.com/v4/letter/h/ac8455/32.png) [@hippie](https://discuss.elastic.co/u/hippie)\
**Post date:** [December 8, 2017, 11:57am UTC](https://discuss.elastic.co/t/migration-problem-6-0/108891/5 "2017-12-08T11:57:02Z")

</div>

I found that problem has many people but no one is talking about solution  
Can anyone tell what can be the cause when .kibana index is going to read-only state?  
I know that It happens when the disk is close to full out, but in my case the partition have had a lot of free space.  
Any suggestions?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 5, 2018, 11:57am UTC](https://discuss.elastic.co/t/migration-problem-6-0/108891/6 "2018-01-05T11:57:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
