# Mimecasta integration with api v2

**URL:** <https://discuss.elastic.co/t/mimecasta-integration-with-api-v2/380157>\
**Category:** Kibana\
**Tags:** elastic-stack-monitoring\
**Created:** [July 16, 2025, 3:35am UTC](https://discuss.elastic.co/t/mimecasta-integration-with-api-v2/380157 "2025-07-16T03:35:52Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![Haidar](https://avatars.discourse-cdn.com/v4/letter/h/96bed5/32.png) [@Haidar](https://discuss.elastic.co/u/Haidar)\
**Post date:** [July 16, 2025, 3:35am UTC](https://discuss.elastic.co/t/mimecasta-integration-with-api-v2/380157/1 "2025-07-16T03:35:52Z")

</div>

Hi, i have integration to mimecast with apiv2

this is my env used:  
Elastic stack : 9.0.0v  
OS: Ubuntu  
Elastic agent : 9.0.2v

I got error an error in several data\_stream.dataset wich is in:

- mimecast.cloud\_integrated\_logs
- mimecast.threat\_intel\_malware\_grid
- mimecast.siem\_logs
- mimecast.threat\_intel\_malware\_customer

with error.message

```auto
[
  GET /siem/v1/batch/events/ci: {
      "fail": [
          {
             "code": "app_forbidden",
             "message": "Forbidden to perform the requested operation. Resource or method requested does not exist in any product assigned to the application."
          }
      ]
  },
  Processor 'json' with tag '' failed with message 'field [original] not present as part of path [event.original]'
]

```

several dataset only have this error.message :

`[failed proto conversion: optional.none() dereference, Processor 'json' with tag '' failed with message 'field [original] not present as part of path [event.original]']`

can someone help me for solved this error?
