# Modified elasticsearch.yml - now Elasticsearch will not start

**URL:** <https://discuss.elastic.co/t/modified-elasticsearch-yml-now-elasticsearch-will-not-start/32903>\
**Category:** Elasticsearch\
**Created:** [October 24, 2015, 6:04am UTC](https://discuss.elastic.co/t/modified-elasticsearch-yml-now-elasticsearch-will-not-start/32903 "2015-10-24T06:04:53Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![mojave](https://avatars.discourse-cdn.com/v4/letter/m/58f4c7/32.png) [@mojave](https://discuss.elastic.co/u/mojave)\
**Post date:** [October 24, 2015, 6:04am UTC](https://discuss.elastic.co/t/modified-elasticsearch-yml-now-elasticsearch-will-not-start/32903/1 "2015-10-24T06:04:54Z")

</div>

Brand new to Elasticsearch. Running it on AWS. I modified elasticsearch.yml per a YouTube video and now Elasticsearch will not start with this output:

```auto
[root@ip-xxx-xx-x-xxx elasticsearch]# service elasticsearch start
Starting elasticsearch: [OK]
[root@ip-xxx-xx-x-xxx elasticsearch]# {1.7.2}: Setup Failed ...
- SettingsException[Failed to load settings from [file:/etc/elasticsearch/elasticsearch.yml]]
        ScannerException[while scanning a simple key; could not found expected ':'; in 'reader', line 18, column 1:
    cd ES_HOME/config
    ^]
org.elasticsearch.common.settings.SettingsException: Failed to load settings from [file:/etc/elasticsearch/elasticsearch.yml]
        at org.elasticsearch.common.settings.ImmutableSettings$Builder.loadFromStream(ImmutableSettings.java:985)
        at org.elasticsearch.common.settings.ImmutableSettings$Builder.loadFromUrl(ImmutableSettings.java:969)
        at org.elasticsearch.node.internal.InternalSettingsPreparer.prepareSettings(InternalSettingsPreparer.java:110)
        at org.elasticsearch.bootstrap.Bootstrap.initialSettings(Bootstrap.java:144)
        at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:215)
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)
Caused by: while scanning a simple key
 in 'reader', line 17, column 1:
    cd /etc/elasticsearch
    ^
could not found expected ':'
 in 'reader', line 18, column 1:
    cd ES_HOME/config
    ^

        at org.elasticsearch.common.jackson.dataformat.yaml.snakeyaml.scanner.ScannerImpl.stalePossibleSimpleKeys(ScannerImpl.java:465)
        at org.elasticsearch.common.jackson.dataformat.yaml.snakeyaml.scanner.ScannerImpl.needMoreTokens(ScannerImpl.java:280)
        at org.elasticsearch.common.jackson.dataformat.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:225)
        at org.elasticsearch.common.jackson.dataformat.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(ParserImpl.java:558)
        at org.elasticsearch.common.jackson.dataformat.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:158)
        at org.elasticsearch.common.jackson.dataformat.yaml.snakeyaml.parser.ParserImpl.getEvent(ParserImpl.java:168)
        at org.elasticsearch.common.jackson.dataformat.yaml.YAMLParser.nextToken(YAMLParser.java:331)
        at org.elasticsearch.common.xcontent.json.JsonXContentParser.nextToken(JsonXContentParser.java:51)
        at org.elasticsearch.common.settings.loader.XContentSettingsLoader.serializeObject(XContentSettingsLoader.java:91)
        at org.elasticsearch.common.settings.loader.XContentSettingsLoader.load(XContentSettingsLoader.java:68)
        at org.elasticsearch.common.settings.loader.XContentSettingsLoader.load(XContentSettingsLoader.java:46)
        at org.elasticsearch.common.settings.loader.YamlSettingsLoader.load(YamlSettingsLoader.java:46)
        at org.elasticsearch.common.settings.ImmutableSettings$Builder.loadFromStream(ImmutableSettings.java:982)
        ... 5 more

```

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [October 24, 2015, 6:29am UTC](https://discuss.elastic.co/t/modified-elasticsearch-yml-now-elasticsearch-will-not-start/32903/2 "2015-10-24T06:29:46Z")

</div>

Your `elasticsearch.yml` file is incorrect.

---

<div class="post-metadata">

**Author:** ![niraj\_kumar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/niraj_kumar/32/4130_2.png) [@niraj\_kumar](https://discuss.elastic.co/u/niraj_kumar)\
**Post date:** [October 26, 2015, 7:10am UTC](https://discuss.elastic.co/t/modified-elasticsearch-yml-now-elasticsearch-will-not-start/32903/3 "2015-10-26T07:10:39Z")

</div>

Post your yml file

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:42pm UTC](https://discuss.elastic.co/t/modified-elasticsearch-yml-now-elasticsearch-will-not-start/32903/4 "2017-07-05T23:42:44Z")

</div>


