# Mongo-connector giving bulk index error when running with mongodb

**URL:** <https://discuss.elastic.co/t/mongo-connector-giving-bulk-index-error-when-running-with-mongodb/59319>\
**Category:** Elasticsearch\
**Created:** [August 30, 2016, 2:06pm UTC](https://discuss.elastic.co/t/mongo-connector-giving-bulk-index-error-when-running-with-mongodb/59319 "2016-08-30T14:06:04Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Satyadeep\_Kumar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/satyadeep_kumar/32/8589_2.png) [@Satyadeep\_Kumar](https://discuss.elastic.co/u/Satyadeep_Kumar)\
**Post date:** [August 30, 2016, 2:06pm UTC](https://discuss.elastic.co/t/mongo-connector-giving-bulk-index-error-when-running-with-mongodb/59319/1 "2016-08-30T14:06:04Z")

</div>

I am trying to run mongo-connector to map mongodb to elasticsearch, but am getting

```
BulkIndexError: (document(s) failed to index.'

```

The command used is `mongo-connector -m localhost:27017 -t localhost:9200 -d elastic2_doc_manager`.

**MongoDB** version is `3.2.7`. OS `CentOS Linux release 7.2.1511 (Core)`

**Mongo** is set to run in replica mode

```
replication:
  oplogSizeMB: 10240
  replSetName: "rs0"

```

Any idea?

Thanks

Any help, greatly appreciated.

---

<div class="post-metadata">

**Author:** ![Satyadeep\_Kumar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/satyadeep_kumar/32/8589_2.png) [@Satyadeep\_Kumar](https://discuss.elastic.co/u/Satyadeep_Kumar)\
**Post date:** [September 2, 2016, 10:46am UTC](https://discuss.elastic.co/t/mongo-connector-giving-bulk-index-error-when-running-with-mongodb/59319/2 "2016-09-02T10:46:04Z")

</div>

Fixed it myself , it was just that ES is less forgiving 🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:22pm UTC](https://discuss.elastic.co/t/mongo-connector-giving-bulk-index-error-when-running-with-mongodb/59319/3 "2017-07-05T22:22:55Z")

</div>


