# Monitoring - error 400

**URL:** <https://discuss.elastic.co/t/monitoring-error-400/105066>\
**Category:** Elasticsearch\
**Created:** [October 24, 2017, 12:32pm UTC](https://discuss.elastic.co/t/monitoring-error-400/105066 "2017-10-24T12:32:51Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![knights](https://avatars.discourse-cdn.com/v4/letter/k/7c8e57/32.png) [@knights](https://discuss.elastic.co/u/knights)\
**Post date:** [October 24, 2017, 12:32pm UTC](https://discuss.elastic.co/t/monitoring-error-400/105066/1 "2017-10-24T12:32:51Z")

</div>

Hello,

I'm currently testing the monitoring options given by x-pack.

In my development environment, I set up 2 clusters, sending their monitoring data into a 3rd cluster.  
When I try to visualize the monitoring data via Kibana, I get the following error :

"Monitoring: Error 400 Bad Request: Cannot read property 'status' of undefined"

When I look the stack trace, i get

"request [12:28:52.897] [error][monitoring-ui] TypeError: Cannot read property 'status' of undefined at validateMonitoringLicense"

I'm, however, well inside the 30 days trial.

How could I solve this?  
Thanks.

---

<div class="post-metadata">

**Author:** ![tsullivan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tsullivan/32/31077_2.png) [@tsullivan](https://discuss.elastic.co/u/tsullivan)\
**Post date:** [October 24, 2017, 4:49pm UTC](https://discuss.elastic.co/t/monitoring-error-400/105066/2 "2017-10-24T16:49:42Z")

</div>

- What are the versions of the 2 Elasticsearch clusters, and the Monitoring cluster?
- What is the version of Kibana that is used to visualize the monitoring data?

---

<div class="post-metadata">

**Author:** ![knights](https://avatars.discourse-cdn.com/v4/letter/k/7c8e57/32.png) [@knights](https://discuss.elastic.co/u/knights)\
**Post date:** [October 25, 2017, 7:20am UTC](https://discuss.elastic.co/t/monitoring-error-400/105066/3 "2017-10-25T07:20:00Z")

</div>

Hello, and thanks for your reply.

Everything is in V5.5.1.

However, when I came back this morning, everything started to work properly, despite the fact I didn't take any actions after I left yesterday, while I still had those errors 400.

So, everything works wonder, now, even If i'm still curious as to why I had that problem, and why It seems to have solved itself.

Anyway, thanks, and have a nice day.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 22, 2017, 7:20am UTC](https://discuss.elastic.co/t/monitoring-error-400/105066/4 "2017-11-22T07:20:01Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
