# Muliple nodes on a single machine in 2.3.4

**URL:** <https://discuss.elastic.co/t/muliple-nodes-on-a-single-machine-in-2-3-4/57109>\
**Category:** Elasticsearch\
**Created:** [August 3, 2016, 1:17pm UTC](https://discuss.elastic.co/t/muliple-nodes-on-a-single-machine-in-2-3-4/57109 "2016-08-03T13:17:35Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Hitesh\_Bansal](https://avatars.discourse-cdn.com/v4/letter/h/e19b73/32.png) [@Hitesh\_Bansal](https://discuss.elastic.co/u/Hitesh_Bansal)\
**Post date:** [August 3, 2016, 1:17pm UTC](https://discuss.elastic.co/t/muliple-nodes-on-a-single-machine-in-2-3-4/57109/1 "2016-08-03T13:17:35Z")

</div>

DES command is not running when we try to make multiple yml file in /etc/elasticsearch

hitesh@hitesh-HP-EliteBook-8470p:/usr/share/elasticsearch$ bin/elasticsearch -Des.path.conf=/etc/elasticsearch/elasticsearch1.yml

Exception in thread "main" ElasticsearchException[Failed to load logging configuration]; nested: AccessDeniedException[/etc/elasticsearch/elasticsearch1.yml];  
Likely root cause: java.nio.file.AccessDeniedException: /etc/elasticsearch/elasticsearch1.yml  
at sun.nio.fs.UnixException.translateToIOException(UnixException.java:84)  
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102)  
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107)  
at sun.nio.fs.UnixFileAttributeViews$Basic.readAttributes(UnixFileAttributeViews.java:55)  
at sun.nio.fs.UnixFileSystemProvider.readAttributes(UnixFileSystemProvider.java:144)  
at sun.nio.fs.LinuxFileSystemProvider.readAttributes(LinuxFileSystemProvider.java:99)  
at java.nio.file.Files.readAttributes(Files.java:1737)  
at java.nio.file.FileTreeWalker.getAttributes(FileTreeWalker.java:225)  
at java.nio.file.FileTreeWalker.visit(FileTreeWalker.java:276)  
at java.nio.file.FileTreeWalker.walk(FileTreeWalker.java:322)  
at java.nio.file.Files.walkFileTree(Files.java:2662)  
at org.elasticsearch.common.logging.log4j.LogConfigurator.resolveConfig(LogConfigurator.java:142)  
at org.elasticsearch.common.logging.log4j.LogConfigurator.configure(LogConfigurator.java:103)  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:243)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:35)  
Refer to the log for complete error details.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [August 3, 2016, 1:37pm UTC](https://discuss.elastic.co/t/muliple-nodes-on-a-single-machine-in-2-3-4/57109/2 "2016-08-03T13:37:04Z")

</div>

I think it should be

```auto
bin/elasticsearch -Des.path.conf=/etc/elasticsearch/

```

---

<div class="post-metadata">

**Author:** ![Hitesh\_Bansal](https://avatars.discourse-cdn.com/v4/letter/h/e19b73/32.png) [@Hitesh\_Bansal](https://discuss.elastic.co/u/Hitesh_Bansal)\
**Post date:** [August 4, 2016, 4:28am UTC](https://discuss.elastic.co/t/muliple-nodes-on-a-single-machine-in-2-3-4/57109/3 "2016-08-04T04:28:17Z")

</div>

It is still showing the same error message . Can you tell the whole method again to create multiple nodes on a single  
machine in elasticsearch version 2.3.4. Thanks in advance.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [August 4, 2016, 7:09am UTC](https://discuss.elastic.co/t/muliple-nodes-on-a-single-machine-in-2-3-4/57109/4 "2016-08-04T07:09:20Z")

</div>

My guess is that is for testing right?

Just download the tar or zip file, unzip  
Then launch bin/elasticsearch as many time you wish everyone in its shell.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:30pm UTC](https://discuss.elastic.co/t/muliple-nodes-on-a-single-machine-in-2-3-4/57109/5 "2017-07-05T22:30:13Z")

</div>


