# Multiple beats to one logstash

**URL:** <https://discuss.elastic.co/t/multiple-beats-to-one-logstash/189969>\
**Category:** Beats\
**Created:** [July 11, 2019, 10:15am UTC](https://discuss.elastic.co/t/multiple-beats-to-one-logstash/189969 "2019-07-11T10:15:45Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![markov](https://avatars.discourse-cdn.com/v4/letter/m/f1d935/32.png) [@markov](https://discuss.elastic.co/u/markov)\
**Post date:** [July 11, 2019, 10:15am UTC](https://discuss.elastic.co/t/multiple-beats-to-one-logstash/189969/1 "2019-07-11T10:15:45Z")

</div>

Hi guys,  
i have one filebeat instance shipping logs to logstash and i after added another filebeat instance in another machine, they won't show up in kibana, the log file shows that the connection is established and it shows logs shipped but nothing appears, is there any other parameters i have to add in logstash or in the second filebeat !!!

---

<div class="post-metadata">

**Author:** ![steffens](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/steffens/32/79630_2.png) [@steffens](https://discuss.elastic.co/u/steffens)\
**Post date:** [July 11, 2019, 2:24pm UTC](https://discuss.elastic.co/t/multiple-beats-to-one-logstash/189969/2 "2019-07-11T14:24:28Z")

</div>

No, it should just work. Can you share logs and configs (please format them using the `</>` button)?

---

<div class="post-metadata">

**Author:** ![markov](https://avatars.discourse-cdn.com/v4/letter/m/f1d935/32.png) [@markov](https://discuss.elastic.co/u/markov)\
**Post date:** [July 11, 2019, 2:32pm UTC](https://discuss.elastic.co/t/multiple-beats-to-one-logstash/189969/3 "2019-07-11T14:32:44Z")

</div>

it shows the failed to conncet message !!

```
> Failed to connect to backoff(async(tcp://xx.xx.xxx.164:5044)): dial tcp xx.xx.xxx.x:5044: connect: connection refused

```

Note that i have configured filebeat.yml in the same way as the one working, and the proxy is configured in our private network

---

<div class="post-metadata">

**Author:** ![steffens](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/steffens/32/79630_2.png) [@steffens](https://discuss.elastic.co/u/steffens)\
**Post date:** [July 15, 2019, 9:53am UTC](https://discuss.elastic.co/t/multiple-beats-to-one-logstash/189969/4 "2019-07-15T09:53:06Z")

</div>

You normally get `connection refused` if the port is not available on the target machine. Check if Logstash is running, bound to the correct device/ip (or not bound to any) and your is proxy correctly forwarding the port.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 12, 2019, 11:53am UTC](https://discuss.elastic.co/t/multiple-beats-to-one-logstash/189969/5 "2019-08-12T11:53:08Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
