# Multiple hosts in ES output - one of them down

**URL:** https://discuss.elastic.co/t/multiple-hosts-in-es-output-one-of-them-down/212826
**Category:** Logstash
**Created:** [December 23, 2019, 9:34am UTC](https://discuss.elastic.co/t/multiple-hosts-in-es-output-one-of-them-down/212826 "2019-12-23T09:34:03Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![elastic22](https://avatars.discourse-cdn.com/v4/letter/e/6de8d8/32.png) [@elastic22](https://discuss.elastic.co/u/elastic22)
#### Post date: [December 23, 2019, 9:34am UTC](https://discuss.elastic.co/t/multiple-hosts-in-es-output-one-of-them-down/212826/1 "2019-12-23T09:34:03Z")

</div>

Hi

I have a 5 node cluster, two of which are used for "hot" data.  
In my Logstash configs in the Elasticsearch output, I define both hosts:  
elasticsearch {  
hosts =\> ["[https://host1:9200](https://host1:9200)", "[https://host2:9200](https://host2:9200)" ]  
}

I would expect LS to load balance the requests across both hosts, and if one of them goes down, it should send all messages to the remaining one.  
But it seems that the whole pipeline stops working. I get lots of errors regarding the one host that is down:  
"Attempted to resurrect connection to dead ES instance, but got an error", "host unreachable", etc.

Is there a way to make it behave that way?

I am using ES and LS 7.5

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 20, 2020, 9:34am UTC](https://discuss.elastic.co/t/multiple-hosts-in-es-output-one-of-them-down/212826/2 "2020-01-20T09:34:10Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
