# Multiple jdbc input configs error

**URL:** <https://discuss.elastic.co/t/multiple-jdbc-input-configs-error/32688>\
**Category:** Logstash\
**Created:** [October 21, 2015, 3:37pm UTC](https://discuss.elastic.co/t/multiple-jdbc-input-configs-error/32688 "2015-10-21T15:37:09Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![CraigFoote](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/craigfoote/32/4571_2.png) [@CraigFoote](https://discuss.elastic.co/u/CraigFoote)\
**Post date:** [October 21, 2015, 3:37pm UTC](https://discuss.elastic.co/t/multiple-jdbc-input-configs-error/32688/1 "2015-10-21T15:37:09Z")

</div>

I have two Logstash config files that run independently fine but not when run with -f as their directory.  
They're almost identical in that they use jdbc input plugin just with different connection strings and system names in tags.

```
input{
    jdbc{
        jdbc_driver_library => "/licensed/elk.oracle-jdbc/ojdbc6_g.jar"
        jdbc_driver_class => "Java::oracle.jdbc.Oracledriver"
        ...
        tags => ["system1"]
    }
}
output{
    if "system1" in [tags]{
        elasticsearch{
            ...
        }
    }
}

```

The error I'm getting on Logstash startup is:

> "Error: Expected one of #, {, } at line 35, column 27 (byte 851) after ... input{\n\tjdbc{\n\t\tjdbc\_driver\_library =\> ""}

Like I said, they run independently fine but not together. Is there any issue with running multiple jdbc input plugins?

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [October 21, 2015, 3:42pm UTC](https://discuss.elastic.co/t/multiple-jdbc-input-configs-error/32688/2 "2015-10-21T15:42:22Z")

</div>

Does your config file really say `jdbc_driver class` and not `jdbc_driver_class`?

---

<div class="post-metadata">

**Author:** ![CraigFoote](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/craigfoote/32/4571_2.png) [@CraigFoote](https://discuss.elastic.co/u/CraigFoote)\
**Post date:** [October 21, 2015, 3:53pm UTC](https://discuss.elastic.co/t/multiple-jdbc-input-configs-error/32688/3 "2015-10-21T15:53:27Z")

</div>

No sorry, that was a typo on my part. I'm on a private network and had to retype everything on my internet machine and missed the underscore. I've edited my original post to be accurate. I see in the error message the concatenation of the two config files, i.e. I see the end of one file then the beginning of the next but the point it reports the error at, near the beginning of the second file, doesn't make much sense.

---

<div class="post-metadata">

**Author:** ![CraigFoote](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/craigfoote/32/4571_2.png) [@CraigFoote](https://discuss.elastic.co/u/CraigFoote)\
**Post date:** [October 21, 2015, 4:03pm UTC](https://discuss.elastic.co/t/multiple-jdbc-input-configs-error/32688/4 "2015-10-21T16:03:03Z")

</div>

My apologies, It turned out the first file was missing a closing quote. Sorry for the noise ☹

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 5:25am UTC](https://discuss.elastic.co/t/multiple-jdbc-input-configs-error/32688/5 "2017-07-06T05:25:52Z")

</div>


