# Multiple pipeline on single host not working as expected

**URL:** <https://discuss.elastic.co/t/multiple-pipeline-on-single-host-not-working-as-expected/361330>\
**Category:** Logstash\
**Created:** [June 12, 2024, 2:00pm UTC](https://discuss.elastic.co/t/multiple-pipeline-on-single-host-not-working-as-expected/361330 "2024-06-12T14:00:03Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ajay\_Bhatnagar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ajay_bhatnagar/32/122097_2.png) [@Ajay\_Bhatnagar](https://discuss.elastic.co/u/Ajay_Bhatnagar)\
**Post date:** [June 12, 2024, 2:00pm UTC](https://discuss.elastic.co/t/multiple-pipeline-on-single-host-not-working-as-expected/361330/1 "2024-06-12T14:00:03Z")

</div>

When defining multiple pipelines on single host with output to elasticsearch in different indices (each pipeline points its own separate config file, different pipeline id and different output index name defined in config file), logstash throws errors because of parsing using different config file than specified for pipeline. Individual single pipeline with same config works fine. Is there another setting required for multiple pipeline on same host. Logstash version 8.13.4.

example pipe line defined in pipeline.yml as

```auto
- pipeline.id: client_analytics
  path.config: "/etc/logstash/conf.d/clientAnalyticsLog.conf"
- pipeline.id: client_session
  path.config: "/etc/logstash/conf.d/clientSessionLog.conf"

In the config files output section of respective config file

output {
    elasticsearch {
        ...
        index => "client_analytics_log"
        }
}

in second config file
output {
    elasticsearch {
      ...
        index => "client_session_log"
        }
}

```

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [June 12, 2024, 2:26pm UTC](https://discuss.elastic.co/t/multiple-pipeline-on-single-host-not-working-as-expected/361330/2 "2024-06-12T14:26:47Z")

</div>

> [@Ajay\_Bhatnagar](#):
>
> logstash throws errors

Exactly what errors does it throw?

---

<div class="post-metadata">

**Author:** ![Ajay\_Bhatnagar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ajay_bhatnagar/32/122097_2.png) [@Ajay\_Bhatnagar](https://discuss.elastic.co/u/Ajay_Bhatnagar)\
**Post date:** [June 13, 2024, 12:34pm UTC](https://discuss.elastic.co/t/multiple-pipeline-on-single-host-not-working-as-expected/361330/3 "2024-06-13T12:34:26Z")

</div>

Please ignore the issue. Found the problem.
