# MultiplePipeline not working.. Lost all day :-(

**URL:** <https://discuss.elastic.co/t/multiplepipeline-not-working-lost-all-day/115802>\
**Category:** Logstash\
**Created:** [January 16, 2018, 10:45pm UTC](https://discuss.elastic.co/t/multiplepipeline-not-working-lost-all-day/115802 "2018-01-16T22:45:06Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Karthik\_Ramachandran](https://avatars.discourse-cdn.com/v4/letter/k/f19dbf/32.png) [@Karthik\_Ramachandran](https://discuss.elastic.co/u/Karthik_Ramachandran)\
**Post date:** [January 16, 2018, 10:45pm UTC](https://discuss.elastic.co/t/multiplepipeline-not-working-lost-all-day/115802/1 "2018-01-16T22:45:06Z")

</div>

Trying to get multiple pipelines work from logstash and fed up with settings. Below are details

logstash.yml  
path.data: /var/lib/logstash  
path.logs: /var/log/logstash

Note that "path.config" is not present as I want logstash to pickup pipelines.yml file. pipelines.yml file is present in the same directory as logstash.yml.

pipelines.yml

- [pipeline.id](http://pipeline.id): system-messages-devtest  
path.config: "/etc/logstash/conf.d/ls-system.messages.pipeline.yml"
- [pipeline.id](http://pipeline.id): system-auth-devtest  
path.config: "/etc/logstash/conf.d/ls-system.auth.pipeline.yml"

NOTE: It will resemble like filebeat name as I re-used a bit from there for transformations.

Logstash is started using "sudo systemctl start logstash.service"  
Also, tried with sudo /usr/share/logstash/bin/logstash --path.settings /etc/logstash

Error:  
[root@........]# sudo /usr/share/logstash/bin/logstash --path.settings /etc/logstash  
Sending Logstash's logs to /var/log/logstash which is now configured via log4j2.properties  
ERROR: No configuration file was specified. Perhaps you forgot to provide the '-f yourlogstash.conf' flag?  
usage:  
bin/logstash -f CONFIG\_PATH [-t] [-r] [] [-w COUNT] [-l LOG]  
bin/logstash --modules MODULE\_NAME [-M "MODULE\_NAME.var.PLUGIN\_TYPE.PLUGIN\_NAME.VARIABLE\_NAME=VALUE"] [-t] [-w COUNT] [-l LOG]  
bin/logstash -e CONFIG\_STR [-t] [--log.level fatal|error|warn|info|debug|trace] [-w COUNT] [-l LOG]  
bin/logstash -i SHELL [--log.level fatal|error|warn|info|debug|trace]  
bin/logstash -V [--log.level fatal|error|warn|info|debug|trace]  
bin/logstash --help

When started as service using "sudo systemctl start logstash.service", below is observed in log /var/log/logstash/logstash-plain.log  
[root@........]# sudo systemctl start logstash.service  
[root@........]# ps -ef|grep logstash  
logstash 16770 1 99 22:42 ? 00:00:28 /usr/bin/java -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+DisableExplicitGC -Djava.awt.headless=true -Dfile.encoding=UTF-8 -XX:+HeapDumpOnOutOfMemoryError -Xmx1g -Xms256m -Xss2048k -Djffi.boot.library.path=/usr/share/logstash/vendor/jruby/lib/jni -Xbootclasspath/a:/usr/share/logstash/vendor/jruby/lib/jruby.jar -classpath : -Djruby.home=/usr/share/logstash/vendor/jruby -Djruby.lib=/usr/share/logstash/vendor/jruby/lib -Djruby.script=jruby -Djruby.shell=/bin/sh org.jruby.Main /usr/share/logstash/lib/bootstrap/environment.rb logstash/runner.rb --path.settings /etc/logstash  
root 16808 10416 0 22:42 pts/0 00:00:00 grep --color=auto logstash  
[root@........]# cat /var/log/logstash/logstash-plain.log  
[2018-01-16T22:43:19,202][INFO][logstash.modules.scaffold] Initializing module {:module\_name=\>"fb\_apache", :directory=\>"/usr/share/logstash/modules/fb\_apache/configuration"}  
[2018-01-16T22:43:19,220][INFO][logstash.modules.scaffold] Initializing module {:module\_name=\>"netflow", :directory=\>"/usr/share/logstash/modules/netflow/configuration"}

NO PIPELINES ARE STARTED

Any help is appreciated.

---

<div class="post-metadata">

**Author:** ![Karthik\_Ramachandran](https://avatars.discourse-cdn.com/v4/letter/k/f19dbf/32.png) [@Karthik\_Ramachandran](https://discuss.elastic.co/u/Karthik_Ramachandran)\
**Post date:** [January 17, 2018, 12:05am UTC](https://discuss.elastic.co/t/multiplepipeline-not-working-lost-all-day/115802/2 "2018-01-17T00:05:17Z")

</div>

Ah. Figured the root cause..unknowingly LS was reverted to older version.....5.x

Admin - Please archive.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 14, 2018, 12:05am UTC](https://discuss.elastic.co/t/multiplepipeline-not-working-lost-all-day/115802/3 "2018-02-14T00:05:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
