# Must I restart the cluster when a new node is added, in a cloud compute environment?

**URL:** https://discuss.elastic.co/t/must-i-restart-the-cluster-when-a-new-node-is-added-in-a-cloud-compute-environment/18688
**Category:** Elasticsearch
**Created:** [July 16, 2014, 5:18am UTC](https://discuss.elastic.co/t/must-i-restart-the-cluster-when-a-new-node-is-added-in-a-cloud-compute-environment/18688 "2014-07-16T05:18:48Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![11158](https://avatars.discourse-cdn.com/v4/letter/1/d9b06d/32.png) [@11158](https://discuss.elastic.co/u/11158)
#### Post date: [July 16, 2014, 5:18am UTC](https://discuss.elastic.co/t/must-i-restart-the-cluster-when-a-new-node-is-added-in-a-cloud-compute-environment/18688/1 "2014-07-16T05:18:48Z")

</div>

Hi everyone!

I have two problems that confuse me, I have already searched with google,  
and dived into the doc of this project, but I can't find proper explains  
for them, I need help!

1. I use www._aliyun_.com cloud compute virtual machine build a  
elasticsearch cluster, and I already know that add a now node(in real  
server environment) that could auto join in a exist cluster which hold the  
same cluster name.  
But in my work environment(I use virtual machine and use default "zen  
discovery"), I must restart the cluster when I add a new node in this  
cluster. Is this necessary?

I have noticed that there are exclusive plugins for google, es2, azure  
cloud compute, is cloud compute different real machine? If it is, what  
different between them?

1. Is there any backup or snapshot mechanism in elasticsearch, because  
every midnight (from 2:00-6:00), the performance became lower than daytime  
and more likely occur error such as below, should I limit "bulk" operation  
in this range of time?

If you know the answer, please explain it for me, Thank you!

by magigo

the error message!  
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

No handlers could be found for logger "elasticsearch"  
Exception in thread C\_Threading:  
Traceback (most recent call last):  
File "/usr/lib/python2.7/threading.py", line 551, in \_\_bootstrap\_inner  
self.run()  
File "es\_indexing\_3.py", line 87, in run  
res = helpers.bulk(self.es, actions, chunk\_size=size)  
File  
"/usr/local/lib/python2.7/dist-packages/elasticsearch/helpers/ **init**.py",  
line 145, in bulk  
for ok, item in streaming\_bulk(client, actions, \*\*kwargs):  
File  
"/usr/local/lib/python2.7/dist-packages/elasticsearch/helpers/ **init**.py",  
line 104, in streaming\_bulk  
resp = client.bulk(bulk\_actions, \*\*kwargs)  
File  
"/usr/local/lib/python2.7/dist-packages/elasticsearch/client/utils.py",  
line 67, in \_wrapped  
return func(\*args, params=params, \*\*kwargs)  
File  
"/usr/local/lib/python2.7/dist-packages/elasticsearch/client/ **init**.py",  
line 646, in bulk  
params=params, body=self.\_bulk\_body(body))  
File "/usr/local/lib/python2.7/dist-packages/elasticsearch/transport.py",  
line 276, in perform\_request  
status, headers, data = connection.perform\_request(method, url, params,  
body, ignore=ignore, timeout=timeout)  
File  
"/usr/local/lib/python2.7/dist-packages/elasticsearch/connection/http\_urllib3.py",  
line 51, in perform\_request  
raise ConnectionError('N/A', str(e), e)  
ConnectionError: ConnectionError(HTTPConnectionPool(host='10.161.165.194',  
port=9200): Read timed out. (read timeout=10)) caused by:  
ReadTimeoutError(HTTPConnectionPool(host='10.161.165.194'$

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/3c7c96a9-a8c0-4477-9082-7f7c47e7258f%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/3c7c96a9-a8c0-4477-9082-7f7c47e7258f%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [July 16, 2014, 6:50am UTC](https://discuss.elastic.co/t/must-i-restart-the-cluster-when-a-new-node-is-added-in-a-cloud-compute-environment/18688/2 "2014-07-16T06:50:53Z")

</div>

I think that you should use unicast instead of multicast.  
I never looked at aliyun. Is it compatible to AWS EC2 api? If so, you could use aws cloud plugin.

--  
David 😉  
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 16 juil. 2014 à 07:18, 纪路 [magievanerv@gmail.com](mailto:magievanerv@gmail.com) a écrit :

Hi everyone!

I have two problems that confuse me, I have already searched with google, and dived into the doc of this project, but I can't find proper explains for them, I need help!

1. I use [www.aliyun.com](http://www.aliyun.com) cloud compute virtual machine build a elasticsearch cluster, and I already know that add a now node(in real server environment) that could auto join in a exist cluster which hold the same cluster name.  
But in my work environment(I use virtual machine and use default "zen discovery"), I must restart the cluster when I add a new node in this cluster. Is this necessary?

I have noticed that there are exclusive plugins for google, es2, azure cloud compute, is cloud compute different real machine? If it is, what different between them?

1. Is there any backup or snapshot mechanism in elasticsearch, because every midnight (from 2:00-6:00), the performance became lower than daytime and more likely occur error such as below, should I limit "bulk" operation in this range of time?

If you know the answer, please explain it for me, Thank you!

by magigo

the error message!  
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

## No handlers could be found for logger "elasticsearch" Exception in thread C\_Threading: Traceback (most recent call last): File "/usr/lib/python2.7/threading.py", line 551, in \_\_bootstrap\_inner self.run() File "es\_indexing\_3.py", line 87, in run res = helpers.bulk(self.es, actions, chunk\_size=size) File "/usr/local/lib/python2.7/dist-packages/elasticsearch/helpers/ **init**.py", line 145, in bulk for ok, item in streaming\_bulk(client, actions, \*\*kwargs): File "/usr/local/lib/python2.7/dist-packages/elasticsearch/helpers/ **init**.py", line 104, in streaming\_bulk resp = client.bulk(bulk\_actions, \*\*kwargs) File "/usr/local/lib/python2.7/dist-packages/elasticsearch/client/utils.py", line 67, in \_wrapped return func(\*args, params=params, \*\*kwargs) File "/usr/local/lib/python2.7/dist-packages/elasticsearch/client/ **init**.py", line 646, in bulk params=params, body=self.\_bulk\_body(body)) File "/usr/local/lib/python2.7/dist-packages/elasticsearch/transport.py", line 276, in perform\_request status, headers, data = connection.perform\_request(method, url, params, body, ignore=ignore, timeout=timeout) File "/usr/local/lib/python2.7/dist-packages/elasticsearch/connection/http\_urllib3.py", line 51, in perform\_request raise ConnectionError('N/A', str(e), e) ConnectionError: ConnectionError(HTTPConnectionPool(host='10.161.165.194', port=9200): Read timed out. (read timeout=10)) caused by: ReadTimeoutError(HTTPConnectionPool(host='10.161.165.194'$

You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/3c7c96a9-a8c0-4477-9082-7f7c47e7258f%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/3c7c96a9-a8c0-4477-9082-7f7c47e7258f%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/342AEAF8-A773-4BCF-BCEB-25CE34CD3A58%40pilato.fr](https://groups.google.com/d/msgid/elasticsearch/342AEAF8-A773-4BCF-BCEB-25CE34CD3A58%40pilato.fr).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 1:15am UTC](https://discuss.elastic.co/t/must-i-restart-the-cluster-when-a-new-node-is-added-in-a-cloud-compute-environment/18688/3 "2017-07-06T01:15:34Z")

</div>


