# My ES client always receives "Request execution exceeded the timeout"

**URL:** <https://discuss.elastic.co/t/my-es-client-always-receives-request-execution-exceeded-the-timeout/310309>\
**Category:** Elasticsearch\
**Created:** [July 21, 2022, 2:38pm UTC](https://discuss.elastic.co/t/my-es-client-always-receives-request-execution-exceeded-the-timeout/310309 "2022-07-21T14:38:25Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![fraf](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fraf/32/107072_2.png) [@fraf](https://discuss.elastic.co/u/fraf)\
**Post date:** [July 21, 2022, 2:38pm UTC](https://discuss.elastic.co/t/my-es-client-always-receives-request-execution-exceeded-the-timeout/310309/1 "2022-07-21T14:38:25Z")

</div>

Hi everyone,

When validating my indexes on client side, requests are sent to my ES server. After 100s, I received a timeout exception from the client.

```auto
Failure:
org.hibernate.search.util.common.SearchException: HSEARCH400034: Unable to retrieve index metadata from Elasticsearch: HSEARCH400590: Request execution exceeded the timeout of 100s, 0ms and 0ns. Request was GET /autretiers-write,autretiers-read with parameters {ignore_unavailable=true, allow_no_indices=true}
	at org.hibernate.search.backend.elasticsearch.schema.management.impl.ElasticsearchSchemaAccessor.lambda$getCurrentIndexMetadata$0(ElasticsearchSchemaAccessor.java:93)
	at org.hibernate.search.util.common.impl.Futures.lambda$handler$1(Futures.java:63)
	at java.base/java.util.concurrent.CompletableFuture.uniExceptionally(CompletableFuture.java:986)
	at java.base/java.util.concurrent.CompletableFuture$UniExceptionally.tryFire(CompletableFuture.java:970)
	at java.base/java.util.concurrent.CompletableFuture.postComplete(CompletableFuture.java:506)
	at java.base/java.util.concurrent.CompletableFuture.completeExceptionally(CompletableFuture.java:2088)
	at org.hibernate.search.backend.elasticsearch.client.impl.ElasticsearchClientImpl.lambda$send$2(ElasticsearchClientImpl.java:156)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
	at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: org.hibernate.search.util.common.SearchTimeoutException: HSEARCH400590: Request execution exceeded the timeout of 100s, 0ms and 0ns. Request was GET /autretiers-write,autretiers-read with parameters {ignore_unavailable=true, allow_no_indices=true}
	at org.hibernate.search.backend.elasticsearch.client.impl.ElasticsearchClientImpl.lambda$send$2(ElasticsearchClientImpl.java:153)
	... 6 common frames omitted
2022-07-21 16:27:22,047 o.h.s.e.r.spi.RootFailureCollector [E] HSEARCH000521: Hibernate Search encountered a failure during bootstrap; continuing for now to list all problems, but the process will ultimately be aborted.
Context: Hibernate ORM mapping, type 'com.allegoria.notariat.business.ConservationHypotheque'

```

My question is, how can I speedup Elasticsearch server ? Because, my CPU is almost at zero usage and I still have free memory. My ES Server is like on idle whereas my client is waiting for too long. Something is wrong.

Note : I am all in local on windows (Client + ES Server).

Thanks.

---

<div class="post-metadata">

**Author:** ![fraf](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fraf/32/107072_2.png) [@fraf](https://discuss.elastic.co/u/fraf)\
**Post date:** [July 25, 2022, 9:31am UTC](https://discuss.elastic.co/t/my-es-client-always-receives-request-execution-exceeded-the-timeout/310309/2 "2022-07-25T09:31:57Z")

</div>

I tried to increase request timeout to 1000s , and still timeout occurs for validating indexes. My application is not starting. If ignoring index validation, application starts. I suppose my ES server does nothing, my rest connection failed in idle state.  
The logs (almost the same) :

```auto
2022-07-25 11:11:55,290 org.elasticsearch.client.RestClient [W] request [GET http://127.0.0.1:9200/clientmoral-write,clientmoral-read?ignore_unavailable=true&allow_no_indices=true] returned 1 warnings: [299 Elasticsearch-7.16.3-4e6e4eab2297e949ec994e688dad46290d018022 "Elasticsearch built-in security features are not enabled. Without authentication, your cluster could be accessible to anyone. See https://www.elastic.co/guide/en/elasticsearch/reference/7.16/security-minimal-setup.html to enable security."]
2022-07-25 11:11:55,290 org.elasticsearch.client.RestClient [D] request [GET http://127.0.0.1:9200/caisseretraite-write,caisseretraite-read?ignore_unavailable=true&allow_no_indices=true] returned [HTTP/1.1 200 OK]
2022-07-25 11:11:55,291 org.elasticsearch.client.RestClient [W] request [GET http://127.0.0.1:9200/caisseretraite-write,caisseretraite-read?ignore_unavailable=true&allow_no_indices=true] returned 1 warnings: [299 Elasticsearch-7.16.3-4e6e4eab2297e949ec994e688dad46290d018022 "Elasticsearch built-in security features are not enabled. Without authentication, your cluster could be accessible to anyone. See https://www.elastic.co/guide/en/elasticsearch/reference/7.16/security-minimal-setup.html to enable security."]
2022-07-25 11:11:55,290 org.elasticsearch.client.RestClient [W] request [GET http://127.0.0.1:9200/banque-write,banque-read?ignore_unavailable=true&allow_no_indices=true] returned 1 warnings: [299 Elasticsearch-7.16.3-4e6e4eab2297e949ec994e688dad46290d018022 "Elasticsearch built-in security features are not enabled. Without authentication, your cluster could be accessible to anyone. See https://www.elastic.co/guide/en/elasticsearch/reference/7.16/security-minimal-setup.html to enable security."]

2022-07-25 11:28:35,267 o.h.s.e.r.spi.RootFailureCollector [E] HSEARCH000521: Hibernate Search encountered a failure during bootstrap; continuing for now to list all problems, but the process will ultimately be aborted.
Context: Hibernate ORM mapping, type 'com.allegoria.notariat.business.ActeParticipation'
Failure:
org.hibernate.search.util.common.SearchException: HSEARCH400034: Unable to retrieve index metadata from Elasticsearch: HSEARCH400590: Request execution exceeded the timeout of 1000s, 0ms and 0ns. Request was GET /acteparticipation-write,acteparticipation-read with parameters {ignore_unavailable=true, allow_no_indices=true}
	at org.hibernate.search.backend.elasticsearch.schema.management.impl.ElasticsearchSchemaAccessor.lambda$getCurrentIndexMetadata$0(ElasticsearchSchemaAccessor.java:93)
	at org.hibernate.search.util.common.impl.Futures.lambda$handler$1(Futures.java:63)
	at java.base/java.util.concurrent.CompletableFuture.uniExceptionally(CompletableFuture.java:986)
	at java.base/java.util.concurrent.CompletableFuture$UniExceptionally.tryFire(CompletableFuture.java:970)
	at java.base/java.util.concurrent.CompletableFuture.postComplete(CompletableFuture.java:506)
	at java.base/java.util.concurrent.CompletableFuture.completeExceptionally(CompletableFuture.java:2088)
	at org.hibernate.search.backend.elasticsearch.client.impl.ElasticsearchClientImpl.lambda$send$2(ElasticsearchClientImpl.java:156)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
	at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: org.hibernate.search.util.common.SearchTimeoutException: HSEARCH400590: Request execution exceeded the timeout of 1000s, 0ms and 0ns. Request was GET /acteparticipation-write,acteparticipation-read with parameters {ignore_unavailable=true, allow_no_indices=true}
	at org.hibernate.search.backend.elasticsearch.client.impl.ElasticsearchClientImpl.lambda$send$2(ElasticsearchClientImpl.java:153)
	... 6 common frames omitted
2022-07-25 11:28:35,271 o.h.s.e.r.spi.RootFailureCollector [E] HSEARCH000521: Hibernate Search encountered a failure during bootstrap; continuing for now to list all problems, but the process will ultimately be aborted.
Context: Hibernate ORM mapping, type 'com.allegoria.notariat.business.AssociationSyndicale'
Failure:
org.hibernate.search.util.common.SearchException: HSEARCH400034: Unable to retrieve index metadata from Elasticsearch: HSEARCH400590: Request execution exceeded the timeout of 1000s, 0ms and 0ns. Request was GET /associationsyndicale-write,associationsyndicale-read with parameters {ignore_unavailable=true, allow_no_indices=true}
	at org.hibernate.search.backend.elasticsearch.schema.management.impl.ElasticsearchSchemaAccessor.lambda$getCurrentIndexMetadata$0(ElasticsearchSchemaAccessor.java:93)
	at org.hibernate.search.util.common.impl.Futures.lambda$handler$1(Futures.java:63)
	at java.base/java.util.concurrent.CompletableFuture.uniExceptionally(CompletableFuture.java:986)
	at java.base/java.util.concurrent.CompletableFuture$UniExceptionally.tryFire(CompletableFuture.java:970)
	at java.base/java.util.concurrent.CompletableFuture.postComplete(CompletableFuture.java:506)
	at java.base/java.util.concurrent.CompletableFuture.completeExceptionally(CompletableFuture.java:2088)
	at org.hibernate.search.backend.elasticsearch.client.impl.ElasticsearchClientImpl.lambda$send$2(ElasticsearchClientImpl.java:156)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
	at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: org.hibernate.search.util.common.SearchTimeoutException: HSEARCH400590: Request execution exceeded the timeout of 1000s, 0ms and 0ns. Request was GET /associationsyndicale-write,associationsyndicale-read with parameters {ignore_unavailable=true, allow_no_indices=true}
	at org.hibernate.search.backend.elasticsearch.client.impl.ElasticsearchClientImpl.lambda$send$2(ElasticsearchClientImpl.java:153)
	... 6 common frames omitted
2022-07-25 11:28:35,275 o.h.s.e.r.spi.RootFailureCollector [E] HSEARCH000521: Hibernate Search encountered a failure during bootstrap; continuing for now to list all problems, but the process will ultimately be aborted.
Context: Hibernate ORM mapping, type 'com.allegoria.notariat.business.Assurance'

```

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 25, 2022, 11:28am UTC](https://discuss.elastic.co/t/my-es-client-always-receives-request-execution-exceeded-the-timeout/310309/3 "2022-07-25T11:28:56Z")

</div>

Is that happening for every request or from time to time?

Is your elasticsearch cluster running correctly? What are the elasticsearch logs?

---

<div class="post-metadata">

**Author:** ![fraf](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fraf/32/107072_2.png) [@fraf](https://discuss.elastic.co/u/fraf)\
**Post date:** [July 26, 2022, 9:59am UTC](https://discuss.elastic.co/t/my-es-client-always-receives-request-execution-exceeded-the-timeout/310309/4 "2022-07-26T09:59:04Z")

</div>

Problem is solved, timeout was cause by internal framework hsearch.

Thanks.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 23, 2022, 9:59am UTC](https://discuss.elastic.co/t/my-es-client-always-receives-request-execution-exceeded-the-timeout/310309/5 "2022-08-23T09:59:47Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
