# My Filebeat isn't working when pushing Sophos XG firewall logs

**URL:** https://discuss.elastic.co/t/my-filebeat-isnt-working-when-pushing-sophos-xg-firewall-logs/294799
**Category:** Beats
**Tags:** filebeat
**Created:** [January 19, 2022, 11:15am UTC](https://discuss.elastic.co/t/my-filebeat-isnt-working-when-pushing-sophos-xg-firewall-logs/294799 "2022-01-19T11:15:38Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Siyabonga](https://avatars.discourse-cdn.com/v4/letter/s/6de8d8/32.png) [@Siyabonga](https://discuss.elastic.co/u/Siyabonga)
#### Post date: [January 19, 2022, 11:15am UTC](https://discuss.elastic.co/t/my-filebeat-isnt-working-when-pushing-sophos-xg-firewall-logs/294799/1 "2022-01-19T11:15:39Z")

</div>

Hi Guys I am getting the following error when configuring Filebeat can any one please assist?

Overwriting ILM policy is disabled. Set `setup.ilm.overwrite: true` for enabling.

Index setup finished.  
Loading dashboards (Kibana must be running and reachable)  
Loaded dashboards  
Setting up ML using setup --machine-learning is going to be removed in 8.0.0. Please use the ML app instead.  
See more: [Machine Learning in the Elastic Stack [7.16] | Elastic](https://www.elastic.co/guide/en/machine-learning/current/index.html)  
Exiting: 1 error: error loading config file: invalid config: yaml: line 22: did not find expected key

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 16, 2022, 1:15pm UTC](https://discuss.elastic.co/t/my-filebeat-isnt-working-when-pushing-sophos-xg-firewall-logs/294799/2 "2022-02-16T13:15:53Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
