# My first steps with elasticsearch

**URL:** <https://discuss.elastic.co/t/my-first-steps-with-elasticsearch/22348>\
**Category:** Elasticsearch\
**Created:** [February 24, 2015, 9:15am UTC](https://discuss.elastic.co/t/my-first-steps-with-elasticsearch/22348 "2015-02-24T09:15:23Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![jan99](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@jan99](https://discuss.elastic.co/u/jan99)\
**Post date:** [February 24, 2015, 9:15am UTC](https://discuss.elastic.co/t/my-first-steps-with-elasticsearch/22348/1 "2015-02-24T09:15:23Z")

</div>

Hi !

i try to go my firststeps by elasticsearch because i want to use for a  
local mediawiki search on a win7 64bit machine. current i look at a video  
tutorial on youtube called "getting started with elasticsearch".

current i unzip the installation file and start the batch-file. in the film  
(8:15) now some example-data will test in fiddler. i write the example-data

_{ "name":"Joes", "description":"best  
pasta", "address":{ "street":"mainstreet", "city":"los  
angeles", "state":"CA", "zip":"90013", }, "location":[34,-118], "tags":["ital","spagetti","pasta"], "rating":"4.5"}_

an paste into the _Request Body-field,_ set the combo to\* POST\* and click \*Execute.  
\*in the film the log-field show the result 201 -\>OK. in my installation i  
get the result 400!

when i look into the running process window of elasticsearch 1.4.4  
(cmd-window) there will following be logged:

_[2015-02-24 08:54:25,369][DEBUG][action.index] [Mariko  
Yashida] [places][4], node[rgiQnV\_FRme4oiigE0zc7Q], [P], s[STARTED]: Failed  
to execute [index {[places][restaurant][AUu6lHDZ\_PQl5sOyj-WQ],  
source[{ "name":"Joes", "description":"best pasta",  
"address":{  
"street":"mainstreet", "city":"los  
angeles", "state":"CA",  
"zip":"90013", }, "location":[34,-118],  
"tags":["ital","spagetti","pasta"],  
"rating":"4.5"}]}]org.elasticsearch.index.mapper.MapperParsingException:  
failed to parse at  
org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.java:563)  
at  
org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.java:491)  
at  
org.elasticsearch.index.shard.service.InternalIndexShard.prepareCreate(InternalIndexShard.java:392)  
at  
org.elasticsearch.action.index.TransportIndexAction.shardOperationOnPrimary(TransportIndexAction.java:198)  
at  
org.elasticsearch.action.support.replication.TransportShardReplicationOperationAction$AsyncShardOperationAction.performOnPrimary(TransportShardReplicationOperationAction.java:512)  
at  
org.elasticsearch.action.support.replication.TransportShardReplicationOperationAction$AsyncShardOperationAction$1.run(TransportShardReplicationOperationAction.java:419)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown  
Source) at java.lang.Thread.run(Unknown Source)Caused by:  
org.elasticsearch.common.jackson.core.JsonParseException:  
Unexpectedcharacter ('}' (code 125)): was expecting either valid name  
character (for unquoted name) or double-quote (for quoted) to start field  
name at [Source: [B@a2bc760; line: 9, column: 3] at  
org.elasticsearch.common.jackson.core.JsonParser.\_constructError(JsonParser.java:1419)  
at  
org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_reportError(ParserMinimalBase.java:508)  
at  
org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_reportUnexpectedChar(ParserMinimalBase.java:437)  
at  
org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.\_handleOddName(UTF8StreamJsonParser.java:1808)  
at  
org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.\_parseName(UTF8StreamJsonParser.java:1496)  
at  
org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.nextToken(UTF8StreamJsonParser.java:693)  
at  
org.elasticsearch.common.xcontent.json.JsonXContentParser.nextToken(JsonXContentParser.java:51)  
at  
org.elasticsearch.index.mapper.object.ObjectMapper.parse(ObjectMapper.java:502)  
at  
org.elasticsearch.index.mapper.object.ObjectMapper.putDynamicMapper(ObjectMapper.java:663)  
at  
org.elasticsearch.index.mapper.object.ObjectMapper.serializeObject(ObjectMapper.java:583)  
at  
org.elasticsearch.index.mapper.object.ObjectMapper.parse(ObjectMapper.java:490)  
at  
org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.java:542)  
... 8 more_

i am local admin and the result is independ of start the bat at normal user  
(admin right) or via kontextmenue _start as admin_.

could someone help me ?

reagards Jan

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/81ac0000-a6a8-4e78-8634-8f7def90a7ea%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/81ac0000-a6a8-4e78-8634-8f7def90a7ea%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![colings86](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/colings86/32/44960_2.png) [@colings86](https://discuss.elastic.co/u/colings86)\
**Post date:** [February 24, 2015, 9:27am UTC](https://discuss.elastic.co/t/my-first-steps-with-elasticsearch/22348/2 "2015-02-24T09:27:17Z")

</div>

Hi,

The problem is that the last field in your `address` object (the `zip`  
field) ends with a `,` character. This means it is not valid JSON and fails  
to be parsed by elasticsearch. If you remove the `,` character from that  
line your request should work.

Hope that helps,

Colin

On Tuesday, 24 February 2015 09:15:23 UTC, jan99 wrote:

> Hi !
> 
> i try to go my firststeps by elasticsearch because i want to use for a  
> local mediawiki search on a win7 64bit machine. current i look at a video  
> tutorial on youtube called "getting started with elasticsearch".
> 
> current i unzip the installation file and start the batch-file. in the  
> film (8:15) now some example-data will test in fiddler. i write the  
> example-data
> 
> _{ "name":"Joes", "description":"best  
> pasta", "address":{ "street":"mainstreet", "city":"los  
> angeles", "state":"CA", "zip":"90013", }, "location":[34,-118], "tags":["ital","spagetti","pasta"], "rating":"4.5"}_
> 
> an paste into the _Request Body-field,_ set the combo to\* POST\* and click \*Execute.  
> \*in the film the log-field show the result 201 -\>OK. in my installation i  
> get the result 400!
> 
> when i look into the running process window of elasticsearch 1.4.4  
> (cmd-window) there will following be logged:
> 
> _[2015-02-24 08:54:25,369][DEBUG][action.index] [Mariko  
> Yashida] [places][4], node[rgiQnV\_FRme4oiigE0zc7Q], [P], s[STARTED]: Failed  
> to execute [index {[places][restaurant][AUu6lHDZ\_PQl5sOyj-WQ],  
> source[{ "name":"Joes", "description":"best pasta",  
> "address":{  
> "street":"mainstreet", "city":"los  
> angeles", "state":"CA",  
> "zip":"90013", }, "location":[34,-118],  
> "tags":["ital","spagetti","pasta"],  
> "rating":"4.5"}]}]org.elasticsearch.index.mapper.MapperParsingException:  
> failed to parse at  
> org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.java:563)  
> at  
> org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.java:491)  
> at  
> org.elasticsearch.index.shard.service.InternalIndexShard.prepareCreate(InternalIndexShard.java:392)  
> at  
> org.elasticsearch.action.index.TransportIndexAction.shardOperationOnPrimary(TransportIndexAction.java:198)  
> at  
> org.elasticsearch.action.support.replication.TransportShardReplicationOperationAction$AsyncShardOperationAction.performOnPrimary(TransportShardReplicationOperationAction.java:512)  
> at  
> org.elasticsearch.action.support.replication.TransportShardReplicationOperationAction$AsyncShardOperationAction$1.run(TransportShardReplicationOperationAction.java:419)  
> at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)  
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown  
> Source) at java.lang.Thread.run(Unknown Source)Caused by:  
> org.elasticsearch.common.jackson.core.JsonParseException:  
> Unexpectedcharacter ('}' (code 125)): was expecting either valid name  
> character (for unquoted name) or double-quote (for quoted) to start field  
> name at [Source: [B@a2bc760; line: 9, column: 3] at  
> org.elasticsearch.common.jackson.core.JsonParser.\_constructError(JsonParser.java:1419)  
> at  
> org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_reportError(ParserMinimalBase.java:508)  
> at  
> org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_reportUnexpectedChar(ParserMinimalBase.java:437)  
> at  
> org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.\_handleOddName(UTF8StreamJsonParser.java:1808)  
> at  
> org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.\_parseName(UTF8StreamJsonParser.java:1496)  
> at  
> org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.nextToken(UTF8StreamJsonParser.java:693)  
> at  
> org.elasticsearch.common.xcontent.json.JsonXContentParser.nextToken(JsonXContentParser.java:51)  
> at  
> org.elasticsearch.index.mapper.object.ObjectMapper.parse(ObjectMapper.java:502)  
> at  
> org.elasticsearch.index.mapper.object.ObjectMapper.putDynamicMapper(ObjectMapper.java:663)  
> at  
> org.elasticsearch.index.mapper.object.ObjectMapper.serializeObject(ObjectMapper.java:583)  
> at  
> org.elasticsearch.index.mapper.object.ObjectMapper.parse(ObjectMapper.java:490)  
> at  
> org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.java:542)  
> ... 8 more_
> 
> i am local admin and the result is independ of start the bat at normal  
> user (admin right) or via kontextmenue _start as admin_.
> 
> could someone help me ?
> 
> reagards Jan

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/0ead2d3e-e005-43c5-927d-82a096b03341%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/0ead2d3e-e005-43c5-927d-82a096b03341%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![jan99](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@jan99](https://discuss.elastic.co/u/jan99)\
**Post date:** [February 24, 2015, 9:56am UTC](https://discuss.elastic.co/t/my-first-steps-with-elasticsearch/22348/3 "2015-02-24T09:56:51Z")

</div>

Hi !

thanks for show the mistake - successfull!

but now the next steps make a problem - in the film as 10:15.

the next-test-step is to search data. i change the url in fiddler to  
[http://localhost:9200/places/restaurant/\_search](http://localhost:9200/places/restaurant/_search) (combo POST) and in the  
Request Body-field i paste

_{ "query:{ "match\_all":{} }}_

but now the protokoll logs error 400 again !

did you have a new idea against ?

regards jan

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/3b00900e-efb2-46b8-8752-8bdc88a150e3%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/3b00900e-efb2-46b8-8752-8bdc88a150e3%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![colings86](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/colings86/32/44960_2.png) [@colings86](https://discuss.elastic.co/u/colings86)\
**Post date:** [February 24, 2015, 10:05am UTC](https://discuss.elastic.co/t/my-first-steps-with-elasticsearch/22348/4 "2015-02-24T10:05:36Z")

</div>

This is another typo, your `query` field does not have a " character after  
it.

On Tuesday, 24 February 2015 09:56:51 UTC, jan99 wrote:

> Hi !
> 
> thanks for show the mistake - successfull!
> 
> but now the next steps make a problem - in the film as 10:15.
> 
> the next-test-step is to search data. i change the url in fiddler to  
> [http://localhost:9200/places/restaurant/\_search](http://localhost:9200/places/restaurant/_search) (combo POST) and in the  
> Request Body-field i paste
> 
> _{ "query:{ "match\_all":{} }}_
> 
> but now the protokoll logs error 400 again !
> 
> did you have a new idea against ?
> 
> regards jan

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/8156595b-30a1-4816-82f3-8ca17da31a2c%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/8156595b-30a1-4816-82f3-8ca17da31a2c%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![jan99](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@jan99](https://discuss.elastic.co/u/jan99)\
**Post date:** [February 24, 2015, 10:18am UTC](https://discuss.elastic.co/t/my-first-steps-with-elasticsearch/22348/5 "2015-02-24T10:18:36Z")

</div>

Hi !

thanks very much - i looked,looked,looked,looked,looked but did not the  
this error!

+10

regards Jan

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/e6af549b-cdfb-4b60-b25b-230c3684144d%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/e6af549b-cdfb-4b60-b25b-230c3684144d%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![jan99](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@jan99](https://discuss.elastic.co/u/jan99)\
**Post date:** [February 24, 2015, 11:02am UTC](https://discuss.elastic.co/t/my-first-steps-with-elasticsearch/22348/6 "2015-02-24T11:02:56Z")

</div>

hi !

i had to come back .-)

When i look to the example i think elasticsearch will work successfull. now  
i go to the next step.

in the website of elasticsearch is the next step

\*curl -X GET \*_[http://localhost:9200/](http://localhost:9200/)_ [http://localhost:9200/](http://localhost:9200/)

i have download curl, install and now negative answer will come when start  
the exe.

but if i start the command to connect 9200 i get the message:

_curl: (7) Failed connect to localhost:9200; No error_

unable - but no error ?!?!?!?

regards Jan

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/f715293d-0f68-4e6d-9203-3804b2f2b7c4%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/f715293d-0f68-4e6d-9203-3804b2f2b7c4%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [February 24, 2015, 11:53am UTC](https://discuss.elastic.co/t/my-first-steps-with-elasticsearch/22348/7 "2015-02-24T11:53:52Z")

</div>

May be try with 127.0.0.1 instead of localhost ?

--  
David 😉  
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

> Le 24 févr. 2015 à 12:02, jan99 [jan@tappenbeck.net](mailto:jan@tappenbeck.net) a écrit :
> 
> hi !
> 
> i had to come back .-)
> 
> When i look to the example i think elasticsearch will work successfull. now i go to the next step.
> 
> in the website of elasticsearch is the next step
> 
> curl -X GET [http://localhost:9200/](http://localhost:9200/)
> 
> i have download curl, install and now negative answer will come when start the exe.
> 
> but if i start the command to connect 9200 i get the message:
> 
> curl: (7) Failed connect to localhost:9200; No error
> 
> unable - but no error ?!?!?!?
> 
> ## regards Jan
> 
> You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/f715293d-0f68-4e6d-9203-3804b2f2b7c4%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/f715293d-0f68-4e6d-9203-3804b2f2b7c4%40googlegroups.com).  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/E2508F19-A587-4DDB-B786-43C775C321F3%40pilato.fr](https://groups.google.com/d/msgid/elasticsearch/E2508F19-A587-4DDB-B786-43C775C321F3%40pilato.fr).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![jan99](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@jan99](https://discuss.elastic.co/u/jan99)\
**Post date:** [February 24, 2015, 12:25pm UTC](https://discuss.elastic.co/t/my-first-steps-with-elasticsearch/22348/8 "2015-02-24T12:25:39Z")

</div>

Hi !

\*C:\curl\>curl -X GET \*_[http://127.0.0.1:9200/](http://127.0.0.1:9200/)_ [http://127.0.0.1:9200/](http://127.0.0.1:9200/)  
_curl: (7) Failed connect to 127.0.0.1:9200; No error_

no .-)

regards Jan

Am Dienstag, 24. Februar 2015 10:15:23 UTC+1 schrieb jan99:

> Hi !
> 
> i try to go my firststeps by elasticsearch because i want to use for a  
> local mediawiki search on a win7 64bit machine. current i look at a video  
> tutorial on youtube called "getting started with elasticsearch".
> 
> current i unzip the installation file and start the batch-file. in the  
> film (8:15) now some example-data will test in fiddler. i write the  
> example-data
> 
> _{ "name":"Joes", "description":"best  
> pasta", "address":{ "street":"mainstreet", "city":"los  
> angeles", "state":"CA", "zip":"90013", }, "location":[34,-118], "tags":["ital","spagetti","pasta"], "rating":"4.5"}_
> 
> an paste into the _Request Body-field,_ set the combo to\* POST\* and click \*Execute.  
> \*in the film the log-field show the result 201 -\>OK. in my installation i  
> get the result 400!
> 
> when i look into the running process window of elasticsearch 1.4.4  
> (cmd-window) there will following be logged:
> 
> _[2015-02-24 08:54:25,369][DEBUG][action.index] [Mariko  
> Yashida] [places][4], node[rgiQnV\_FRme4oiigE0zc7Q], [P], s[STARTED]: Failed  
> to execute [index {[places][restaurant][AUu6lHDZ\_PQl5sOyj-WQ],  
> source[{ "name":"Joes", "description":"best pasta",  
> "address":{  
> "street":"mainstreet", "city":"los  
> angeles", "state":"CA",  
> "zip":"90013", }, "location":[34,-118],  
> "tags":["ital","spagetti","pasta"],  
> "rating":"4.5"}]}]org.elasticsearch.index.mapper.MapperParsingException:  
> failed to parse at  
> org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.java:563)  
> at  
> org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.java:491)  
> at  
> org.elasticsearch.index.shard.service.InternalIndexShard.prepareCreate(InternalIndexShard.java:392)  
> at  
> org.elasticsearch.action.index.TransportIndexAction.shardOperationOnPrimary(TransportIndexAction.java:198)  
> at  
> org.elasticsearch.action.support.replication.TransportShardReplicationOperationAction$AsyncShardOperationAction.performOnPrimary(TransportShardReplicationOperationAction.java:512)  
> at  
> org.elasticsearch.action.support.replication.TransportShardReplicationOperationAction$AsyncShardOperationAction$1.run(TransportShardReplicationOperationAction.java:419)  
> at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)  
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown  
> Source) at java.lang.Thread.run(Unknown Source)Caused by:  
> org.elasticsearch.common.jackson.core.JsonParseException:  
> Unexpectedcharacter ('}' (code 125)): was expecting either valid name  
> character (for unquoted name) or double-quote (for quoted) to start field  
> name at [Source: [B@a2bc760; line: 9, column: 3] at  
> org.elasticsearch.common.jackson.core.JsonParser.\_constructError(JsonParser.java:1419)  
> at  
> org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_reportError(ParserMinimalBase.java:508)  
> at  
> org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_reportUnexpectedChar(ParserMinimalBase.java:437)  
> at  
> org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.\_handleOddName(UTF8StreamJsonParser.java:1808)  
> at  
> org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.\_parseName(UTF8StreamJsonParser.java:1496)  
> at  
> org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.nextToken(UTF8StreamJsonParser.java:693)  
> at  
> org.elasticsearch.common.xcontent.json.JsonXContentParser.nextToken(JsonXContentParser.java:51)  
> at  
> org.elasticsearch.index.mapper.object.ObjectMapper.parse(ObjectMapper.java:502)  
> at  
> org.elasticsearch.index.mapper.object.ObjectMapper.putDynamicMapper(ObjectMapper.java:663)  
> at  
> org.elasticsearch.index.mapper.object.ObjectMapper.serializeObject(ObjectMapper.java:583)  
> at  
> org.elasticsearch.index.mapper.object.ObjectMapper.parse(ObjectMapper.java:490)  
> at  
> org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.java:542)  
> ... 8 more_
> 
> i am local admin and the result is independ of start the bat at normal  
> user (admin right) or via kontextmenue _start as admin_.
> 
> could someone help me ?
> 
> reagards Jan

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/4cb3a412-df63-4b40-bb9f-228fad7512f5%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/4cb3a412-df63-4b40-bb9f-228fad7512f5%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [February 24, 2015, 1:09pm UTC](https://discuss.elastic.co/t/my-first-steps-with-elasticsearch/22348/9 "2015-02-24T13:09:54Z")

</div>

So it looks like elasticsearch is not running.  
Or may be some firewall issue?

Sounds like you are on Windows.

--  
David 😉  
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

> Le 24 févr. 2015 à 13:25, jan99 [jan@tappenbeck.net](mailto:jan@tappenbeck.net) a écrit :
> 
> Hi !
> 
> C:\curl\>curl -X GET [http://127.0.0.1:9200/](http://127.0.0.1:9200/)  
> curl: (7) Failed connect to 127.0.0.1:9200; No error
> 
> no .-)
> 
> regards Jan
> 
> Am Dienstag, 24. Februar 2015 10:15:23 UTC+1 schrieb jan99:
> 
> > Hi !
> > 
> > i try to go my firststeps by elasticsearch because i want to use for a local mediawiki search on a win7 64bit machine. current i look at a video tutorial on youtube called "getting started with elasticsearch".
> > 
> > current i unzip the installation file and start the batch-file. in the film (8:15) now some example-data will test in fiddler. i write the example-data
> > 
> > {  
> > "name":"Joes",  
> > "description":"best pasta",  
> > "address":{  
> > "street":"mainstreet",  
> > "city":"los angeles",  
> > "state":"CA",  
> > "zip":"90013",  
> > },  
> > "location":[34,-118],  
> > "tags":["ital","spagetti","pasta"],  
> > "rating":"4.5"  
> > }
> > 
> > an paste into the Request Body-field, set the combo to POST and click Execute. in the film the log-field show the result 201 -\>OK. in my installation i get the result 400!
> > 
> > when i look into the running process window of elasticsearch 1.4.4 (cmd-window) there will following be logged:
> > 
> > [2015-02-24 08:54:25,369][DEBUG][action.index] [Mariko Yashida] [pl  
> > aces][4], node[rgiQnV\_FRme4oiigE0zc7Q], [P], s[STARTED]: Failed to execute [inde  
> > x {[places][restaurant][AUu6lHDZ\_PQl5sOyj-WQ], source[{  
> > "name":"Joes",  
> > "description":"best pasta",  
> > "address":{  
> > "street":"mainstreet",  
> > "city":"los angeles",  
> > "state":"CA",  
> > "zip":"90013",  
> > },  
> > "location":[34,-118],  
> > "tags":["ital","spagetti","pasta"],  
> > "rating":"4.5"  
> > }]}]  
> > org.elasticsearch.index.mapper.MapperParsingException: failed to parse  
> > at org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.ja  
> > va:563)  
> > at org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.ja  
> > va:491)  
> > at org.elasticsearch.index.shard.service.InternalIndexShard.prepareCreat  
> > e(InternalIndexShard.java:392)  
> > at org.elasticsearch.action.index.TransportIndexAction.shardOperationOnP  
> > rimary(TransportIndexAction.java:198)  
> > at org.elasticsearch.action.support.replication.TransportShardReplicatio  
> > nOperationAction$AsyncShardOperationAction.performOnPrimary(TransportShardReplic  
> > ationOperationAction.java:512)  
> > at org.elasticsearch.action.support.replication.TransportShardReplicatio  
> > nOperationAction$AsyncShardOperationAction$1.run(TransportShardReplicationOperat  
> > ionAction.java:419)  
> > at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)  
> > at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)  
> > at java.lang.Thread.run(Unknown Source)  
> > Caused by: org.elasticsearch.common.jackson.core.JsonParseException: Unexpected  
> > character ('}' (code 125)): was expecting either valid name character (for unquo  
> > ted name) or double-quote (for quoted) to start field name  
> > at [Source: [B@a2bc760; line: 9, column: 3]  
> > at org.elasticsearch.common.jackson.core.JsonParser.\_constructError(Json  
> > Parser.java:1419)  
> > at org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_reportE  
> > rror(ParserMinimalBase.java:508)  
> > at org.elasticsearch.common.jackson.core.base.ParserMinimalBase.\_reportU  
> > nexpectedChar(ParserMinimalBase.java:437)  
> > at org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.\_hand  
> > leOddName(UTF8StreamJsonParser.java:1808)  
> > at org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.\_pars  
> > eName(UTF8StreamJsonParser.java:1496)  
> > at org.elasticsearch.common.jackson.core.json.UTF8StreamJsonParser.nextT  
> > oken(UTF8StreamJsonParser.java:693)  
> > at org.elasticsearch.common.xcontent.json.JsonXContentParser.nextToken(J  
> > sonXContentParser.java:51)  
> > at org.elasticsearch.index.mapper.object.ObjectMapper.parse(ObjectMapper  
> > .java:502)  
> > at org.elasticsearch.index.mapper.object.ObjectMapper.putDynamicMapper(O  
> > bjectMapper.java:663)  
> > at org.elasticsearch.index.mapper.object.ObjectMapper.serializeObject(Ob  
> > jectMapper.java:583)  
> > at org.elasticsearch.index.mapper.object.ObjectMapper.parse(ObjectMapper  
> > .java:490)  
> > at org.elasticsearch.index.mapper.DocumentMapper.parse(DocumentMapper.ja  
> > va:542)  
> > ... 8 more
> > 
> > i am local admin and the result is independ of start the bat at normal user (admin right) or via kontextmenue start as admin.
> > 
> > could someone help me ?
> > 
> > reagards Jan
> 
> --  
> You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/4cb3a412-df63-4b40-bb9f-228fad7512f5%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/4cb3a412-df63-4b40-bb9f-228fad7512f5%40googlegroups.com).  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/CB5E3AF6-A023-4A20-A0C1-21589F1697D1%40pilato.fr](https://groups.google.com/d/msgid/elasticsearch/CB5E3AF6-A023-4A20-A0C1-21589F1697D1%40pilato.fr).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![jan99](https://avatars.discourse-cdn.com/v4/letter/j/d78d45/32.png) [@jan99](https://discuss.elastic.co/u/jan99)\
**Post date:** [February 24, 2015, 1:46pm UTC](https://discuss.elastic.co/t/my-first-steps-with-elasticsearch/22348/10 "2015-02-24T13:46:36Z")

</div>

hi !

yes windows - i write at beginning "win7 64bit machine".

i will have a look to the firewall.

regards Jan

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/043b03a0-9807-44ff-9883-6e7c71c160a4%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/043b03a0-9807-44ff-9883-6e7c71c160a4%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 12:30am UTC](https://discuss.elastic.co/t/my-first-steps-with-elasticsearch/22348/11 "2017-07-06T00:30:31Z")

</div>


