# N of n shards failed error persists

**URL:** <https://discuss.elastic.co/t/n-of-n-shards-failed-error-persists/182585>\
**Category:** Elasticsearch\
**Created:** [May 24, 2019, 8:04am UTC](https://discuss.elastic.co/t/n-of-n-shards-failed-error-persists/182585 "2019-05-24T08:04:07Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![ShilpaT](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shilpat/32/43553_2.png) [@ShilpaT](https://discuss.elastic.co/u/ShilpaT)\
**Post date:** [May 24, 2019, 8:04am UTC](https://discuss.elastic.co/t/n-of-n-shards-failed-error-persists/182585/1 "2019-05-24T08:04:07Z")

</div>

The error 'n of n shards failed' is always there every time I change the the time range. It was happening in version 6.5.3, and now on 6.7.2 as well. In between I have installed Curator to remove older indices. And have tried to change the Dashboard look and feel to run less queries at the same time. But the failing of the shards still persists.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 24, 2019, 7:14pm UTC](https://discuss.elastic.co/t/n-of-n-shards-failed-error-persists/182585/2 "2019-05-24T19:14:59Z")

</div>

What do the Elasticsearch logs show?

---

<div class="post-metadata">

**Author:** ![ShilpaT](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shilpat/32/43553_2.png) [@ShilpaT](https://discuss.elastic.co/u/ShilpaT)\
**Post date:** [May 27, 2019, 10:41am UTC](https://discuss.elastic.co/t/n-of-n-shards-failed-error-persists/182585/3 "2019-05-27T10:41:56Z")

</div>

It hasn't happened since that day, so the logs don't show any error.  
But I think it has something to do with this:

"metricbeat-6.5.3-2019.05.25  
This index has [1836] fields, which exceeds the automatic field expansion limit of 1024 and does not have [index.query.default\_field] set, which may cause queries which use automatic field expansion, such as query\_string, simple\_query\_string, and multi\_match to fail if fields are not explicitly specified in the query."

I have recently updated Elastic and Kibana version to 6.7.2, but metricbeat is still 6.5.3. Could this be the reason behind failing to load data into widgets and shards fail error?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 24, 2019, 10:55am UTC](https://discuss.elastic.co/t/n-of-n-shards-failed-error-persists/182585/4 "2019-06-24T10:55:08Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
