# NameError with DLQ input plugin

**URL:** <https://discuss.elastic.co/t/nameerror-with-dlq-input-plugin/92688>\
**Category:** Logstash\
**Created:** [July 11, 2017, 3:48pm UTC](https://discuss.elastic.co/t/nameerror-with-dlq-input-plugin/92688 "2017-07-11T15:48:09Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![scarletdenizen](https://avatars.discourse-cdn.com/v4/letter/s/22d042/32.png) [@scarletdenizen](https://discuss.elastic.co/u/scarletdenizen)\
**Post date:** [July 11, 2017, 3:48pm UTC](https://discuss.elastic.co/t/nameerror-with-dlq-input-plugin/92688/1 "2017-07-11T15:48:09Z")

</div>

I'm trying to use the dead\_letter\_queue input plugin to reintroduce Elasticsearch events that get dropped back into the Logstash pipe and tag them. It appears as the Logstash 5.5 distribution fails to find the dead\_letter\_queue input when it is put into the configuration file.

My config looks like this:

```auto
dead_letter_queue {
   path => "/home/logstash/logstash/data/dead_letter_queue"
}

```

And I do have `dead_letter_queue.enable` set to true in `logstash.yml`.

Here is the error I receive when Logstash starts up:

```auto
Jul 11 11:34:56 <HIDDEN> logstash[18488]: [2017-07-11T11:34:56,396][ERROR][logstash.plugins.registry] Problems loading a plugin with {:type=>"input", :name=>"dead_letter_queue", :path=>"logstash/input
s/dead_letter_queue", :error_message=>"NameError", :error_class=>NameError, :error_backtrace=>["/home/logstash/logstash/logstash-core/lib/logstash/plugins/registry.rb:226:in `namespace_lookup'", "/home/logstash/logstash/logstash-co
re/lib/logstash/plugins/registry.rb:162:in `legacy_lookup'", "/home/logstash/logstash/logstash-core/lib/logstash/plugins/registry.rb:138:in `lookup'", "/home/logstash/logstash/logstash-core/lib/logstash/plugins/registry.rb:180:in `
lookup_pipeline_plugin'", "/home/logstash/logstash/logstash-core/lib/logstash/plugin.rb:140:in `lookup'", "/home/logstash/logstash/logstash-core/lib/logstash/pipeline.rb:100:in `plugin'", "(eval):256:in `initialize'", "org/jruby/Ru
byKernel.java:1079:in `eval'", "/home/logstash/logstash/logstash-core/lib/logstash/pipeline.rb:72:in `initialize'", "/home/logstash/logstash/logstash-core/lib/logstash/pipeline.rb:156:in `initialize'", "/home/logstash/logstash/logs
tash-core/lib/logstash/agent.rb:286:in `create_pipeline'", "/home/logstash/logstash/logstash-core/lib/logstash/agent.rb:95:in `register_pipeline'", "/home/logstash/logstash/logstash-core/lib/logstash/runner.rb:314:in `execute'", "/
home/logstash/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67:in `run'", "/home/logstash/logstash/logstash-core/lib/logstash/runner.rb:209:in `run'", "/home/logstash/logstash/vendor/bundle/jruby/1.9/gems/c
lamp-0.6.5/lib/clamp/command.rb:132:in `run'", "/home/logstash/logstash/lib/bootstrap/environment.rb:71:in `(root)'"]}
Jul 11 11:34:56 <HIDDEN> logstash[18488]: [2017-07-11T11:34:56,402][ERROR][logstash.agent] Cannot create pipeline {:reason=>"Couldn't find any input plugin named 'dead_letter_queue'. Are yo
u sure this is correct? Trying to load the dead_letter_queue input plugin resulted in this error: Problems loading the requested plugin named dead_letter_queue of type input. Error: NameError NameError"}

```

Removing the dead\_letter\_queue plugin through the Logstash plugin-install script and reinstalling it doesn't fix the problem. I can confirm that the plugin dead\_letter\_queue is listed when I do `./bin/logstash-plugin list`.

I'm running Logstash on RHEL 7.3.

---

<div class="post-metadata">

**Author:** ![jakelandis](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jakelandis/32/36163_2.png) [@jakelandis](https://discuss.elastic.co/u/jakelandis)\
**Post date:** [July 14, 2017, 2:17pm UTC](https://discuss.elastic.co/t/nameerror-with-dlq-input-plugin/92688/2 "2017-07-14T14:17:52Z")

</div>

We recently discovered an issue with this plugin [1]. This will be fixed in 5.5.1 and until then can be fixed with:

`bin/logstash-plugin update logstash-input-dead_letter_queue`

[1]

> [@\[Attention\] Logstash 5.5.0 - Known Issue with Dissect Filter and Dead Letter Queue Input](https://discuss.elastic.co/t/attention-logstash-5-5-0-known-issue-with-dissect-filter-and-dead-letter-queue-input/92337):
>
> This notice addresses a known issue with the default bundled versions of the [dissect filter](https://www.elastic.co/guide/en/logstash/current/plugins-filters-dissect.html) and [dead letter queue input](https://www.elastic.co/guide/en/logstash/current/plugins-inputs-dead_letter_queue.html) plugins in the Logstash 5.5.0 release. The Problem When using the dissect filter or dead letter queue input in a new or existing pipeline configuration with Logstash 5.5.0, users will encounter this fatal error when starting Logstash: [2017-07-07T11:18:16,031][ERROR][logstash.agent] Cannot create pipeline {:reason=\>"Couldn't find any filter plugin named 'dissect'. Are you sur…

---

<div class="post-metadata">

**Author:** ![scarletdenizen](https://avatars.discourse-cdn.com/v4/letter/s/22d042/32.png) [@scarletdenizen](https://discuss.elastic.co/u/scarletdenizen)\
**Post date:** [July 14, 2017, 3:01pm UTC](https://discuss.elastic.co/t/nameerror-with-dlq-input-plugin/92688/3 "2017-07-14T15:01:58Z")

</div>

Thanks for the quick fix!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 11, 2017, 3:02pm UTC](https://discuss.elastic.co/t/nameerror-with-dlq-input-plugin/92688/4 "2017-08-11T15:02:37Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
