# NAS drive mount give not able to obtain lock

**URL:** <https://discuss.elastic.co/t/nas-drive-mount-give-not-able-to-obtain-lock/297636>\
**Category:** Elasticsearch\
**Tags:** docker\
**Created:** [February 18, 2022, 7:27pm UTC](https://discuss.elastic.co/t/nas-drive-mount-give-not-able-to-obtain-lock/297636 "2022-02-18T19:27:44Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Uma\_Nath\_Jha](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/uma_nath_jha/32/102002_2.png) [@Uma\_Nath\_Jha](https://discuss.elastic.co/u/Uma_Nath_Jha)\
**Post date:** [February 18, 2022, 7:27pm UTC](https://discuss.elastic.co/t/nas-drive-mount-give-not-able-to-obtain-lock/297636/1 "2022-02-18T19:27:44Z")

</div>

Hi Team,

I have Elasticsearch running within a docker container and I have created a volume for my NAS drive which I mount for elastic data but it fails and gives me " ```  
Caused by: java.lang.IllegalStateException: failed to obtain node locks, tried [[/usr/share/Elasticsearch/data]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max\_local\_storage\_nodes]"

I have tried to follow this [Elasticsearch, NFS, and locking issues](https://www.frakkingsweet.com/elasticsearch-nfs-and-locking-issues/) with no success.

Could someone please help?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 18, 2022, 7:28pm UTC](https://discuss.elastic.co/t/nas-drive-mount-give-not-able-to-obtain-lock/297636/2 "2022-03-18T19:28:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
