# Native authentication with Basic License

**URL:** <https://discuss.elastic.co/t/native-authentication-with-basic-license/194494>\
**Category:** Elasticsearch\
**Created:** [August 8, 2019, 6:55pm UTC](https://discuss.elastic.co/t/native-authentication-with-basic-license/194494 "2019-08-08T18:55:39Z")\
**Posts on this page:** 1\
**Showing post:** 10

<div class="post-metadata">

**Author:** ![harryk1](https://avatars.discourse-cdn.com/v4/letter/h/aeb1de/32.png) [@harryk1](https://discuss.elastic.co/u/harryk1)\
**Post date:** [August 14, 2019, 3:23pm UTC](https://discuss.elastic.co/t/native-authentication-with-basic-license/194494/10 "2019-08-14T15:23:32Z")

</div>

Thanks for the reply, Alexander. We verified the operator but it needs some tweaks to get it running on our Kubernetes environment. So, I started by trying it via my existing setup on K8s using the link share by you.  
I have generated the ca and certs , and placed those on a persistent volume at path /var/lib/elasticsearch/certs/nodecert.p12 but elastic is failing with the following error:  
"Caused by: java.security.AccessControlException: access denied ("java.io.FilePermission" "/var/lib/elasticsearch/certs/nodecert.p12" "read")",  
"at java.security.AccessControlContext.checkPermission(AccessControlContext.java:472) ~[?:?]",  
"at java.security.AccessController.checkPermission(AccessController.java:1042) ~[?:?]",

Seems it is expecting files to be present in a specific directory (per your comment on [Elasticsearch is not starting owing to wrong file permission](https://discuss.elastic.co/t/elasticsearch-is-not-starting-owing-to-wrong-file-permission/118855/2)). Since I am pulling the images as part of the setup on k8s, i believe it should be /usr/share/elasticsearch/config  
Is my understanding correct?

---

_[View the full topic](https://discuss.elastic.co/t/native-authentication-with-basic-license/194494)._
