# \[Need help\] Error when installing winlogbeat on Windows Server 2012 R2

**URL:** <https://discuss.elastic.co/t/need-help-error-when-installing-winlogbeat-on-windows-server-2012-r2/259351>\
**Category:** Beats\
**Tags:** winlogbeat\
**Created:** [December 22, 2020, 8:57am UTC](https://discuss.elastic.co/t/need-help-error-when-installing-winlogbeat-on-windows-server-2012-r2/259351 "2020-12-22T08:57:49Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![lachezar.uzunov](https://avatars.discourse-cdn.com/v4/letter/l/ecae2f/32.png) [@lachezar.uzunov](https://discuss.elastic.co/u/lachezar.uzunov)\
**Post date:** [December 22, 2020, 8:57am UTC](https://discuss.elastic.co/t/need-help-error-when-installing-winlogbeat-on-windows-server-2012-r2/259351/1 "2020-12-22T08:57:49Z")

</div>

Hello everyone

I need help debugging what is actually going on. I am installing winlogbeat as mentioned in the documentation ([www.elastic.co/guide/en/beats/winlogbeat/7.10/winlogbeat-installation-configuration.html](http://www.elastic.co/guide/en/beats/winlogbeat/7.10/winlogbeat-installation-configuration.html)).  
Then I download my http.p12 cert and install it using windows double click (I install it for current user and local machine)

The error I get is: Exiting: couldn't connect to any of the configured Elasticsearch hosts. Errors: [error connecting to Elasticsearch at [https://192.168.200.169:9200](https://192.168.200.169:9200): Get "[https://192.168.200.169:9200](https://192.168.200.169:9200)": x509: certificate is valid for 192.168.200.169, not 192.168.200.169]

My elastic machine is with running on 192.168.200.169. I tried adding the hostname in windows hosts file, generating different types of certs but still get the same error.

On windows server 2016+ it is working without any kind of problem.

Do someone know what the issue is?

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [December 22, 2020, 2:05pm UTC](https://discuss.elastic.co/t/need-help-error-when-installing-winlogbeat-on-windows-server-2012-r2/259351/2 "2020-12-22T14:05:43Z")

</div>

I suspect the issue is that your certificate does not contain an IP Subject Alternative Name field. I think when you connect via an IP the server cert must have a SAN value for that IP.

---

<div class="post-metadata">

**Author:** ![lachezar.uzunov](https://avatars.discourse-cdn.com/v4/letter/l/ecae2f/32.png) [@lachezar.uzunov](https://discuss.elastic.co/u/lachezar.uzunov)\
**Post date:** [December 22, 2020, 2:26pm UTC](https://discuss.elastic.co/t/need-help-error-when-installing-winlogbeat-on-windows-server-2012-r2/259351/3 "2020-12-22T14:26:29Z")

</div>

Upon creating the certificate I make sure the host and IP info is correct.

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [December 22, 2020, 3:06pm UTC](https://discuss.elastic.co/t/need-help-error-when-installing-winlogbeat-on-windows-server-2012-r2/259351/4 "2020-12-22T15:06:15Z")

</div>

Then I would use Wireshark to capture and analyze the TLS handshake from the wire. This might reveal some additional details about the error.

I would also use

`openssl s_client -connect 192.168.200.169:9200 -showcerts`

to look at the server's response and certs. Then check the returned leaf cert with `openssl x509 -text -noout` to verify the presence of "IP Address" in `X509v3 Subject Alternative Name:`. Like

```auto
            X509v3 Subject Alternative Name: 
                DNS:localhost, DNS:xx.consul, DNS:xy.consul, DNS:xyz, IP Address:127.0.0.1, IP Address:10.3.12.34

```

---

<div class="post-metadata">

**Author:** ![lachezar.uzunov](https://avatars.discourse-cdn.com/v4/letter/l/ecae2f/32.png) [@lachezar.uzunov](https://discuss.elastic.co/u/lachezar.uzunov)\
**Post date:** [January 4, 2021, 7:19am UTC](https://discuss.elastic.co/t/need-help-error-when-installing-winlogbeat-on-windows-server-2012-r2/259351/5 "2021-01-04T07:19:03Z")

</div>

The DNS is correct, as well as the IP addresses, I tried experimenting with the values and got to the point where it displays NO error message but still do not send any information what so ever.

---

<div class="post-metadata">

**Author:** ![lachezar.uzunov](https://avatars.discourse-cdn.com/v4/letter/l/ecae2f/32.png) [@lachezar.uzunov](https://discuss.elastic.co/u/lachezar.uzunov)\
**Post date:** [January 7, 2021, 7:00am UTC](https://discuss.elastic.co/t/need-help-error-when-installing-winlogbeat-on-windows-server-2012-r2/259351/6 "2021-01-07T07:00:45Z")

</div>

The issue was solved after putting both my domain name and the ip as hostnames and then again enter only the ip for IPs

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 4, 2021, 9:00am UTC](https://discuss.elastic.co/t/need-help-error-when-installing-winlogbeat-on-windows-server-2012-r2/259351/7 "2021-02-04T09:00:52Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
