# Network host elasticsearch

**URL:** <https://discuss.elastic.co/t/network-host-elasticsearch/246205>\
**Category:** Elasticsearch\
**Created:** [August 25, 2020, 1:40am UTC](https://discuss.elastic.co/t/network-host-elasticsearch/246205 "2020-08-25T01:40:22Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Juliano\_de\_Mello](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/juliano_de_mello/32/45777_2.png) [@Juliano\_de\_Mello](https://discuss.elastic.co/u/Juliano_de_Mello)\
**Post date:** [August 25, 2020, 1:40am UTC](https://discuss.elastic.co/t/network-host-elasticsearch/246205/1 "2020-08-25T01:40:23Z")

</div>

In the configuration file elasticsearch.yml, I add the parameter  
network.host: 0.0.0.0, however when starting the system again it returns me the following error:  
No arquivo de configuração elasticsearch.yml, adiciono o pârametro  
network.host: 0.0.0.0, contudo ao iniciar o sistema novamente me retorna o seguinte erro:

> > > sudo systemctl start elasticsearch.service  
> > > Job for elasticsearch.service failed because the control process exited with error code.  
> > > See "systemctl status elasticsearch.service" and "journalctl -xe" for details.

* * *

Without the network.host: 0.0.0.0 setting, elasticsearch starts normally.  
Sem a configuração network.host: 0.0.0.0, o elasticsearch inicia normalmente.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [August 25, 2020, 1:42am UTC](https://discuss.elastic.co/t/network-host-elasticsearch/246205/2 "2020-08-25T01:42:33Z")

</div>

What do your Elasticsearch logs show?

---

<div class="post-metadata">

**Author:** ![Steve\_Mushero](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/steve_mushero/32/22441_2.png) [@Steve\_Mushero](https://discuss.elastic.co/u/Steve_Mushero)\
**Post date:** [August 25, 2020, 2:21am UTC](https://discuss.elastic.co/t/network-host-elasticsearch/246205/3 "2020-08-25T02:21:21Z")

</div>

And post the whole elasticsearch.yml file as you may have other strange things in there. Odd it won't bind to 0.0.0.0

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 22, 2020, 2:21am UTC](https://discuss.elastic.co/t/network-host-elasticsearch/246205/4 "2020-09-22T02:21:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
