# Network.host issue

**URL:** <https://discuss.elastic.co/t/network-host-issue/109063>\
**Category:** Elasticsearch\
**Created:** [November 24, 2017, 4:57pm UTC](https://discuss.elastic.co/t/network-host-issue/109063 "2017-11-24T16:57:08Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![AskingBoy](https://avatars.discourse-cdn.com/v4/letter/a/2bfe46/32.png) [@AskingBoy](https://discuss.elastic.co/u/AskingBoy)\
**Post date:** [November 24, 2017, 4:57pm UTC](https://discuss.elastic.co/t/network-host-issue/109063/1 "2017-11-24T16:57:08Z")

</div>

when network.host: 127.0.0.1, es can be working normally. However, when i set network.host: (real ip like ) "234.233.232.0", the error will come up .... does anyone know this issue...please kindly help...

logs here:

```auto
[2017-11-25T00:51:47,905][INFO][o.e.t.TransportService] [afs-node-1] publish_address {234.233.232.0:9300}, bound_addresses {234.233.232.0:9300}
[2017-11-25T00:51:47,923][INFO][o.e.b.BootstrapChecks] [afs-node-1] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks
[2017-11-25T00:51:47,927][ERROR][o.e.b.Bootstrap] [afs-node-1] node validation exception
[3] bootstrap checks failed
[1]: max file descriptors [65535] for elasticsearch process is too low, increase to at least [65536]
[2]: max number of threads [1024] for user [useres] is too low, increase to at least [4096]
[3]: max virtual memory areas vm.max_map_count [65536] is too low, increase to at least [262144]
[2017-11-25T00:51:47,930][INFO][o.e.n.Node] [afs-node-1] stopping ...
[2017-11-25T00:51:47,975][INFO][o.e.n.Node] [afs-node-1] stopped
[2017-11-25T00:51:47,975][INFO][o.e.n.Node] [afs-node-1] closing ...
[2017-11-25T00:51:47,988][INFO][o.e.n.Node] [afs-node-1] closed

```

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [November 24, 2017, 5:21pm UTC](https://discuss.elastic.co/t/network-host-issue/109063/2 "2017-11-24T17:21:48Z")

</div>

Please read [https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html)

---

<div class="post-metadata">

**Author:** ![AskingBoy](https://avatars.discourse-cdn.com/v4/letter/a/2bfe46/32.png) [@AskingBoy](https://discuss.elastic.co/u/AskingBoy)\
**Post date:** [November 24, 2017, 6:41pm UTC](https://discuss.elastic.co/t/network-host-issue/109063/3 "2017-11-24T18:41:40Z")

</div>

Thanks.

after reading the link, I added discovery.type: single-node. It works like a charm...thank u ...but it comes up another issue for me.

Because I would like to use kibana but received a red, so I followed  
curl -s [http://localhost:9200/.kibana/\_recovery?pretty](http://localhost:9200/.kibana/_recovery?pretty)  
curl -XPUT 'localhost:9200/.kibana/\_settings' -d '  
{  
"index" : {  
"number\_of\_replicas" : 0  
}  
}'

tried to make red to green in kibana.  
Unfortunately, the error is {"error":"Content-Type header [application/x-www-form-urlencoded] is not supported","status":406}

so how can this be solved?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [November 24, 2017, 7:46pm UTC](https://discuss.elastic.co/t/network-host-issue/109063/4 "2017-11-24T19:46:44Z")

</div>

You need to pass a Content-Type to tell elasticsearch that you want to communicate in JSon.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 22, 2017, 7:46pm UTC](https://discuss.elastic.co/t/network-host-issue/109063/5 "2017-12-22T19:46:51Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
