# New 2.1.1 cluster forms with errors \[SOLVED\]

**URL:** <https://discuss.elastic.co/t/new-2-1-1-cluster-forms-with-errors-solved/37994>\
**Category:** Elasticsearch\
**Created:** [December 27, 2015, 3:44am UTC](https://discuss.elastic.co/t/new-2-1-1-cluster-forms-with-errors-solved/37994 "2015-12-27T03:44:12Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![kawika](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kawika/32/52042_2.png) [@kawika](https://discuss.elastic.co/u/kawika)\
**Post date:** [December 27, 2015, 3:44am UTC](https://discuss.elastic.co/t/new-2-1-1-cluster-forms-with-errors-solved/37994/1 "2015-12-27T03:44:12Z")

</div>

Node 1: Master/Data  
Node 2: Master/ Data  
Node 3: Master

Node 1 & 2 form a cluster, have all imported data, queries and Marvel look great.  
Bringing up Node 3, Node 1 & 2 cluster/health shows 3 nodes, logs look good. Marvel says 3 nodes but doesn't show Node 3 in the Node list.

Problem is Node 3 logs do not show cluster messages like master found, cluster/health times out and it's generally unusable. It kind of looks like split-brain but only Node 3 thinks it is not in a cluster.

Thanks for any ideas to try.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [December 27, 2015, 4:02am UTC](https://discuss.elastic.co/t/new-2-1-1-cluster-forms-with-errors-solved/37994/2 "2015-12-27T04:02:08Z")

</div>

What do your configs look like?

---

<div class="post-metadata">

**Author:** ![kawika](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kawika/32/52042_2.png) [@kawika](https://discuss.elastic.co/u/kawika)\
**Post date:** [December 27, 2015, 4:15am UTC](https://discuss.elastic.co/t/new-2-1-1-cluster-forms-with-errors-solved/37994/3 "2015-12-27T04:15:38Z")

</div>

Here's what they look like. comments show difference between the three machines. - Thanks

> node.name: "node1" # node2 and node3  
> network.host: 192.168.20.11 # .12 and .13  
> action.destructive\_requires\_name: true  
> bootstrap.mlockall: true  
> cluster.name: analytics  
> discovery.zen.minimum\_master\_nodes: 2  
> discovery.zen.ping.multicast.enabled: false  
> discovery.zen.ping.timeout: 15s  
> discovery.zen.ping.unicast.hosts: ["192.168.20.11", "192.168.20.12", "192.168.20.13"]  
> gateway.expected\_nodes: 2  
> gateway.recover\_after\_nodes: 1  
> gateway.recover\_after\_time: 5m  
> http.cors.enabled: true  
> index.cache.field.expire: 5m  
> index.number\_of\_replicas: 1  
> index.number\_of\_shards: 5  
> indices.fielddata.cache.size: 3GB  
> node.data: true # false for node3  
> node.master: true  
> path.data: "/mnt/ssd/elasticsearch"

---

<div class="post-metadata">

**Author:** ![kawika](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kawika/32/52042_2.png) [@kawika](https://discuss.elastic.co/u/kawika)\
**Post date:** [December 27, 2015, 4:27am UTC](https://discuss.elastic.co/t/new-2-1-1-cluster-forms-with-errors-solved/37994/4 "2015-12-27T04:27:33Z")

</div>

Turned on log debug level on node3 192.168.20.13. The following set of messages just repeats.

> [2015-12-26 20:11:53,687][DEBUG][transport.netty] [node3] connected to node [{#zen\_unicast\_4#}{192.168.20.11}{192.168.20.11:9300}]  
> [2015-12-26 20:11:53,687][DEBUG][transport.netty] [node3] connected to node [{#zen\_unicast\_2#}{192.168.20.12}{192.168.20.12:9300}]

> ...15 second pause...

> [2015-12-26 20:22:08,702][DEBUG][transport.netty] [node3] disconnecting from [{#zen\_unicast\_4#}{192.168.20.11}{192.168.20.11:9300}] due to explicit disconnect call  
> [2015-12-26 20:22:08,702][DEBUG][discovery.zen] [node3] filtered ping responses: (filter\_client[true], filter\_data[false])  
> --\> ping\_response{node [{node1}{jrPBHHpuQgqrYlJvA5Qhcg}{192.168.20.11}{192.168.20.11:9300}{master=true}], id[365], master [{node2}{5\_5TIHtiRC-FvuqZzzYjTw}{192.168.20.12}{192.168.20.12:9300}{master=true}], hasJoinedOnce [true], cluster\_name[analytics]}  
> --\> ping\_response{node [{node2}{5\_5TIHtiRC-FvuqZzzYjTw}{192.168.20.12}{192.168.20.12:9300}{master=true}], id[364], master [{node2}{5\_5TIHtiRC-FvuqZzzYjTw}{192.168.20.12}{192.168.20.12:9300}{master=true}], hasJoinedOnce [true], cluster\_name[analytics]}  
> [2015-12-26 20:22:08,702][DEBUG][transport.netty] [node3] disconnecting from [{#zen\_unicast\_2#}{192.168.20.12}{192.168.20.12:9300}] due to explicit disconnect call  
> [2015-12-26 20:22:08,707][DEBUG][discovery.zen.publish] [node3] received diff for but don't have any local cluster state - requesting full state  
> [2015-12-26 20:22:08,812][DEBUG][cluster.service] [node3] processing [finalize\_join ({node2}{5\_5TIHtiRC-FvuqZzzYjTw}{192.168.20.12}{192.168.20.12:9300}{master=true})]: execute  
> [2015-12-26 20:22:08,812][DEBUG][discovery.zen] [node3] no master node is set, despite of join request completing. retrying pings.  
> [2015-12-26 20:22:08,812][DEBUG][cluster.service] [node3] processing [finalize\_join ({node2}{5\_5TIHtiRC-FvuqZzzYjTw}{192.168.20.12}{192.168.20.12:9300}{master=true})]: took 0s no change in cluster\_state  
> [2015-12-26 20:22:08,817][DEBUG][transport.netty] [node3] connected to node [{#zen\_unicast\_2#}{192.168.20.12}{192.168.20.12:9300}]  
> [2015-12-26 20:22:08,818][DEBUG][transport.netty] [node3] connected to node [{#zen\_unicast\_4#}{192.168.20.11}{192.168.20.11:9300}]

---

<div class="post-metadata">

**Author:** ![kawika](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kawika/32/52042_2.png) [@kawika](https://discuss.elastic.co/u/kawika)\
**Post date:** [December 27, 2015, 4:37am UTC](https://discuss.elastic.co/t/new-2-1-1-cluster-forms-with-errors-solved/37994/5 "2015-12-27T04:37:47Z")

</div>

> <https://github.com/elastic/elasticsearch/issues/13445>

I didn't install the license on the third node. Installed it and all is good.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:28pm UTC](https://discuss.elastic.co/t/new-2-1-1-cluster-forms-with-errors-solved/37994/6 "2017-07-05T23:28:31Z")

</div>


