# New install Metricbeat failing to run setup

**URL:** <https://discuss.elastic.co/t/new-install-metricbeat-failing-to-run-setup/314127>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [September 11, 2022, 12:54am UTC](https://discuss.elastic.co/t/new-install-metricbeat-failing-to-run-setup/314127 "2022-09-11T00:54:02Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![alexsamad](https://avatars.discourse-cdn.com/v4/letter/a/f9ae1b/32.png) [@alexsamad](https://discuss.elastic.co/u/alexsamad)\
**Post date:** [September 11, 2022, 12:54am UTC](https://discuss.elastic.co/t/new-install-metricbeat-failing-to-run-setup/314127/1 "2022-09-11T00:54:02Z")

</div>

Hi

got a new install, looking at metricbeat, I have it monitoring the ELK cluster, but I want the system plugin to work.  
I noticed the dashboards where missing so I tried

metricbeat setup --dashboards --index-management --pipelines -e -v

Think this is the problem

```auto
"error":{"root_cause":[{"type":"security_exception","reason":"action [cluster:admin/ilm/get] is unauthorized for user [metricbeat_internal] with roles [kibana_admin,monitoring_user], this action is granted by the cluster privileges [read_ilm,manage_ilm,manage,all]"}],"type":"security_exception","reason":"action [cluster:admin/ilm/get] is unauthorized for user [metricbeat_internal] with roles [kibana_admin,monitoring_user], this action is granted by the
cluster privileges [read_ilm,manage_ilm,manage,all]"},"status":403}

```

Not sure what to do now

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [September 11, 2022, 4:59am UTC](https://discuss.elastic.co/t/new-install-metricbeat-failing-to-run-setup/314127/2 "2022-09-11T04:59:12Z")

</div>

What user (with roles) do you have configured in the elasticsearch output section.

During set you need at least [these](https://www.elastic.co/guide/en/beats/metricbeat/current/privileges-to-setup-beats.html) privileges.

The error is saying you do not have the right privileges.

You could also use the `elastic` user.

2nd just run

`metricbeat setup -e`

Without all the other stuff...

---

<div class="post-metadata">

**Author:** ![alexsamad](https://avatars.discourse-cdn.com/v4/letter/a/f9ae1b/32.png) [@alexsamad](https://discuss.elastic.co/u/alexsamad)\
**Post date:** [September 11, 2022, 5:55am UTC](https://discuss.elastic.co/t/new-install-metricbeat-failing-to-run-setup/314127/3 "2022-09-11T05:55:19Z")

</div>

Hi

thanks, I add the user to kibana\_admin and monitoring\_user  
I couldn't find these other roles.

Guess I could just run it once to set things up, with elastic username and password.

But if you can point me to where I could read how to setup these other roles - couldn't find it in the doco

EDIT:  
I ran it with elastic username and password - passed via the cli

The only think left is  
Overwriting ILM policy is disabled. Set `setup.ilm.overwrite: true` for enabling.

Where to I set that ?

EDIT2  
where do I find the dashboard, I can see the metricbeats for the java processes, but not the output from the system module

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 9, 2022, 7:55am UTC](https://discuss.elastic.co/t/new-install-metricbeat-failing-to-run-setup/314127/4 "2022-10-09T07:55:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
