# New install of ElasticSearch Fail

**URL:** <https://discuss.elastic.co/t/new-install-of-elasticsearch-fail/185882>\
**Category:** Elasticsearch\
**Tags:** elastic-stack-machine-learning\
**Created:** [June 14, 2019, 3:15pm UTC](https://discuss.elastic.co/t/new-install-of-elasticsearch-fail/185882 "2019-06-14T15:15:48Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![sean-39](https://avatars.discourse-cdn.com/v4/letter/s/d78d45/32.png) [@sean-39](https://discuss.elastic.co/u/sean-39)\
**Post date:** [June 14, 2019, 3:15pm UTC](https://discuss.elastic.co/t/new-install-of-elasticsearch-fail/185882/1 "2019-06-14T15:15:48Z")

</div>

# ElasticSearch Service Fails

Any help would be nice! trying to play with and start learning ElasticStack but when i try to install on CentOS I hit failure straight away. Below I included information about the system, failure, and logs. Thanks in advance!

Followed RPM install: [https://www.elastic.co/guide/en/elasticsearch/reference/7.1/rpm.html](https://www.elastic.co/guide/en/elasticsearch/reference/7.1/rpm.html)

CentOS: CentOS Linux release 7.6.1810 (Core)

Elasticsearch 7.1.1

Results of: systemctl status elasticsearch

```
elasticsearch.service - Elasticsearch
   Loaded: loaded
   (/usr/lib/systemd/system/elasticsearch.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Fri 2019-06-14 10:50:48 EDT; 13min ago
   Docs: http://www.elastic.co
   Process: 14117 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)
   Main PID: 14117 (code=exited, status=1/FAILURE)
   Jun 14 10:50:22 ElasticStack.mybeda.com systemd[1]: Started Elasticsearch.
   Jun 14 10:50:23 ElasticStack.mybeda.com elasticsearch[14117]: OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
   Jun 14 10:50:48 ElasticStack.mybeda.com systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE
   Jun 14 10:50:48 ElasticStack.mybeda.com systemd[1]: Unit elasticsearch.service entered failed state.
   Jun 14 10:50:48 ElasticStack.mybeda.com systemd[1]: elasticsearch.service failed.

```

Elasticsearch Log: tail -n 50 /var/log/elasticsearch/elasticsearch.log

```
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) ~[elasticsearch-cli-7.1.1.jar:7.1.1]
at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-7.1.1.jar:7.1.1]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:115) ~[elasticsearch-7.1.1.jar:7.1.1]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-7.1.1.jar:7.1.1]
Caused by: org.elasticsearch.ElasticsearchException: Failed to create native process factories for Machine Learning
at org.elasticsearch.xpack.ml.MachineLearning.createComponents(MachineLearning.java:433) ~[?:?]
at org.elasticsearch.node.Node.lambda$new$9(Node.java:440) ~[elasticsearch-7.1.1.jar:7.1.1]
at java.util.stream.ReferencePipeline$7$1.accept(ReferencePipeline.java:271) ~[?:?]
at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1654) ~[?:?]
at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:484) ~[?:?]
at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:474) ~[?:?]
at java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:913) ~[?:?]
at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234) ~[?:?]
at java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:578) ~[?:?]
at org.elasticsearch.node.Node.<init>(Node.java:443) ~[elasticsearch-7.1.1.jar:7.1.1]
at org.elasticsearch.node.Node.<init>(Node.java:252) ~[elasticsearch-7.1.1.jar:7.1.1]
at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:211) ~[elasticsearch-7.1.1.jar:7.1.1]
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:211) ~[elasticsearch-7.1.1.jar:7.1.1]
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:325) ~[elasticsearch-7.1.1.jar:7.1.1]
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-7.1.1.jar:7.1.1]
... 6 more
Caused by: java.io.FileNotFoundException: /tmp/elasticsearch-11798504030955121450/controller_log_14117 (No such file or directory)
at java.io.FileInputStream.open0(Native Method) ~[?:?]
at java.io.FileInputStream.open(FileInputStream.java:213) ~[?:?]
at java.io.FileInputStream.<init>(FileInputStream.java:155) ~[?:?]
at java.io.FileInputStream.<init>(FileInputStream.java:110) ~[?:?]
at org.elasticsearch.xpack.ml.utils.NamedPipeHelper$PrivilegedInputPipeOpener.run(NamedPipeHelper.java:288) ~[?:?]
at org.elasticsearch.xpack.ml.utils.NamedPipeHelper$PrivilegedInputPipeOpener.run(NamedPipeHelper.java:277) ~[?:?]
at java.security.AccessController.doPrivileged(AccessController.java:310) ~[?:?]
at org.elasticsearch.xpack.ml.utils.NamedPipeHelper.openNamedPipeInputStream(NamedPipeHelper.java:130) ~[?:?]
at org.elasticsearch.xpack.ml.utils.NamedPipeHelper.openNamedPipeInputStream(NamedPipeHelper.java:97) ~[?:?]
at org.elasticsearch.xpack.ml.process.ProcessPipes.connectStreams(ProcessPipes.java:131) ~[?:?]
at org.elasticsearch.xpack.ml.process.NativeController.<init>(NativeController.java:61) ~[?:?]
at org.elasticsearch.xpack.ml.process.NativeControllerHolder.getNativeController(NativeControllerHolder.java:40) ~[?:?]
at org.elasticsearch.xpack.ml.MachineLearning.createComponents(MachineLearning.java:418) ~[?:?]
at org.elasticsearch.node.Node.lambda$new$9(Node.java:440) ~[elasticsearch-7.1.1.jar:7.1.1]
at java.util.stream.ReferencePipeline$7$1.accept(ReferencePipeline.java:271) ~[?:?]
at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1654) ~[?:?]
at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:484) ~[?:?]
at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:474) ~[?:?]
at java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:913) ~[?:?]
at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234) ~[?:?]
at java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:578) ~[?:?]
at org.elasticsearch.node.Node.<init>(Node.java:443) ~[elasticsearch-7.1.1.jar:7.1.1]
at org.elasticsearch.node.Node.<init>(Node.java:252) ~[elasticsearch-7.1.1.jar:7.1.1]
at org.elasticsearch.bootstrap.Bootstrap$5.<init>(Bootstrap.java:211) ~[elasticsearch-7.1.1.jar:7.1.1]
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:211) ~[elasticsearch-7.1.1.jar:7.1.1]
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:325) ~[elasticsearch-7.1.1.jar:7.1.1]
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:159) ~[elasticsearch-7.1.1.jar:7.1.1]
... 6 more
```

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [June 14, 2019, 10:23pm UTC](https://discuss.elastic.co/t/new-install-of-elasticsearch-fail/185882/2 "2019-06-14T22:23:26Z")

</div>

> [@sean-39](#):
>
> Elasticsearch Log: tail -n 50 /var/log/elasticsearch/elasticsearch.log
> 
> ```auto
> 
> ```

Can you show more of that please, there's relevant information prior to the end.

---

<div class="post-metadata">

**Author:** ![sean-39](https://avatars.discourse-cdn.com/v4/letter/s/d78d45/32.png) [@sean-39](https://discuss.elastic.co/u/sean-39)\
**Post date:** [June 14, 2019, 10:42pm UTC](https://discuss.elastic.co/t/new-install-of-elasticsearch-fail/185882/3 "2019-06-14T22:42:57Z")

</div>

Of course. Cleared the log and reproduced the issue.

Full log posted: [https://pastebin.com/embed\_js/tjmru6S1](https://pastebin.com/embed_js/tjmru6S1)

Thanks!

---

<div class="post-metadata">

**Author:** ![richcollier](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/richcollier/32/115035_2.png) [@richcollier](https://discuss.elastic.co/u/richcollier)\
**Post date:** [June 15, 2019, 11:17am UTC](https://discuss.elastic.co/t/new-install-of-elasticsearch-fail/185882/4 "2019-06-15T11:17:46Z")

</div>

Looks to be the same issue as reported in this thread: [Elasticsearch 7.1.1 Failed to create native process factories for Machine Learning](https://discuss.elastic.co/t/elasticsearch-7-1-1-failed-to-create-native-process-factories-for-machine-learning/184006)

Follow the suggestions there.

---

<div class="post-metadata">

**Author:** ![sean-39](https://avatars.discourse-cdn.com/v4/letter/s/d78d45/32.png) [@sean-39](https://discuss.elastic.co/u/sean-39)\
**Post date:** [June 18, 2019, 5:12pm UTC](https://discuss.elastic.co/t/new-install-of-elasticsearch-fail/185882/5 "2019-06-18T17:12:55Z")

</div>

Huge help! turns out i'm running AMD on Proxmox so this feature is not supported and me being a noob I was unaware of this.

`xpack.ml.enabled: false` fixed my issue.

@richcollier Thanks for the direction!!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 16, 2019, 5:18pm UTC](https://discuss.elastic.co/t/new-install-of-elasticsearch-fail/185882/6 "2019-07-16T17:18:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
