# New Install - Security Error

**URL:** https://discuss.elastic.co/t/new-install-security-error/307549
**Category:** Kibana
**Tags:** elastic-stack-security
**Created:** [June 17, 2022, 9:32pm UTC](https://discuss.elastic.co/t/new-install-security-error/307549 "2022-06-17T21:32:29Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![jhop](https://avatars.discourse-cdn.com/v4/letter/j/ebca7d/32.png) [@jhop](https://discuss.elastic.co/u/jhop)
#### Post date: [June 17, 2022, 9:32pm UTC](https://discuss.elastic.co/t/new-install-security-error/307549/1 "2022-06-17T21:32:29Z")

</div>

Hi I am new to Elastic. I have just installed Elasticsearch and Kibana. I am able to hit Elasticsearch on my browser. I configured it with basic security. I am now trying to connect with Kibana and I get "Kibana server is not ready yet" displayed on the browser. When I looked at the kibana.log the error message was:

["error","savedobjects-service"],"pid":412971,"message":"[.kibana] Action failed with 'security\_exception: [security\_exception] Reason: action [indices:admin/mapping/put] is unauthorized for user [elastic] wit  
h roles [superuser] on restricted indices [.kibana\_7.17.4\_001], this action is granted by the index privileges [manage,all]'

In my kibana.yml file I have used my Elasticsearch user and password as below:

```auto
elasticsearch.username: "elastic"
elasticsearch.password: "MyPasswordHere"

```

Thanks in advance for any help you could give me.

- jason

---

<div class="post-metadata">

### Author: ![bhavyarm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bhavyarm/32/22392_2.png) [@bhavyarm](https://discuss.elastic.co/u/bhavyarm)
#### Post date: [June 17, 2022, 9:48pm UTC](https://discuss.elastic.co/t/new-install-security-error/307549/2 "2022-06-17T21:48:38Z")

</div>

Hi,

So the elasticsearch.username here is for kibana\_system as you can see in the commented lines in kibana.yml. Did you set up the password? Here is our doc which explains it.

> **[Built-in users | Elasticsearch Guide \[7.17\] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/7.17/built-in-users.html)**

# If your Elasticsearch is protected with basic authentication, these settings provide

# the username and password that the Kibana server uses to perform maintenance on the Kibana

# index at startup. Your Kibana users still need to authenticate with Elasticsearch, which

# is proxied through the Kibana server.

#elasticsearch.username: "kibana\_system"  
#elasticsearch.password: "pass"

Thanks,  
Bhavya

---

<div class="post-metadata">

### Author: ![jhop](https://avatars.discourse-cdn.com/v4/letter/j/ebca7d/32.png) [@jhop](https://discuss.elastic.co/u/jhop)
#### Post date: [June 17, 2022, 10:06pm UTC](https://discuss.elastic.co/t/new-install-security-error/307549/3 "2022-06-17T22:06:52Z")

</div>

Hi thanks for your reply. I used the Elasticsearch-reset-password command to set my password and used that password in the Elasticsearch.password field. I used the built-in user elastic for the Elasticsearch.username field.

---

<div class="post-metadata">

### Author: ![jhop](https://avatars.discourse-cdn.com/v4/letter/j/ebca7d/32.png) [@jhop](https://discuss.elastic.co/u/jhop)
#### Post date: [June 21, 2022, 12:36pm UTC](https://discuss.elastic.co/t/new-install-security-error/307549/4 "2022-06-21T12:36:56Z")

</div>

I still have not solved this problem. Any more Ideas?

---

<div class="post-metadata">

### Author: ![Yang\_Wang](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yang_wang/32/48857_2.png) [@Yang\_Wang](https://discuss.elastic.co/u/Yang_Wang)
#### Post date: [June 22, 2022, 1:04am UTC](https://discuss.elastic.co/t/new-install-security-error/307549/5 "2022-06-22T01:04:12Z")

</div>

You need to use the `kibana_system` user for connecting kibana to elasticsearch as suggested above.

---

<div class="post-metadata">

### Author: ![jhop](https://avatars.discourse-cdn.com/v4/letter/j/ebca7d/32.png) [@jhop](https://discuss.elastic.co/u/jhop)
#### Post date: [June 22, 2022, 2:11pm UTC](https://discuss.elastic.co/t/new-install-security-error/307549/6 "2022-06-22T14:11:09Z")

</div>

I'm sorry I misunderstood. Thanks both of you.

Best regards,

Jason

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 20, 2022, 2:11pm UTC](https://discuss.elastic.co/t/new-install-security-error/307549/7 "2022-07-20T14:11:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
