# New installation - Unable to connect to kibana 7.9.2

**URL:** <https://discuss.elastic.co/t/new-installation-unable-to-connect-to-kibana-7-9-2/256579>\
**Category:** Kibana\
**Created:** [November 24, 2020, 10:00pm UTC](https://discuss.elastic.co/t/new-installation-unable-to-connect-to-kibana-7-9-2/256579 "2020-11-24T22:00:47Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![drivera](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/drivera/32/39900_2.png) [@drivera](https://discuss.elastic.co/u/drivera)\
**Post date:** [November 24, 2020, 10:00pm UTC](https://discuss.elastic.co/t/new-installation-unable-to-connect-to-kibana-7-9-2/256579/1 "2020-11-24T22:00:47Z")

</div>

Unable to connect to my kibana server. When connecting through my browser I get the message "refused to connect". This is a new installation. No visible errors in the kibana.log file. Not sure where to go from here. I'm including my yml file in the bottom.

The port is listening:

```auto
tcp 0 0 127.0.0.1:5601 0.0.0.0:* LISTEN 5184/node           

```

My ES cluster is up:

```auto
{
  "cluster_name" : "staging",
  "status" : "green",
  "timed_out" : false,
  "number_of_nodes" : 7,
  "number_of_data_nodes" : 7,
  "active_primary_shards" : 6,
  "active_shards" : 12,
  "relocating_shards" : 0,
  "initializing_shards" : 0,
  "unassigned_shards" : 0,
  "delayed_unassigned_shards" : 0,
  "number_of_pending_tasks" : 0,
  "number_of_in_flight_fetch" : 0,
  "task_max_waiting_in_queue_millis" : 0,
  "active_shards_percent_as_number" : 100.0

```

excerpt of yml file

```auto
server.port: 5601
server.host: "ist0002591"
server.name: "ist0002591"

# My Elasticsearch client node to use for all my queries. I've also tried connecting directly to the ES master with no cigar.
elasticsearch.hosts: ["http://ist0002583:9200"]

```

---

<div class="post-metadata">

**Author:** ![Dzmitry](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dzmitry/32/65026_2.png) [@Dzmitry](https://discuss.elastic.co/u/Dzmitry)\
**Post date:** [November 25, 2020, 3:59pm UTC](https://discuss.elastic.co/t/new-installation-unable-to-connect-to-kibana-7-9-2/256579/2 "2020-11-25T15:59:51Z")

</div>

Hi @drivera,

It sounds like a network issue. Does it work from localhost - the machine that is running Kibana?

If it does, but does not from external machines, are you sure the port is open on the machine running Kibana? Maybe hostname is incorrectly resolved by external machine?

Regards, Dzmitry

---

<div class="post-metadata">

**Author:** ![drivera](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/drivera/32/39900_2.png) [@drivera](https://discuss.elastic.co/u/drivera)\
**Post date:** [November 30, 2020, 4:43pm UTC](https://discuss.elastic.co/t/new-installation-unable-to-connect-to-kibana-7-9-2/256579/3 "2020-11-30T16:43:46Z")

</div>

Running a the sudo curl -l [http://localhost:5601/status](http://localhost:5601/status) from the local host, I get a bunch of output, like the output below which I think means kibana is running"

```auto
[~]$ sudo curl -l http://localhost:5601/status
<!DOCTYPE html><html lang="en"><head><meta charSet="utf-8"/><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/><meta name="viewport" content="width=device-width"/><title>Elastic</title><style>
        
        @font-face {
          font-family: 'Inter UI';
          font-style: normal;
          font-weight: 100;
          src: url('/ui/fonts/inter_ui/Inter-UI-Thin-BETA.woff2') format('woff2'), url('/ui/fonts/inter_ui/Inter-UI-Thin-BETA.woff') format('woff');
        }

```

However, when trying to use the curl command above from a remote host, I get the following failure:

```auto
[remote-host ~]$ sudo curl -l http://ist0002591:5601/status
curl: (7) Failed to connect to ist0002591 port 5601: Connection refused

```

On the kibana host I can see that the port 5601 is listening.

```auto
tcp 0 0 127.0.0.1:5601 0.0.0.0:* LISTEN 6105/node  

```

Any ideas? Firewall issue maybe?

---

<div class="post-metadata">

**Author:** ![drivera](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/drivera/32/39900_2.png) [@drivera](https://discuss.elastic.co/u/drivera)\
**Post date:** [November 30, 2020, 4:52pm UTC](https://discuss.elastic.co/t/new-installation-unable-to-connect-to-kibana-7-9-2/256579/4 "2020-11-30T16:52:08Z")

</div>

Update: Running the command below, I get confirmation Kibana is running on the localhost

```auto
[~]$ sudo curl -XGET http://localhost:5601/status -I |more   
  % Total % Received % Xferd Average Speed Time Time Time Current
                                 Dload Upload Total Spent Left Speed
  0 114k 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
HTTP/1.1 200 OK
content-type: text/html; charset=utf-8
content-security-policy: script-src 'unsafe-eval' 'self'; worker-src blob: 'self'; style-src 'unsafe-
inline' 'self'
kbn-name: ist0002591.esri.com
kbn-license-sig: 9cbb27f1e1e6639cfc78834318161360106cc8c727416816dff99cc3ecc2ed90
kbn-xpack-sig: 0213ac89bd6c118858950458439d872f
cache-control: private, no-cache, no-store, must-revalidate
content-length: 117422
vary: accept-encoding
accept-ranges: bytes
Date: Mon, 30 Nov 2020 16:50:44 GMT
Connection: keep-alive

```

---

<div class="post-metadata">

**Author:** ![drivera](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/drivera/32/39900_2.png) [@drivera](https://discuss.elastic.co/u/drivera)\
**Post date:** [November 30, 2020, 8:05pm UTC](https://discuss.elastic.co/t/new-installation-unable-to-connect-to-kibana-7-9-2/256579/5 "2020-11-30T20:05:27Z")

</div>

Update: Resolved!

I noticed when running the netstat -nltup command that port 5601 was bound to my localhost, instead of my internal IP address:

```auto
tcp 0 0 127.0.0.1:5601 0.0.0.0:* LISTEN 6105/node  

```

I edited my /etc/hosts file which had a bogus reference to the localhost and that fixed the issue. Now port 5601 is bound to the IP.

```auto
tcp 0 0 10.x.x.x:5601 0.0.0.0:* LISTEN 1204/node     
``
Thanks for your help @Dzmitry
```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 28, 2020, 8:05pm UTC](https://discuss.elastic.co/t/new-installation-unable-to-connect-to-kibana-7-9-2/256579/6 "2020-12-28T20:05:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
