# New logstash 6.6 fail to start

**URL:** https://discuss.elastic.co/t/new-logstash-6-6-fail-to-start/166854
**Category:** Logstash
**Created:** [February 3, 2019, 7:08am UTC](https://discuss.elastic.co/t/new-logstash-6-6-fail-to-start/166854 "2019-02-03T07:08:29Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![yossiv](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yossiv/32/10662_2.png) [@yossiv](https://discuss.elastic.co/u/yossiv)
#### Post date: [February 3, 2019, 7:08am UTC](https://discuss.elastic.co/t/new-logstash-6-6-fail-to-start/166854/1 "2019-02-03T07:08:29Z")

</div>

Hi Guys,  
i have new logstash installed. but for some reason it faile to start.  
1 input and output ( the input and output works fine to my on other logstash system i have)  
plugin were installed already

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/4/c/4cc6f7c84091fa9adaff23b6c4a8c208320d3088.png)  
appreciate your help

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [February 3, 2019, 9:05am UTC](https://discuss.elastic.co/t/new-logstash-6-6-fail-to-start/166854/2 "2019-02-03T09:05:15Z")

</div>

Please don't post pictures of text, they are difficult to read and some people may not be even able to see them 🙂

---

<div class="post-metadata">

### Author: ![yossiv](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yossiv/32/10662_2.png) [@yossiv](https://discuss.elastic.co/u/yossiv)
#### Post date: [February 3, 2019, 9:54am UTC](https://discuss.elastic.co/t/new-logstash-6-6-fail-to-start/166854/3 "2019-02-03T09:54:33Z")

</div>

[2019-02-03T17:53:45,087][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2019-02-03T17:54:07,172][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"6.6.0"}  
[2019-02-03T17:54:08,418][ERROR][logstash.agent] Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"LogStash::ConfigurationError", :message=\>"Expected one of #, input, filter, output at line 37, column 2 (byte 982) after ", :backtrace=\>["/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:41:in `compile_imperative'", "/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:49:in`compile\_graph'", "/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:11:in `block in compile_sources'", "org/jruby/RubyArray.java:2486:in`map'", "/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:10:in `compile_sources'", "org/logstash/execution/AbstractPipelineExt.java:149:in`initialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:22:in `initialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:90:in`initialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline\_action/create.rb:42:in `block in execute'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:92:in`block in exclusive'", "org/jruby/ext/thread/Mutex.java:148:in `synchronize'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:92:in`exclusive'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline\_action/create.rb:38:in `execute'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:317:in`block in converge\_state'"]}  
[2019-02-03T17:54:08,658][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}

---

<div class="post-metadata">

### Author: ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)
#### Post date: [February 3, 2019, 9:59am UTC](https://discuss.elastic.co/t/new-logstash-6-6-fail-to-start/166854/4 "2019-02-03T09:59:17Z")

</div>

It seems like you have an issue at line 37 in your config, so it would help you could show it.

---

<div class="post-metadata">

### Author: ![yossiv](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yossiv/32/10662_2.png) [@yossiv](https://discuss.elastic.co/u/yossiv)
#### Post date: [February 3, 2019, 11:52am UTC](https://discuss.elastic.co/t/new-logstash-6-6-fail-to-start/166854/5 "2019-02-03T11:52:08Z")

</div>

i dont think this related to the input conf. i fix it and same thing it fails on the same errors

# Read all documents from Elasticsearch matching the given query

elasticsearch {  
tags =\> ["AWS"]  
hosts =\> "10.120.55.80:9200"  
index =\> "graylog\__"  
schedule =\> "_/5 \* \* \* \*"  
query =\> '{  
"query": {  
"bool": {  
"must": [  
{  
"query\_string": {  
"default\_field": "F5\_RequestStats",  
"fields": [  
"Profit"  
],  
"query": " (K2\_GameAction:ProcessSlotMachine AND F5\_ResponseCode:200) "  
}  
}  
],  
"filter": {  
"range": {  
"timestamp": {  
"gte": "now-3m/m",  
"lt": "now/m"  
}  
}  
}  
}  
}  
}'  
}  
}

---

<div class="post-metadata">

### Author: ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)
#### Post date: [February 3, 2019, 12:54pm UTC](https://discuss.elastic.co/t/new-logstash-6-6-fail-to-start/166854/6 "2019-02-03T12:54:45Z")

</div>

The configuration you posted is only 34 lines, so it is hard to say what logstash objected to at line 37. However, given that it does not print any configuration where it says 'after "' my guess would be an extra trailing } in the file.

```
schedule => "*/5 "

```

That is not a valid schedule.

---

<div class="post-metadata">

### Author: ![yossiv](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yossiv/32/10662_2.png) [@yossiv](https://discuss.elastic.co/u/yossiv)
#### Post date: [February 3, 2019, 3:19pm UTC](https://discuss.elastic.co/t/new-logstash-6-6-fail-to-start/166854/7 "2019-02-03T15:19:59Z")

</div>

please see above it fixed,  
but still same error  
[2019-02-03T23:17:20,423][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2019-02-03T23:17:47,908][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"6.6.0"}  
[2019-02-03T23:17:49,087][ERROR][logstash.agent] Failed to execute action {:action=\>LogStash::PipelineAction::Create/pipeline\_id:main, :exception=\>"LogStash::ConfigurationError", :message=\>"Expected one of #, input, filter, output at line 37, column 2 (byte 982) after ", :backtrace=\>["/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:41:in `compile_imperative'", "/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:49:in`compile\_graph'", "/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:11:in `block in compile_sources'", "org/jruby/RubyArray.java:2486:in`map'", "/usr/share/logstash/logstash-core/lib/logstash/compiler.rb:10:in `compile_sources'", "org/logstash/execution/AbstractPipelineExt.java:149:in`initialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:22:in `initialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline.rb:90:in`initialize'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline\_action/create.rb:42:in `block in execute'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:92:in`block in exclusive'", "org/jruby/ext/thread/Mutex.java:148:in `synchronize'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:92:in`exclusive'", "/usr/share/logstash/logstash-core/lib/logstash/pipeline\_action/create.rb:38:in `execute'", "/usr/share/logstash/logstash-core/lib/logstash/agent.rb:317:in`block in converge\_state'"]}

---

<div class="post-metadata">

### Author: ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)
#### Post date: [February 3, 2019, 4:26pm UTC](https://discuss.elastic.co/t/new-logstash-6-6-fail-to-start/166854/8 "2019-02-03T16:26:59Z")

</div>

You need to show us all 37 lines of the configuration. Select the text in the edit pane and click on \</\> in the tool bar above to quote it so that formatting is retained.

---

<div class="post-metadata">

### Author: ![yossiv](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yossiv/32/10662_2.png) [@yossiv](https://discuss.elastic.co/u/yossiv)
#### Post date: [February 5, 2019, 12:39pm UTC](https://discuss.elastic.co/t/new-logstash-6-6-fail-to-start/166854/9 "2019-02-05T12:39:28Z")

</div>

Hi guys,  
all good , i was missing "output" command at output file  
we can close this issue

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 5, 2019, 12:39pm UTC](https://discuss.elastic.co/t/new-logstash-6-6-fail-to-start/166854/10 "2019-03-05T12:39:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
