# Newly installed metricbeat=\>logstash 6.0.0 Error (BeatsParser InvalidFrameProtocolException: Invalid Frame Type)

**URL:** <https://discuss.elastic.co/t/newly-installed-metricbeat-logstash-6-0-0-error-beatsparser-invalidframeprotocolexception-invalid-frame-type/115147>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [January 11, 2018, 5:11pm UTC](https://discuss.elastic.co/t/newly-installed-metricbeat-logstash-6-0-0-error-beatsparser-invalidframeprotocolexception-invalid-frame-type/115147 "2018-01-11T17:11:11Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![jamesliu\_london](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jamesliu_london/32/38602_2.png) [@jamesliu\_london](https://discuss.elastic.co/u/jamesliu_london)\
**Post date:** [January 11, 2018, 5:11pm UTC](https://discuss.elastic.co/t/newly-installed-metricbeat-logstash-6-0-0-error-beatsparser-invalidframeprotocolexception-invalid-frame-type/115147/1 "2018-01-11T17:11:11Z")

</div>

When connecting metricbeats to logstash, I'm metricbeats is unable to connect:  
"Caused by: org.logstash.beats.BeatsParser$InvalidFrameProtocolException: Invalid Frame Type, received"

We have EL5.6+Xpack , Kib5.6 +Xpack (NonSSL passwords for EL5.6)

- I installed Metricbeat 6.1.1 (with a password and hooked it into ES with no problems.

- I installed Logstash 5.x and upgraded it to EL 6.x (with a username + password), and it connected to EL fine. (using http inputs). I updated the logstash-input-beats.

- When I change Logstash to "input { beats { port =\> "5044" } }". And repointed MetricBeat (from EL to Logstash (with and without the password in the now-defunct EL stanza), I get:  
"Caused by: org.logstash.beats.BeatsParser$InvalidFrameProtocolException: Invalid Frame Type, received"

From MetricBeat I get a connection reset by peer.

===  
Metric Beat config  
egrep -v "^[]_#|^$" /etc/metricbeat/metricbeat.yml  
metricbeat.config.modules:  
path: ${path.config}/modules.d/_.yml  
reload.enabled: true  
reload.period: 10s  
setup.template.settings:  
index.number\_of\_shards: 1  
index.codec: best\_compression  
setup.kibana:  
host: "localhost:5601"  
output.elasticsearch:  
hosts: ["localhost:5044", "10.x.y.z:5044"]  
logging.level: debug

========

input {  
beats {  
port =\> "5044"  
}  
}  
filter {  
grok {  
match =\> {"message" =\> [ "hdfs%{GREEDYDATA:datanode\_process}org.apache.hadoop.hdfs.server.datanode.DataNode",  
"##REAL##%{GREEDYDATA:real\_message}",  
"%{GREEDYDATA:basic\_message}"]}  
}  
if [datanode\_process] {  
mutate {  
replace =\> { "message" =\> "%{datanode\_process}" }  
add\_tag =\> ["DataNode"]  
}  
} else if [real\_message] {  
mutate {  
replace =\> { "message" =\> "%{real\_message}" }  
add\_tag =\> ["Real"]  
}  
} else {  
mutate {  
add\_tag =\> ["Basic"]  
}  
}  
}  
output {  
elasticsearch {  
hosts =\> ["xxx:9200", "yyy:9200", "zzz:9200"]  
user =\> username  
password =\> pass  
manage\_template =\> false  
index =\> "%{[@metadata][beat]}-%{+YYYY.MM.dd}"  
document\_type =\> "%{[@metadata][type]}"  
}  
}

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [January 11, 2018, 5:34pm UTC](https://discuss.elastic.co/t/newly-installed-metricbeat-logstash-6-0-0-error-beatsparser-invalidframeprotocolexception-invalid-frame-type/115147/2 "2018-01-11T17:34:25Z")

</div>

Please share your Metricbeat config.

---

<div class="post-metadata">

**Author:** ![jamesliu\_london](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jamesliu_london/32/38602_2.png) [@jamesliu\_london](https://discuss.elastic.co/u/jamesliu_london)\
**Post date:** [January 11, 2018, 5:41pm UTC](https://discuss.elastic.co/t/newly-installed-metricbeat-logstash-6-0-0-error-beatsparser-invalidframeprotocolexception-invalid-frame-type/115147/3 "2018-01-11T17:41:06Z")

</div>

Added.

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [January 11, 2018, 5:54pm UTC](https://discuss.elastic.co/t/newly-installed-metricbeat-logstash-6-0-0-error-beatsparser-invalidframeprotocolexception-invalid-frame-type/115147/4 "2018-01-11T17:54:41Z")

</div>

> [@jamesliu\_london](#):
>
> output.elasticsearch:
> 
> hosts: ["localhost:5044", "10.x.y.z:5044"]

Try using the Logstash output. [Configure the Logstash output | Metricbeat Reference [8.11] | Elastic](https://www.elastic.co/guide/en/beats/metricbeat/current/logstash-output.html)

---

<div class="post-metadata">

**Author:** ![jamesliu\_london](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jamesliu_london/32/38602_2.png) [@jamesliu\_london](https://discuss.elastic.co/u/jamesliu_london)\
**Post date:** [January 11, 2018, 6:15pm UTC](https://discuss.elastic.co/t/newly-installed-metricbeat-logstash-6-0-0-error-beatsparser-invalidframeprotocolexception-invalid-frame-type/115147/5 "2018-01-11T18:15:19Z")

</div>

> [@jamesliu\_london](#):
>
> etricbeat.config.modules:
> 
> path: ${path.config}/modules.d/.yml
> 
> reload.enabled: true
> 
> reload.period: 10s
> 
> setup.template.settings:
> 
> index.number\_of\_shards: 1
> 
> index.codec: best\_compression
> 
> setup.kibana:
> 
> host: "localhost:5601"
> 
> output.elasticsearch:
> 
> hosts: ["localhost:5044", "10.x.y.z:5044"]
> 
> logging.level: debug

Thank you. Forgot to change the comments in the config.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 8, 2018, 6:15pm UTC](https://discuss.elastic.co/t/newly-installed-metricbeat-logstash-6-0-0-error-beatsparser-invalidframeprotocolexception-invalid-frame-type/115147/6 "2018-02-08T18:15:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
