# Nginx filebeat logging

**URL:** <https://discuss.elastic.co/t/nginx-filebeat-logging/120650>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [February 20, 2018, 1:41pm UTC](https://discuss.elastic.co/t/nginx-filebeat-logging/120650 "2018-02-20T13:41:35Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![clock21am](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/clock21am/32/54362_2.png) [@clock21am](https://discuss.elastic.co/u/clock21am)\
**Post date:** [February 20, 2018, 1:41pm UTC](https://discuss.elastic.co/t/nginx-filebeat-logging/120650/1 "2018-02-20T13:41:35Z")

</div>

Hi,

we are trying to log our nginx log to elasticsearch. our code is working fine and logging in es.  
but while creating dashboard it is showing following

 ![1](https://us1.discourse-cdn.com/elastic/original/3X/c/0/c0b2e53e3f5f7f3ff28a4f7dc04dbd650a7a0862.png) errors in our kibana-dashboard  
dashboard is showing the following error - ![4](https://us1.discourse-cdn.com/elastic/original/3X/6/4/641ca32ea2f2f511ab0171bca5ecdec9787a3cca.png)  
and this is our filebeat.yml ![3](https://us1.discourse-cdn.com/elastic/original/3X/4/5/45d53c8556ea40d89e3d2951e36c15d11d7e0856.png)

---

<div class="post-metadata">

**Author:** ![pierhugues](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pierhugues/32/48383_2.png) [@pierhugues](https://discuss.elastic.co/u/pierhugues)\
**Post date:** [February 20, 2018, 3:17pm UTC](https://discuss.elastic.co/t/nginx-filebeat-logging/120650/2 "2018-02-20T15:17:56Z")

</div>

Hello,

Are our provided Nginx dashboard working for you? Is this error only happen when creating custom dashboard?

---

<div class="post-metadata">

**Author:** ![clock21am](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/clock21am/32/54362_2.png) [@clock21am](https://discuss.elastic.co/u/clock21am)\
**Post date:** [February 20, 2018, 3:31pm UTC](https://discuss.elastic.co/t/nginx-filebeat-logging/120650/3 "2018-02-20T15:31:23Z")

</div>

your nginx dashboard is only showing the error.  
no this happens in all the dashboard creating for nginx and apache.

---

<div class="post-metadata">

**Author:** ![pierhugues](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pierhugues/32/48383_2.png) [@pierhugues](https://discuss.elastic.co/u/pierhugues)\
**Post date:** [February 22, 2018, 3:42pm UTC](https://discuss.elastic.co/t/nginx-filebeat-logging/120650/5 "2018-02-22T15:42:31Z")

</div>

Is there any error when you start Filebeat, there is an error finding the index-pattern.  
I wonder if the nginx data is actually send to ES.

---

<div class="post-metadata">

**Author:** ![clock21am](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/clock21am/32/54362_2.png) [@clock21am](https://discuss.elastic.co/u/clock21am)\
**Post date:** [February 23, 2018, 3:58pm UTC](https://discuss.elastic.co/t/nginx-filebeat-logging/120650/6 "2018-02-23T15:58:07Z")

</div>

There is no error when we start Filebeat.  
Yes these are nginx logs only who are going to Elasticsearch.

---

<div class="post-metadata">

**Author:** ![ruflin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ruflin/32/3116_2.png) [@ruflin](https://discuss.elastic.co/u/ruflin)\
**Post date:** [March 4, 2018, 5:39am UTC](https://discuss.elastic.co/t/nginx-filebeat-logging/120650/8 "2018-03-04T05:39:36Z")

</div>

Could you share the versions you are using of the different tools?

Please keep in mind that this is a community forum and also Elastic{ON} is/was happening.

---

<div class="post-metadata">

**Author:** ![Obay\_Abdelgader](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/obay_abdelgader/32/43161_2.png) [@Obay\_Abdelgader](https://discuss.elastic.co/u/Obay_Abdelgader)\
**Post date:** [March 5, 2018, 8:21am UTC](https://discuss.elastic.co/t/nginx-filebeat-logging/120650/9 "2018-03-05T08:21:42Z")

</div>

I think you are missing the geoip plugin, if so run the following commands to install it:  
cd "elasticserch directory"  
bin/elasticsearch-plugin install ingest-geoip

---

<div class="post-metadata">

**Author:** ![clock21am](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/clock21am/32/54362_2.png) [@clock21am](https://discuss.elastic.co/u/clock21am)\
**Post date:** [March 6, 2018, 7:38am UTC](https://discuss.elastic.co/t/nginx-filebeat-logging/120650/10 "2018-03-06T07:38:25Z")

</div>

No, the issue was that when we create the dashboard's there are un-wanted visual created, and many of the fields were invalid. whenever u create the dashboard u need to remove them. Need to modify the filter pattern.

---

<div class="post-metadata">

**Author:** ![clock21am](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/clock21am/32/54362_2.png) [@clock21am](https://discuss.elastic.co/u/clock21am)\
**Post date:** [March 6, 2018, 7:38am UTC](https://discuss.elastic.co/t/nginx-filebeat-logging/120650/11 "2018-03-06T07:38:49Z")

</div>

Thanks for replying but we are done with issue.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 3, 2018, 7:38am UTC](https://discuss.elastic.co/t/nginx-filebeat-logging/120650/12 "2018-04-03T07:38:52Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
