# No cached mapping Error

**URL:** https://discuss.elastic.co/t/no-cached-mapping-error/254694
**Category:** Kibana
**Created:** [November 8, 2020, 10:59pm UTC](https://discuss.elastic.co/t/no-cached-mapping-error/254694 "2020-11-08T22:59:40Z")
**Posts on this page:** 9
**Page:** 1

<div class="post-metadata">

### Author: ![droidus](https://avatars.discourse-cdn.com/v4/letter/d/13edae/32.png) [@droidus](https://discuss.elastic.co/u/droidus)
#### Post date: [November 8, 2020, 10:59pm UTC](https://discuss.elastic.co/t/no-cached-mapping-error/254694/1 "2020-11-08T22:59:40Z")

</div>

I am getting this message on my filebeats index. I went to Management \> Selected Index, then Refresh. But I still see this error. For example, I am looking for the log.file.path. Strange thing is, when I go to search for it in Management \> Index, and then filter for this value, it does not show up. Am I missing something?

---

<div class="post-metadata">

### Author: ![wylie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wylie/32/81794_2.png) [@wylie](https://discuss.elastic.co/u/wylie)
#### Post date: [November 11, 2020, 4:58pm UTC](https://discuss.elastic.co/t/no-cached-mapping-error/254694/2 "2020-11-11T16:58:44Z")

</div>

You didn't say where you were seeing the message, but it's probably in Discover? This happens when the Discover is trying to show you a field, but the mapping is missing. So if `log.file.path` is missing in your mappings, you should fix that.

---

<div class="post-metadata">

### Author: ![droidus](https://avatars.discourse-cdn.com/v4/letter/d/13edae/32.png) [@droidus](https://discuss.elastic.co/u/droidus)
#### Post date: [November 12, 2020, 5:52pm UTC](https://discuss.elastic.co/t/no-cached-mapping-error/254694/3 "2020-11-12T17:52:01Z")

</div>

Yes, that is correct.  
How do I add this to my mappings?

---

<div class="post-metadata">

### Author: ![wylie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wylie/32/81794_2.png) [@wylie](https://discuss.elastic.co/u/wylie)
#### Post date: [November 12, 2020, 6:04pm UTC](https://discuss.elastic.co/t/no-cached-mapping-error/254694/4 "2020-11-12T18:04:33Z")

</div>

It sounds like something has gotten out of sync between filebeat and kibana. I would recommend re-running the setup code from filebeat: [https://www.elastic.co/guide/en/beats/filebeat/current/filebeat-installation-configuration.html#setup-assets](https://www.elastic.co/guide/en/beats/filebeat/current/filebeat-installation-configuration.html#setup-assets)

---

<div class="post-metadata">

### Author: ![droidus](https://avatars.discourse-cdn.com/v4/letter/d/13edae/32.png) [@droidus](https://discuss.elastic.co/u/droidus)
#### Post date: [November 12, 2020, 6:56pm UTC](https://discuss.elastic.co/t/no-cached-mapping-error/254694/5 "2020-11-12T18:56:00Z")

</div>

I ran that on one of my hosts. I noticed the following at the end of the output:

````auto
2020-11-12T13:51:34.824-0500 ERROR instance/beat.go:951 Exiting: Index management requested but the Elasticsearch output is not configured/enabled
Exiting: Index management requested but the Elasticsearch output is not configured/enabled```

I am using logstash in my filebeat.yml:
```output.logstash:
  # The Logstash hosts
  hosts: ["192.168.0.100:5044"]```
That IP is my server.
````

---

<div class="post-metadata">

### Author: ![wylie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wylie/32/81794_2.png) [@wylie](https://discuss.elastic.co/u/wylie)
#### Post date: [November 12, 2020, 7:10pm UTC](https://discuss.elastic.co/t/no-cached-mapping-error/254694/6 "2020-11-12T19:10:28Z")

</div>

If you read the link I sent earlier, it has a note about using non-Elasticsearch outputs. Please follow those instructions instead

---

<div class="post-metadata">

### Author: ![droidus](https://avatars.discourse-cdn.com/v4/letter/d/13edae/32.png) [@droidus](https://discuss.elastic.co/u/droidus)
#### Post date: [November 12, 2020, 7:26pm UTC](https://discuss.elastic.co/t/no-cached-mapping-error/254694/7 "2020-11-12T19:26:52Z")

</div>

When running the filebeat setup -e command, I get a lot of values that are 1024:

```auto
           "certificate": {
              "properties": {
                "common_name": {
                  "ignore_above": 1024,
                  "type": "keyword"
                },
                "curve": {
                  "ignore_above": 1024,
                  "type": "keyword"
                },
                "exponent": {
                  "ignore_above": 1024,
                  "type": "keyword"
                },
                "issuer": {
                  "properties": {
                    "common_name": {
                      "ignore_above": 1024,
                      "type": "keyword"
                    },
                    "country": {
                      "ignore_above": 1024,
                      "type": "keyword"
                    },
                    "locality": {
                      "ignore_above": 1024,
                      "type": "keyword"
                    },
                    "organization": {
                      "ignore_above": 1024,
                      "type": "keyword"
                    },
                    "organizational_unit": {
                      "ignore_above": 1024,
                      "type": "keyword"
                    },
                    "state": {
                      "ignore_above": 1024,
                      "type": "keyword"
                    }
                  }
                },
                "key": {
                  "properties": {
                    "algorithm": {
                      "ignore_above": 1024,
                      "type": "keyword"
                    },
                    "length": {
                      "type": "long"
                    },
                    "type": {
                      "ignore_above": 1024,
                      "type": "keyword"
                    }
                  }
                },
                "serial": {
                  "ignore_above": 1024,
                  "type": "keyword"
                },
                "signature_algorithm": {
                  "ignore_above": 1024,
                  "type": "keyword"
                },
                "subject": {
                  "properties": {
                    "common_name": {
                      "ignore_above": 1024,
                      "type": "keyword"
                    },
                    "country": {
                      "ignore_above": 1024,
                      "type": "keyword"
                    },
                    "locality": {
                      "ignore_above": 1024,
                      "type": "keyword"
                    },
                    "organization": {
                      "ignore_above": 1024,
                      "type": "keyword"
                    },
                    "organizational_unit": {
                      "ignore_above": 1024,
                      "type": "keyword"
                    },
                    "state": {
                      "ignore_above": 1024,
                      "type": "keyword"
                    }
                  }
                },
                "valid": {
                  "properties": {
                    "from": {
                      "type": "date"
                    },
                    "until": {
                      "type": "date"
                    }
                  }
                },
                "version": {
                  "type": "long"
                }
              }
            },
            "id": {
              "ignore_above": 1024,
              "type": "keyword"
            },
            "log_cert": {
              "type": "boolean"
            },
            "san": {
              "properties": {
                "dns": {
                  "ignore_above": 1024,
                  "type": "keyword"
                },
                "email": {
                  "ignore_above": 1024,
                  "type": "keyword"
                },
                "ip": {
                  "type": "ip"
                },
                "other_fields": {
                  "type": "boolean"
                },
                "uri": {
                  "ignore_above": 1024,
                  "type": "keyword"
                }
              }
            }
          }
        }
      }
    }
  }
}
  },
  "order": 1,
  "settings": {
"index": {
  "mapping": {
    "total_fields": {
      "limit": 10000
    }
  },
  "max_docvalue_fields_search": 200,
  "number_of_routing_shards": 30,
  "number_of_shards": 1,
  "refresh_interval": "5s"
}
  }
}

```

What does this mean?

---

<div class="post-metadata">

### Author: ![wylie](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/wylie/32/81794_2.png) [@wylie](https://discuss.elastic.co/u/wylie)
#### Post date: [November 12, 2020, 7:43pm UTC](https://discuss.elastic.co/t/no-cached-mapping-error/254694/8 "2020-11-12T19:43:02Z")

</div>

Here are the docs for that setting [https://www.elastic.co/guide/en/elasticsearch/reference/current/ignore-above.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/ignore-above.html)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 10, 2020, 7:43pm UTC](https://discuss.elastic.co/t/no-cached-mapping-error/254694/9 "2020-12-10T19:43:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
