# No clustering on ec2 due to ClassNotFoundException\[org.elasticsearch.gateway.blobstore.BlobStoreGatewayModule\]

**URL:** https://discuss.elastic.co/t/no-clustering-on-ec2-due-to-classnotfoundexception-org-elasticsearch-gateway-blobstore-blobstoregatewaymodule/18862
**Category:** Elasticsearch
**Created:** [July 24, 2014, 12:47pm UTC](https://discuss.elastic.co/t/no-clustering-on-ec2-due-to-classnotfoundexception-org-elasticsearch-gateway-blobstore-blobstoregatewaymodule/18862 "2014-07-24T12:47:44Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![Anthony\_Oleary](https://avatars.discourse-cdn.com/v4/letter/a/d07c76/32.png) [@Anthony\_Oleary](https://discuss.elastic.co/u/Anthony_Oleary)
#### Post date: [July 24, 2014, 12:47pm UTC](https://discuss.elastic.co/t/no-clustering-on-ec2-due-to-classnotfoundexception-org-elasticsearch-gateway-blobstore-blobstoregatewaymodule/18862/1 "2014-07-24T12:47:44Z")

</div>

Hello,  
in EC@,i installed elasticsearch with  
wget  
[http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.3.0.zip](http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.3.0.zip)  
sudo unzip elasticsearch-1.3.0.zip -d /usr/local/elasticsearch  
cd /usr/local/elasticsearch/elasticsearch-1.3.0  
sudo bin/plugin -install elasticsearch/elasticsearch-cloud-aws/2.1.1

config.yml is

cluster.name: elasticsearch-demo-js  
cloud.aws.access\_key: xxx..  
cloud.aws.secret\_key: yyy...  
cloud.aws.discovery.type: ec2  
gateway.type: s3  
gateway.s3.bucket: codetest

but i get this error as soon as i add the gateway configuration  
{1.3.0}: Initialization Failed ...

- NoClassDefFoundError[org/elasticsearch/gateway/blobstore/BlobStoreGatewayModule]  
ClassNotFoundException[org.elasticsearch.gateway.blobstore.BlobStoreGatewayModule]

any ideas ?

i then tried: sudo bin/plugin -install  
elasticsearch/elasticsearch-cloud-aws/2.2.0 but got

- NoClassSettingsException[Failed to load class setting [gateway.type] with  
value [s3]]

ClassNotFoundException[org.elasticsearch.gateway.s3.S3GatewayModule]

bit lost now!!!

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [July 24, 2014, 1:47pm UTC](https://discuss.elastic.co/t/no-clustering-on-ec2-due-to-classnotfoundexception-org-elasticsearch-gateway-blobstore-blobstoregatewaymodule/18862/2 "2014-07-24T13:47:19Z")

</div>

Gateways have been removed. You can't use that anymore.

--  
David Pilato | Technical Advocate | [Elasticsearch.com](http://Elasticsearch.com)  
@dadoonet | @elasticsearchfr

Le 24 juillet 2014 à 14:47:48, Anthony Oleary ([anthony.oleary@kweekweek.com](mailto:anthony.oleary@kweekweek.com)) a écrit:

Hello,  
in EC@,i installed elasticsearch with  
wget [http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.3.0.zip](http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.3.0.zip)  
sudo unzip elasticsearch-1.3.0.zip -d /usr/local/elasticsearch  
cd /usr/local/elasticsearch/elasticsearch-1.3.0  
sudo bin/plugin -install elasticsearch/elasticsearch-cloud-aws/2.1.1

config.yml is

cluster.name: elasticsearch-demo-js  
cloud.aws.access\_key: xxx..  
cloud.aws.secret\_key: yyy...  
cloud.aws.discovery.type: ec2  
gateway.type: s3  
gateway.s3.bucket: codetest

but i get this error as soon as i add the gateway configuration  
{1.3.0}: Initialization Failed ...

NoClassDefFoundError[org/elasticsearch/gateway/blobstore/BlobStoreGatewayModule] ClassNotFoundException[org.elasticsearch.gateway.blobstore.BlobStoreGatewayModule]  
any ideas ?  
i then tried: sudo bin/plugin -install elasticsearch/elasticsearch-cloud-aws/2.2.0 but got

- NoClassSettingsException[Failed to load class setting [gateway.type] with value [s3]]

ClassNotFoundException[org.elasticsearch.gateway.s3.S3GatewayModule]

bit lost now!!!

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/etPan.53d10e67.77465f01.13e40%40MacBook-Air-de-David.local](https://groups.google.com/d/msgid/elasticsearch/etPan.53d10e67.77465f01.13e40%40MacBook-Air-de-David.local).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![Anthony\_Oleary](https://avatars.discourse-cdn.com/v4/letter/a/d07c76/32.png) [@Anthony\_Oleary](https://discuss.elastic.co/u/Anthony_Oleary)
#### Post date: [July 24, 2014, 2:27pm UTC](https://discuss.elastic.co/t/no-clustering-on-ec2-due-to-classnotfoundexception-org-elasticsearch-gateway-blobstore-blobstoregatewaymodule/18862/3 "2014-07-24T14:27:23Z")

</div>

thanks David  
I got the link about gateways from

> **[Elasticsearch Platform — Find real-time answers at scale](https://www.elastic.co)**
>
> Power insights and outcomes with the Elasticsearch Platform and AI. See into your data and find answers that matter with enterprise solutions designed to help you build, observe, and protect. Try Elasticsearch free today.

what would you recommend i use for clustering on EC2 instead of gateways or  
how to configure the config.yml ?

Anthony

On Thursday, July 24, 2014 2:47:32 PM UTC+1, David Pilato wrote:

> Gateways have been removed. You can't use that anymore.
> 
> --  
> _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)_  
> @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr  
> [https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> 
> Le 24 juillet 2014 à 14:47:48, Anthony Oleary ([anthony...@kweekweek.com](mailto:anthony...@kweekweek.com)  
> \<javascript:\>) a écrit:
> 
> Hello,  
> in EC@,i installed elasticsearch with  
> wget  
> [http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.3.0.zip](http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.3.0.zip)  
> sudo unzip elasticsearch-1.3.0.zip -d /usr/local/elasticsearch  
> cd /usr/local/elasticsearch/elasticsearch-1.3.0  
> sudo bin/plugin -install elasticsearch/elasticsearch-cloud-aws/2.1.1
> 
> config.yml is
> 
> cluster.name: elasticsearch-demo-js  
> cloud.aws.access\_key: xxx..  
> cloud.aws.secret\_key: yyy...  
> cloud.aws.discovery.type: ec2  
> gateway.type: s3  
> gateway.s3.bucket: codetest
> 
> but i get this error as soon as i add the gateway configuration  
> {1.3.0}: Initialization Failed ...
> 
> - NoClassDefFoundError[org/elasticsearch/gateway/blobstore/BlobStoreGatewayModule]  
> ClassNotFoundException[org.elasticsearch.gateway.blobstore.BlobStoreGatewayModule]
> 
> any ideas ?
> 
> i then tried: sudo bin/plugin -install  
> elasticsearch/elasticsearch-cloud-aws/2.2.0 but got
> 
> - NoClassSettingsException[Failed to load class setting [gateway.type]  
> with value [s3]]
> 
> ClassNotFoundException[org.elasticsearch.gateway.s3.S3GatewayModule]
> 
> ## bit lost now!!!
> 
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com) \<javascript:\>.  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com)  
> [https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com?utm_medium=email&utm_source=footer)  
> .  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/be1a74ed-cb2d-4f04-b600-be0014034d38%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/be1a74ed-cb2d-4f04-b600-be0014034d38%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [July 24, 2014, 2:48pm UTC](https://discuss.elastic.co/t/no-clustering-on-ec2-due-to-classnotfoundexception-org-elasticsearch-gateway-blobstore-blobstoregatewaymodule/18862/4 "2014-07-24T14:48:43Z")

</div>

Just use local disk or EBS with provisioned IOs.  
You don't need to store your indices on S3. If you want to do that for backup purpose, have a look at snapshot and restore API.

Basically, in elasticsearch.yml file, remove:

gateway.type: s3  
gateway.s3.bucket: codetest

Gateway has been removed since 1.2.0: [http://www.elasticsearch.org/blog/elasticsearch-1-2-0-released/](http://www.elasticsearch.org/blog/elasticsearch-1-2-0-released/)

--  
David Pilato | Technical Advocate | [Elasticsearch.com](http://Elasticsearch.com)  
@dadoonet | @elasticsearchfr

Le 24 juillet 2014 à 16:27:27, Anthony Oleary ([anthony.oleary@kweekweek.com](mailto:anthony.oleary@kweekweek.com)) a écrit:

thanks David  
I got the link about gateways from  
[http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/](http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/)

what would you recommend i use for clustering on EC2 instead of gateways or how to configure the config.yml ?

Anthony

On Thursday, July 24, 2014 2:47:32 PM UTC+1, David Pilato wrote:  
Gateways have been removed. You can't use that anymore.

--  
David Pilato | Technical Advocate | [Elasticsearch.com](http://Elasticsearch.com)  
@dadoonet | @elasticsearchfr

Le 24 juillet 2014 à 14:47:48, Anthony Oleary ([anthony...@kweekweek.com](mailto:anthony...@kweekweek.com)) a écrit:

Hello,  
in EC@,i installed elasticsearch with  
wget [http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.3.0.zip](http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.3.0.zip)  
sudo unzip elasticsearch-1.3.0.zip -d /usr/local/elasticsearch  
cd /usr/local/elasticsearch/elasticsearch-1.3.0  
sudo bin/plugin -install elasticsearch/elasticsearch-cloud-aws/2.1.1

config.yml is

cluster.name: elasticsearch-demo-js  
cloud.aws.access\_key: xxx..  
cloud.aws.secret\_key: yyy...  
cloud.aws.discovery.type: ec2  
gateway.type: s3  
gateway.s3.bucket: codetest

but i get this error as soon as i add the gateway configuration  
{1.3.0}: Initialization Failed ...

NoClassDefFoundError[org/elasticsearch/gateway/blobstore/BlobStoreGatewayModule] ClassNotFoundException[org.elasticsearch.gateway.blobstore.BlobStoreGatewayModule]  
any ideas ?  
i then tried: sudo bin/plugin -install elasticsearch/elasticsearch-cloud-aws/2.2.0 but got

- NoClassSettingsException[Failed to load class setting [gateway.type] with value [s3]]

ClassNotFoundException[org.elasticsearch.gateway.s3.S3GatewayModule]

bit lost now!!!

## -- You received this message because you are subscribed to the Google Groups "elasticsearch" group. To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com). To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com). For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/be1a74ed-cb2d-4f04-b600-be0014034d38%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/be1a74ed-cb2d-4f04-b600-be0014034d38%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/etPan.53d11ccb.3855585c.13e40%40MacBook-Air-de-David.local](https://groups.google.com/d/msgid/elasticsearch/etPan.53d11ccb.3855585c.13e40%40MacBook-Air-de-David.local).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![Anthony\_Oleary](https://avatars.discourse-cdn.com/v4/letter/a/d07c76/32.png) [@Anthony\_Oleary](https://discuss.elastic.co/u/Anthony_Oleary)
#### Post date: [July 24, 2014, 3:23pm UTC](https://discuss.elastic.co/t/no-clustering-on-ec2-due-to-classnotfoundexception-org-elasticsearch-gateway-blobstore-blobstoregatewaymodule/18862/5 "2014-07-24T15:23:05Z")

</div>

Thanks again David,  
One last question, how would i tell elasticsearch to use the EBS? or is it  
when i create a EC2 to link it to EBS and it works away without telling  
eleasticsearch.

would you recommend EBS in order for the data not to be lost.

On Thursday, July 24, 2014 3:48:53 PM UTC+1, David Pilato wrote:

> Just use local disk or EBS with provisioned IOs.  
> You don't need to store your indices on S3. If you want to do that for  
> backup purpose, have a look at snapshot and restore API.
> 
> Basically, in elasticsearch.yml file, remove:
> 
> gateway.type: s3  
> gateway.s3.bucket: codetest
> 
> Gateway has been removed since 1.2.0:  
> [Elasticsearch Platform — Find real-time answers at scale | Elastic](http://www.elasticsearch.org/blog/elasticsearch-1-2-0-released/)
> 
> --  
> _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)_  
> @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr  
> [https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> 
> Le 24 juillet 2014 à 16:27:27, Anthony Oleary ([anthony...@kweekweek.com](mailto:anthony...@kweekweek.com)  
> \<javascript:\>) a écrit:
> 
> thanks David  
> I got the link about gateways from  
> [Elasticsearch Platform — Find real-time answers at scale | Elastic](http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/)
> 
> what would you recommend i use for clustering on EC2 instead of gateways  
> or how to configure the config.yml ?
> 
> Anthony
> 
> On Thursday, July 24, 2014 2:47:32 PM UTC+1, David Pilato wrote:
> 
> > Gateways have been removed. You can't use that anymore.
> > 
> > ```
> > -- 
> > 
> > ```
> > 
> > _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)_  
> > @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr  
> > [https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> > 
> > Le 24 juillet 2014 à 14:47:48, Anthony Oleary ([anthony...@kweekweek.com](mailto:anthony...@kweekweek.com))  
> > a écrit:
> > 
> > Hello,  
> > in EC@,i installed elasticsearch with  
> > wget  
> > [http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.3.0.zip](http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.3.0.zip)  
> > sudo unzip elasticsearch-1.3.0.zip -d /usr/local/elasticsearch  
> > cd /usr/local/elasticsearch/elasticsearch-1.3.0  
> > sudo bin/plugin -install elasticsearch/elasticsearch-cloud-aws/2.1.1
> > 
> > config.yml is
> > 
> > cluster.name: elasticsearch-demo-js  
> > cloud.aws.access\_key: xxx..  
> > cloud.aws.secret\_key: yyy...  
> > cloud.aws.discovery.type: ec2  
> > gateway.type: s3  
> > gateway.s3.bucket: codetest
> > 
> > but i get this error as soon as i add the gateway configuration  
> > {1.3.0}: Initialization Failed ...
> > 
> > - NoClassDefFoundError[org/elasticsearch/gateway/blobstore/BlobStoreGatewayModule]  
> > ClassNotFoundException[org.elasticsearch.gateway.blobstore.BlobStoreGatewayModule]
> > 
> > any ideas ?
> > 
> > i then tried: sudo bin/plugin -install  
> > elasticsearch/elasticsearch-cloud-aws/2.2.0 but got
> > 
> > - NoClassSettingsException[Failed to load class setting [gateway.type]  
> > with value [s3]]
> > 
> > ClassNotFoundException[org.elasticsearch.gateway.s3.S3GatewayModule]
> > 
> > ## bit lost now!!!
> > 
> > You received this message because you are subscribed to the Google Groups  
> > "elasticsearch" group.  
> > To unsubscribe from this group and stop receiving emails from it, send an  
> > email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com).  
> > To view this discussion on the web visit  
> > [https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com)  
> > [https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > .  
> > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> > 
> > --  
> > You received this message because you are subscribed to the Google Groups  
> > "elasticsearch" group.  
> > To unsubscribe from this group and stop receiving emails from it, send an  
> > email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com) \<javascript:\>.  
> > To view this discussion on the web visit  
> > [https://groups.google.com/d/msgid/elasticsearch/be1a74ed-cb2d-4f04-b600-be0014034d38%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/be1a74ed-cb2d-4f04-b600-be0014034d38%40googlegroups.com)  
> > [https://groups.google.com/d/msgid/elasticsearch/be1a74ed-cb2d-4f04-b600-be0014034d38%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/be1a74ed-cb2d-4f04-b600-be0014034d38%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > .  
> > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/7647fca6-877c-4822-a1b6-f4c58e4230be%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/7647fca6-877c-4822-a1b6-f4c58e4230be%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [July 24, 2014, 4:36pm UTC](https://discuss.elastic.co/t/no-clustering-on-ec2-due-to-classnotfoundexception-org-elasticsearch-gateway-blobstore-blobstoregatewaymodule/18862/6 "2014-07-24T16:36:37Z")

</div>

It's a matter of EC2 configuration. Elasticsearch does not really care to know.

I'd probably start with local disks if possible. Replication is done by elasticsearch. So if you have more than one node, your data could be replicated on another machine.

--  
David Pilato | Technical Advocate | [Elasticsearch.com](http://Elasticsearch.com)  
@dadoonet | @elasticsearchfr

Le 24 juillet 2014 à 17:23:08, Anthony Oleary ([anthony.oleary@kweekweek.com](mailto:anthony.oleary@kweekweek.com)) a écrit:

Thanks again David,  
One last question, how would i tell elasticsearch to use the EBS? or is it when i create a EC2 to link it to EBS and it works away without telling eleasticsearch.

would you recommend EBS in order for the data not to be lost.

On Thursday, July 24, 2014 3:48:53 PM UTC+1, David Pilato wrote:  
Just use local disk or EBS with provisioned IOs.  
You don't need to store your indices on S3. If you want to do that for backup purpose, have a look at snapshot and restore API.

Basically, in elasticsearch.yml file, remove:

gateway.type: s3  
gateway.s3.bucket: codetest

Gateway has been removed since 1.2.0: [http://www.elasticsearch.org/blog/elasticsearch-1-2-0-released/](http://www.elasticsearch.org/blog/elasticsearch-1-2-0-released/)

--  
David Pilato | Technical Advocate | [Elasticsearch.com](http://Elasticsearch.com)  
@dadoonet | @elasticsearchfr

Le 24 juillet 2014 à 16:27:27, Anthony Oleary ([anthony...@kweekweek.com](mailto:anthony...@kweekweek.com)) a écrit:

thanks David  
I got the link about gateways from  
[http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/](http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/)

what would you recommend i use for clustering on EC2 instead of gateways or how to configure the config.yml ?

Anthony

On Thursday, July 24, 2014 2:47:32 PM UTC+1, David Pilato wrote:  
Gateways have been removed. You can't use that anymore.

--  
David Pilato | Technical Advocate | [Elasticsearch.com](http://Elasticsearch.com)  
@dadoonet | @elasticsearchfr

Le 24 juillet 2014 à 14:47:48, Anthony Oleary ([anthony...@kweekweek.com](mailto:anthony...@kweekweek.com)) a écrit:

Hello,  
in EC@,i installed elasticsearch with  
wget [http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.3.0.zip](http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.3.0.zip)  
sudo unzip elasticsearch-1.3.0.zip -d /usr/local/elasticsearch  
cd /usr/local/elasticsearch/elasticsearch-1.3.0  
sudo bin/plugin -install elasticsearch/elasticsearch-cloud-aws/2.1.1

config.yml is

cluster.name: elasticsearch-demo-js  
cloud.aws.access\_key: xxx..  
cloud.aws.secret\_key: yyy...  
cloud.aws.discovery.type: ec2  
gateway.type: s3  
gateway.s3.bucket: codetest

but i get this error as soon as i add the gateway configuration  
{1.3.0}: Initialization Failed ...

NoClassDefFoundError[org/elasticsearch/gateway/blobstore/BlobStoreGatewayModule] ClassNotFoundException[org.elasticsearch.gateway.blobstore.BlobStoreGatewayModule]  
any ideas ?  
i then tried: sudo bin/plugin -install elasticsearch/elasticsearch-cloud-aws/2.2.0 but got

- NoClassSettingsException[Failed to load class setting [gateway.type] with value [s3]]

ClassNotFoundException[org.elasticsearch.gateway.s3.S3GatewayModule]

bit lost now!!!

## -- You received this message because you are subscribed to the Google Groups "elasticsearch" group. To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com). To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com). For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

## You received this message because you are subscribed to the Google Groups "elasticsearch" group. To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com). To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/be1a74ed-cb2d-4f04-b600-be0014034d38%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/be1a74ed-cb2d-4f04-b600-be0014034d38%40googlegroups.com). For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/7647fca6-877c-4822-a1b6-f4c58e4230be%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/7647fca6-877c-4822-a1b6-f4c58e4230be%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/etPan.53d13615.2a487cb0.13e40%40MacBook-Air-de-David.local](https://groups.google.com/d/msgid/elasticsearch/etPan.53d13615.2a487cb0.13e40%40MacBook-Air-de-David.local).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![Anthony\_Oleary](https://avatars.discourse-cdn.com/v4/letter/a/d07c76/32.png) [@Anthony\_Oleary](https://discuss.elastic.co/u/Anthony_Oleary)
#### Post date: [July 25, 2014, 6:07pm UTC](https://discuss.elastic.co/t/no-clustering-on-ec2-due-to-classnotfoundexception-org-elasticsearch-gateway-blobstore-blobstoregatewaymodule/18862/7 "2014-07-25T18:07:38Z")

</div>

hi David  
May I ask,  
if i want to use opsworks, copy my ec2 image onto opswork , and auto  
scale, how can i specify a master node or is it automatic?

anthony

On Thursday, July 24, 2014 5:36:51 PM UTC+1, David Pilato wrote:

> It's a matter of EC2 configuration. Elasticsearch does not really care to  
> know.
> 
> I'd probably start with local disks if possible. Replication is done by  
> elasticsearch. So if you have more than one node, your data could be  
> replicated on another machine.
> 
> --  
> _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)_  
> @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr  
> [https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> 
> Le 24 juillet 2014 à 17:23:08, Anthony Oleary ([anthony...@kweekweek.com](mailto:anthony...@kweekweek.com)  
> \<javascript:\>) a écrit:
> 
> Thanks again David,  
> One last question, how would i tell elasticsearch to use the EBS? or is it  
> when i create a EC2 to link it to EBS and it works away without telling  
> eleasticsearch.
> 
> would you recommend EBS in order for the data not to be lost.
> 
> On Thursday, July 24, 2014 3:48:53 PM UTC+1, David Pilato wrote:
> 
> > Just use local disk or EBS with provisioned IOs.  
> > You don't need to store your indices on S3. If you want to do that for  
> > backup purpose, have a look at snapshot and restore API.
> > 
> > Basically, in elasticsearch.yml file, remove:
> > 
> > gateway.type: s3  
> > gateway.s3.bucket: codetest
> > 
> > Gateway has been removed since 1.2.0:  
> > [Elasticsearch Platform — Find real-time answers at scale | Elastic](http://www.elasticsearch.org/blog/elasticsearch-1-2-0-released/)
> > 
> > ```
> > -- 
> > 
> > ```
> > 
> > _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)_  
> > @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr  
> > [https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> > 
> > Le 24 juillet 2014 à 16:27:27, Anthony Oleary ([anthony...@kweekweek.com](mailto:anthony...@kweekweek.com))  
> > a écrit:
> > 
> > thanks David  
> > I got the link about gateways from  
> > [Elasticsearch Platform — Find real-time answers at scale | Elastic](http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/)
> > 
> > what would you recommend i use for clustering on EC2 instead of gateways  
> > or how to configure the config.yml ?
> > 
> > Anthony
> > 
> > On Thursday, July 24, 2014 2:47:32 PM UTC+1, David Pilato wrote:
> > 
> > > Gateways have been removed. You can't use that anymore.
> > > 
> > > ```
> > > -- 
> > > 
> > > ```
> > > 
> > > _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)_  
> > > @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr  
> > > [https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> > > 
> > > Le 24 juillet 2014 à 14:47:48, Anthony Oleary ([anthony...@kweekweek.com](mailto:anthony...@kweekweek.com))  
> > > a écrit:
> > > 
> > > Hello,  
> > > in EC@,i installed elasticsearch with  
> > > wget  
> > > [http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.3.0.zip](http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.3.0.zip)  
> > > sudo unzip elasticsearch-1.3.0.zip -d /usr/local/elasticsearch  
> > > cd /usr/local/elasticsearch/elasticsearch-1.3.0  
> > > sudo bin/plugin -install elasticsearch/elasticsearch-cloud-aws/2.1.1
> > > 
> > > config.yml is
> > > 
> > > cluster.name: elasticsearch-demo-js  
> > > cloud.aws.access\_key: xxx..  
> > > cloud.aws.secret\_key: yyy...  
> > > cloud.aws.discovery.type: ec2  
> > > gateway.type: s3  
> > > gateway.s3.bucket: codetest
> > > 
> > > but i get this error as soon as i add the gateway configuration  
> > > {1.3.0}: Initialization Failed ...
> > > 
> > > - NoClassDefFoundError[org/elasticsearch/gateway/blobstore/BlobStoreGatewayModule]  
> > > ClassNotFoundException[org.elasticsearch.gateway.blobstore.BlobStoreGatewayModule]
> > > 
> > > any ideas ?
> > > 
> > > i then tried: sudo bin/plugin -install  
> > > elasticsearch/elasticsearch-cloud-aws/2.2.0 but got
> > > 
> > > - NoClassSettingsException[Failed to load class setting [gateway.type]  
> > > with value [s3]]
> > > 
> > > ClassNotFoundException[org.elasticsearch.gateway.s3.S3GatewayModule]
> > > 
> > > ## bit lost now!!!
> > > 
> > > You received this message because you are subscribed to the Google  
> > > Groups "elasticsearch" group.  
> > > To unsubscribe from this group and stop receiving emails from it, send  
> > > an email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com).  
> > > To view this discussion on the web visit  
> > > [https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com)  
> > > [https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > > .  
> > > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> > > 
> > > --  
> > > You received this message because you are subscribed to the Google Groups  
> > > "elasticsearch" group.  
> > > To unsubscribe from this group and stop receiving emails from it, send an  
> > > email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com).  
> > > To view this discussion on the web visit  
> > > [https://groups.google.com/d/msgid/elasticsearch/be1a74ed-cb2d-4f04-b600-be0014034d38%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/be1a74ed-cb2d-4f04-b600-be0014034d38%40googlegroups.com)  
> > > [https://groups.google.com/d/msgid/elasticsearch/be1a74ed-cb2d-4f04-b600-be0014034d38%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/be1a74ed-cb2d-4f04-b600-be0014034d38%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > > .  
> > > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> > 
> > --  
> > You received this message because you are subscribed to the Google Groups  
> > "elasticsearch" group.  
> > To unsubscribe from this group and stop receiving emails from it, send an  
> > email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com) \<javascript:\>.  
> > To view this discussion on the web visit  
> > [https://groups.google.com/d/msgid/elasticsearch/7647fca6-877c-4822-a1b6-f4c58e4230be%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/7647fca6-877c-4822-a1b6-f4c58e4230be%40googlegroups.com)  
> > [https://groups.google.com/d/msgid/elasticsearch/7647fca6-877c-4822-a1b6-f4c58e4230be%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/7647fca6-877c-4822-a1b6-f4c58e4230be%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > .  
> > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/1b2f1047-c22b-4ec7-8e92-50fa8d40ecaf%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/1b2f1047-c22b-4ec7-8e92-50fa8d40ecaf%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [July 25, 2014, 6:47pm UTC](https://discuss.elastic.co/t/no-clustering-on-ec2-due-to-classnotfoundexception-org-elasticsearch-gateway-blobstore-blobstoregatewaymodule/18862/8 "2014-07-25T18:47:01Z")

</div>

Automatic master node election.

## HTH

David 😉  
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 25 juil. 2014 à 20:07, Anthony Oleary [anthony.oleary@kweekweek.com](mailto:anthony.oleary@kweekweek.com) a écrit :

hi David  
May I ask,  
if i want to use opsworks, copy my ec2 image onto opswork , and auto scale, how can i specify a master node or is it automatic?

anthony

> On Thursday, July 24, 2014 5:36:51 PM UTC+1, David Pilato wrote:  
> It's a matter of EC2 configuration. Elasticsearch does not really care to know.
> 
> I'd probably start with local disks if possible. Replication is done by elasticsearch. So if you have more than one node, your data could be replicated on another machine.
> 
> --  
> David Pilato | Technical Advocate | [Elasticsearch.com](http://Elasticsearch.com)  
> @dadoonet | @elasticsearchfr
> 
> > Le 24 juillet 2014 à 17:23:08, Anthony Oleary ([anthony...@kweekweek.com](mailto:anthony...@kweekweek.com)) a écrit:
> > 
> > Thanks again David,  
> > One last question, how would i tell elasticsearch to use the EBS? or is it when i create a EC2 to link it to EBS and it works away without telling eleasticsearch.
> > 
> > would you recommend EBS in order for the data not to be lost.
> > 
> > > On Thursday, July 24, 2014 3:48:53 PM UTC+1, David Pilato wrote:  
> > > Just use local disk or EBS with provisioned IOs.  
> > > You don't need to store your indices on S3. If you want to do that for backup purpose, have a look at snapshot and restore API.
> > > 
> > > Basically, in elasticsearch.yml file, remove:
> > > 
> > > gateway.type: s3  
> > > gateway.s3.bucket: codetest
> > > 
> > > Gateway has been removed since 1.2.0: [Elastic — The Search AI Company | Elastic](http://www.elasticsearch.org/blog/elasticsearch-1-2-0-released/)
> > > 
> > > --  
> > > David Pilato | Technical Advocate | [Elasticsearch.com](http://Elasticsearch.com)  
> > > @dadoonet | @elasticsearchfr
> > > 
> > > > Le 24 juillet 2014 à 16:27:27, Anthony Oleary ([anthony...@kweekweek.com](mailto:anthony...@kweekweek.com)) a écrit:
> > > > 
> > > > thanks David  
> > > > I got the link about gateways from  
> > > > [Elastic — The Search AI Company | Elastic](http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/)
> > > > 
> > > > what would you recommend i use for clustering on EC2 instead of gateways or how to configure the config.yml ?
> > > > 
> > > > Anthony
> > > > 
> > > > > On Thursday, July 24, 2014 2:47:32 PM UTC+1, David Pilato wrote:  
> > > > > Gateways have been removed. You can't use that anymore.
> > > > > 
> > > > > --  
> > > > > David Pilato | Technical Advocate | [Elasticsearch.com](http://Elasticsearch.com)  
> > > > > @dadoonet | @elasticsearchfr
> > > > > 
> > > > > > Le 24 juillet 2014 à 14:47:48, Anthony Oleary ([anthony...@kweekweek.com](mailto:anthony...@kweekweek.com)) a écrit:
> > > > > > 
> > > > > > Hello,  
> > > > > > in EC@,i installed elasticsearch with  
> > > > > > wget [http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.3.0.zip](http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.3.0.zip)  
> > > > > > sudo unzip elasticsearch-1.3.0.zip -d /usr/local/elasticsearch  
> > > > > > cd /usr/local/elasticsearch/elasticsearch-1.3.0  
> > > > > > sudo bin/plugin -install elasticsearch/elasticsearch-cloud-aws/2.1.1
> > > > > > 
> > > > > > config.yml is
> > > > > > 
> > > > > > cluster.name: elasticsearch-demo-js  
> > > > > > cloud.aws.access\_key: xxx..  
> > > > > > cloud.aws.secret\_key: yyy...  
> > > > > > cloud.aws.discovery.type: ec2  
> > > > > > gateway.type: s3  
> > > > > > gateway.s3.bucket: codetest
> > > > > > 
> > > > > > but i get this error as soon as i add the gateway configuration  
> > > > > > {1.3.0}: Initialization Failed ...
> > > > > > 
> > > > > > NoClassDefFoundError[org/elasticsearch/gateway/blobstore/BlobStoreGatewayModule] ClassNotFoundException[org.elasticsearch.gateway.blobstore.BlobStoreGatewayModule]  
> > > > > > any ideas ?  
> > > > > > i then tried: sudo bin/plugin -install elasticsearch/elasticsearch-cloud-aws/2.2.0 but got
> > > > > > 
> > > > > > - NoClassSettingsException[Failed to load class setting [gateway.type] with value [s3]]
> > > > > > 
> > > > > > ClassNotFoundException[org.elasticsearch.gateway.s3.S3GatewayModule]
> > > > > > 
> > > > > > bit lost now!!!
> > > > > > 
> > > > > > --  
> > > > > > You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
> > > > > > To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com).  
> > > > > > To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com).  
> > > > > > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).  
> > > > > > --  
> > > > > > You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
> > > > > > To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com).  
> > > > > > To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/be1a74ed-cb2d-4f04-b600-be0014034d38%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/be1a74ed-cb2d-4f04-b600-be0014034d38%40googlegroups.com).  
> > > > > > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).  
> > > > > > --  
> > > > > > You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
> > > > > > To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com).  
> > > > > > To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/7647fca6-877c-4822-a1b6-f4c58e4230be%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/7647fca6-877c-4822-a1b6-f4c58e4230be%40googlegroups.com).  
> > > > > > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/1b2f1047-c22b-4ec7-8e92-50fa8d40ecaf%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/1b2f1047-c22b-4ec7-8e92-50fa8d40ecaf%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/06F09A51-ED0D-4644-B676-71A4AE8C7533%40pilato.fr](https://groups.google.com/d/msgid/elasticsearch/06F09A51-ED0D-4644-B676-71A4AE8C7533%40pilato.fr).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![Mike\_Ressler](https://avatars.discourse-cdn.com/v4/letter/m/a6a055/32.png) [@Mike\_Ressler](https://discuss.elastic.co/u/Mike_Ressler)
#### Post date: [October 29, 2014, 9:45pm UTC](https://discuss.elastic.co/t/no-clustering-on-ec2-due-to-classnotfoundexception-org-elasticsearch-gateway-blobstore-blobstoregatewaymodule/18862/9 "2014-10-29T21:45:16Z")

</div>

Elasticsearch gurus,

Just getting started with elasticsearch and ran across the same gateway  
issue brought up in this thread. Seems like the documentation really ought  
to be updated. It's several major versions old at this point.

> **[Elasticsearch Platform — Find real-time answers at scale](https://www.elastic.co)**
>
> Power insights and outcomes with the Elasticsearch Platform and AI. See into your data and find answers that matter with enterprise solutions designed to help you build, observe, and protect. Try Elasticsearch free today.

That's the documentation I've been using as I get started.

On Friday, July 25, 2014 2:47:57 PM UTC-4, David Pilato wrote:

> Automatic master node election.
> 
> ## HTH
> 
> David 😉  
> Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs
> 
> Le 25 juil. 2014 à 20:07, Anthony Oleary \<[anthony...@kweekweek.com](mailto:anthony...@kweekweek.com)  
> \<javascript:\>\> a écrit :
> 
> hi David  
> May I ask,  
> if i want to use opsworks, copy my ec2 image onto opswork , and auto  
> scale, how can i specify a master node or is it automatic?
> 
> anthony
> 
> On Thursday, July 24, 2014 5:36:51 PM UTC+1, David Pilato wrote:
> 
> > It's a matter of EC2 configuration. Elasticsearch does not really care to  
> > know.
> > 
> > I'd probably start with local disks if possible. Replication is done by  
> > elasticsearch. So if you have more than one node, your data could be  
> > replicated on another machine.
> > 
> > --  
> > _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)  
> > [http://Elasticsearch.com](http://Elasticsearch.com)_  
> > @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr  
> > [https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> > 
> > Le 24 juillet 2014 à 17:23:08, Anthony Oleary ([anthony...@kweekweek.com](mailto:anthony...@kweekweek.com))  
> > a écrit:
> > 
> > Thanks again David,  
> > One last question, how would i tell elasticsearch to use the EBS? or is  
> > it when i create a EC2 to link it to EBS and it works away without telling  
> > eleasticsearch.
> > 
> > would you recommend EBS in order for the data not to be lost.
> > 
> > On Thursday, July 24, 2014 3:48:53 PM UTC+1, David Pilato wrote:
> > 
> > > Just use local disk or EBS with provisioned IOs.  
> > > You don't need to store your indices on S3. If you want to do that for  
> > > backup purpose, have a look at snapshot and restore API.
> > > 
> > > Basically, in elasticsearch.yml file, remove:
> > > 
> > > gateway.type: s3  
> > > gateway.s3.bucket: codetest
> > > 
> > > Gateway has been removed since 1.2.0:  
> > > [Elasticsearch Platform — Find real-time answers at scale | Elastic](http://www.elasticsearch.org/blog/elasticsearch-1-2-0-released/)
> > > 
> > > ```
> > > -- 
> > > 
> > > ```
> > > 
> > > _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)  
> > > [http://Elasticsearch.com](http://Elasticsearch.com)_  
> > > @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr  
> > > [https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> > > 
> > > Le 24 juillet 2014 à 16:27:27, Anthony Oleary ([anthony...@kweekweek.com](mailto:anthony...@kweekweek.com))  
> > > a écrit:
> > > 
> > > thanks David  
> > > I got the link about gateways from  
> > > [Elasticsearch Platform — Find real-time answers at scale | Elastic](http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/)
> > > 
> > > what would you recommend i use for clustering on EC2 instead of gateways  
> > > or how to configure the config.yml ?
> > > 
> > > Anthony
> > > 
> > > On Thursday, July 24, 2014 2:47:32 PM UTC+1, David Pilato wrote:
> > > 
> > > > Gateways have been removed. You can't use that anymore.
> > > > 
> > > > ```
> > > > -- 
> > > > 
> > > > ```
> > > > 
> > > > _David Pilato_ | _Technical Advocate_ | _[Elasticsearch.com](http://Elasticsearch.com)  
> > > > [http://Elasticsearch.com](http://Elasticsearch.com)_  
> > > > @dadoonet [https://twitter.com/dadoonet](https://twitter.com/dadoonet) | @elasticsearchfr  
> > > > [https://twitter.com/elasticsearchfr](https://twitter.com/elasticsearchfr)
> > > > 
> > > > Le 24 juillet 2014 à 14:47:48, Anthony Oleary ([anthony...@kweekweek.com](mailto:anthony...@kweekweek.com))  
> > > > a écrit:
> > > > 
> > > > Hello,  
> > > > in EC@,i installed elasticsearch with  
> > > > wget  
> > > > [http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.3.0.zip](http://download.elasticsearch.org/elasticsearch/elasticsearch/elasticsearch-1.3.0.zip)  
> > > > sudo unzip elasticsearch-1.3.0.zip -d /usr/local/elasticsearch  
> > > > cd /usr/local/elasticsearch/elasticsearch-1.3.0  
> > > > sudo bin/plugin -install elasticsearch/elasticsearch-cloud-aws/2.1.1
> > > > 
> > > > config.yml is
> > > > 
> > > > cluster.name: elasticsearch-demo-js  
> > > > cloud.aws.access\_key: xxx..  
> > > > cloud.aws.secret\_key: yyy...  
> > > > cloud.aws.discovery.type: ec2  
> > > > gateway.type: s3  
> > > > gateway.s3.bucket: codetest
> > > > 
> > > > but i get this error as soon as i add the gateway configuration  
> > > > {1.3.0}: Initialization Failed ...
> > > > 
> > > > - NoClassDefFoundError[org/elasticsearch/gateway/blobstore/BlobStoreGatewayModule]  
> > > > ClassNotFoundException[org.elasticsearch.gateway.blobstore.BlobStoreGatewayModule]
> > > > 
> > > > any ideas ?
> > > > 
> > > > i then tried: sudo bin/plugin -install  
> > > > elasticsearch/elasticsearch-cloud-aws/2.2.0 but got
> > > > 
> > > > - NoClassSettingsException[Failed to load class setting [gateway.type]  
> > > > with value [s3]]
> > > > 
> > > > ClassNotFoundException[org.elasticsearch.gateway.s3.S3GatewayModule]
> > > > 
> > > > ## bit lost now!!!
> > > > 
> > > > You received this message because you are subscribed to the Google  
> > > > Groups "elasticsearch" group.  
> > > > To unsubscribe from this group and stop receiving emails from it, send  
> > > > an email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com).  
> > > > To view this discussion on the web visit  
> > > > [https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com)  
> > > > [https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/c46bf6f1-ac0d-4437-810a-d2900252d52a%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > > > .  
> > > > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> > > > 
> > > > --  
> > > > You received this message because you are subscribed to the Google  
> > > > Groups "elasticsearch" group.  
> > > > To unsubscribe from this group and stop receiving emails from it, send  
> > > > an email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com).  
> > > > To view this discussion on the web visit  
> > > > [https://groups.google.com/d/msgid/elasticsearch/be1a74ed-cb2d-4f04-b600-be0014034d38%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/be1a74ed-cb2d-4f04-b600-be0014034d38%40googlegroups.com)  
> > > > [https://groups.google.com/d/msgid/elasticsearch/be1a74ed-cb2d-4f04-b600-be0014034d38%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/be1a74ed-cb2d-4f04-b600-be0014034d38%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > > > .  
> > > > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> > > 
> > > --  
> > > You received this message because you are subscribed to the Google Groups  
> > > "elasticsearch" group.  
> > > To unsubscribe from this group and stop receiving emails from it, send an  
> > > email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com).  
> > > To view this discussion on the web visit  
> > > [https://groups.google.com/d/msgid/elasticsearch/7647fca6-877c-4822-a1b6-f4c58e4230be%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/7647fca6-877c-4822-a1b6-f4c58e4230be%40googlegroups.com)  
> > > [https://groups.google.com/d/msgid/elasticsearch/7647fca6-877c-4822-a1b6-f4c58e4230be%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/7647fca6-877c-4822-a1b6-f4c58e4230be%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > > .  
> > > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).
> > 
> > --  
> > You received this message because you are subscribed to the Google Groups  
> > "elasticsearch" group.  
> > To unsubscribe from this group and stop receiving emails from it, send an  
> > email to [elasticsearc...@googlegroups.com](mailto:elasticsearc...@googlegroups.com) \<javascript:\>.  
> > To view this discussion on the web visit  
> > [https://groups.google.com/d/msgid/elasticsearch/1b2f1047-c22b-4ec7-8e92-50fa8d40ecaf%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/1b2f1047-c22b-4ec7-8e92-50fa8d40ecaf%40googlegroups.com)  
> > [https://groups.google.com/d/msgid/elasticsearch/1b2f1047-c22b-4ec7-8e92-50fa8d40ecaf%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/1b2f1047-c22b-4ec7-8e92-50fa8d40ecaf%40googlegroups.com?utm_medium=email&utm_source=footer)  
> > .  
> > For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/3b924029-09d1-4251-aa4d-f5940f7b7177%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/3b924029-09d1-4251-aa4d-f5940f7b7177%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 12:53am UTC](https://discuss.elastic.co/t/no-clustering-on-ec2-due-to-classnotfoundexception-org-elasticsearch-gateway-blobstore-blobstoregatewaymodule/18862/10 "2017-07-06T00:53:06Z")

</div>


