# No config files found in path error Logstash Ubuntu

**URL:** https://discuss.elastic.co/t/no-config-files-found-in-path-error-logstash-ubuntu/267318
**Category:** Logstash
**Created:** [March 16, 2021, 4:23am UTC](https://discuss.elastic.co/t/no-config-files-found-in-path-error-logstash-ubuntu/267318 "2021-03-16T04:23:11Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![varun1992](https://avatars.discourse-cdn.com/v4/letter/v/3da27b/32.png) [@varun1992](https://discuss.elastic.co/u/varun1992)
#### Post date: [March 16, 2021, 4:23am UTC](https://discuss.elastic.co/t/no-config-files-found-in-path-error-logstash-ubuntu/267318/1 "2021-03-16T04:23:11Z")

</div>

```
MLinux1@MLinux1:~/shared$ l
LogStash-Beats-MTenant.conf*
MLinux1@MLinux1:~/shared$

```

> My **pipeline.yml** as below

```
- pipeline.id: beat_input-shared
  path.config: "/home/MLinux1/shared/*.conf"
  pipeline.workers: 2
  queue.type: persisted

```

> my config file as below

```
input {
      beats {
        port => 9010
      }
    }
    #---------------------OUTPUT SECTION----------------------------------------
    output {
      elasticsearch {
        hosts => ["10.11.0.64:9200","10.11.0.60:9200"]
        manage_template => false
        validate_after_inactivity => 10000
        index => "school_er-%{[@metadata][beat]}-%{[@metadata][version]}-%{+YYYY.MM.dd}"
        ilm_enabled => false
      }
    }

```

> i am getting logstash error as below

```
[2021-03-16T03:57:00,997][INFO][logstash.runner] Starting Logstash {"logstash.version"=>"7.11.2", "jruby.version"=>"jruby 9.2.13.0 (2.5.7) 2020-08-03 9a89c94bcc OpenJDK 64-Bit Server VM 11.0.8+10 on 11.0.8+10 +indy +jit [linux-x86_64]"}
    [2021-03-16T03:57:06,259][INFO][logstash.config.source.local.configpathloader] No config files found in path {:path=>"/home/MLinux1/shared/*.conf"}
    [2021-03-16T03:57:06,457][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.
    [2021-03-16T03:57:07,251][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9600}
    [2021-03-16T03:57:11,749][INFO][logstash.runner] Logstash shut down.
    [2021-03-16T03:57:11,762][FATAL][org.logstash.Logstash] Logstash stopped processing because of an error: (SystemExit) exit
    org.jruby.exceptions.SystemExit: (SystemExit) exit
            at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:747) ~[jruby-complete-9.2.13.0.jar:?]
            at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:710) ~[jruby-complete-9.2.13.0.jar:?]
            at usr.share.logstash.lib.bootstrap.environment.<main>(/usr/share/logstash/lib/bootstrap/environment.rb:89) ~[?:?]

```

> Why i am getting error in logstash?  
> when i run conf file with `logstash -f file` , it run without issue

---

<div class="post-metadata">

### Author: ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)
#### Post date: [March 16, 2021, 2:58pm UTC](https://discuss.elastic.co/t/no-config-files-found-in-path-error-logstash-ubuntu/267318/2 "2021-03-16T14:58:46Z")

</div>

How are you starting logstash?

---

<div class="post-metadata">

### Author: ![varun1992](https://avatars.discourse-cdn.com/v4/letter/v/3da27b/32.png) [@varun1992](https://discuss.elastic.co/u/varun1992)
#### Post date: [March 22, 2021, 11:10am UTC](https://discuss.elastic.co/t/no-config-files-found-in-path-error-logstash-ubuntu/267318/3 "2021-03-22T11:10:45Z")

</div>

sudo systemctl start logstash.service

---

<div class="post-metadata">

### Author: ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)
#### Post date: [March 22, 2021, 4:40pm UTC](https://discuss.elastic.co/t/no-config-files-found-in-path-error-logstash-ubuntu/267318/4 "2021-03-22T16:40:59Z")

</div>

> [@varun1992](#):
>
> `"/home/MLinux1/shared/*.conf"`

When logstash expands that pattern it is not finding any files. That could be a permissions issue, where the user that runs the service cannot read the file or the directory.

---

<div class="post-metadata">

### Author: ![varun1992](https://avatars.discourse-cdn.com/v4/letter/v/3da27b/32.png) [@varun1992](https://discuss.elastic.co/u/varun1992)
#### Post date: [April 18, 2021, 6:06am UTC](https://discuss.elastic.co/t/no-config-files-found-in-path-error-logstash-ubuntu/267318/5 "2021-04-18T06:06:01Z")

</div>

thanks

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 16, 2021, 6:06am UTC](https://discuss.elastic.co/t/no-config-files-found-in-path-error-logstash-ubuntu/267318/6 "2021-05-16T06:06:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
