# No log4j2 configuration file found when trying to load test data from X-pack learning tutorial

**URL:** <https://discuss.elastic.co/t/no-log4j2-configuration-file-found-when-trying-to-load-test-data-from-x-pack-learning-tutorial/96574>\
**Category:** Elastic Training\
**Created:** [August 10, 2017, 9:02am UTC](https://discuss.elastic.co/t/no-log4j2-configuration-file-found-when-trying-to-load-test-data-from-x-pack-learning-tutorial/96574 "2017-08-10T09:02:14Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ferrow](https://avatars.discourse-cdn.com/v4/letter/f/7bcc69/32.png) [@Ferrow](https://discuss.elastic.co/u/Ferrow)\
**Post date:** [August 10, 2017, 9:02am UTC](https://discuss.elastic.co/t/no-log4j2-configuration-file-found-when-trying-to-load-test-data-from-x-pack-learning-tutorial/96574/1 "2017-08-10T09:02:14Z")

</div>

Hello out there 🙂

im having trouble getting data loaded for training purpose with the x-pack tutorial. (Lab 1) Im not sure where to start with this error since the files it mentions are in the correct places.  
here is what my terminal have to say:

root@Infowise:/usr/share/logstash/bin# cat stocks.csv | ./logstash -f stocks.conf  
ERROR StatusLogger No log4j2 configuration file found. Using default configuration: logging only errors to the console.  
WARNING: Could not find logstash.yml which is typically located in $LS\_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults  
Could not find log4j2 configuration at path //usr/share/logstash/config/log4j2.properties. Using default config which logs to console  
10:57:36.490 [[main]-pipeline-manager] INFO logstash.outputs.elasticsearch - Elasticsearch pool URLs updated {:changes=\>{:removed=\>[], :added=\>[[http://elastic:xxxxxx@127.0.0.1:9200/](http://elastic:xxxxxx@127.0.0.1:9200/)]}}  
10:57:36.493 [[main]-pipeline-manager] INFO logstash.outputs.elasticsearch - Running health check to see if an Elasticsearch connection is working {:healthcheck\_url=\>[http://elastic:xxxxxx@127.0.0.1:9200/](http://elastic:xxxxxx@127.0.0.1:9200/), :path=\>"/"}

root@Infowise:/usr/share/logstash/bin# ls  
cpdump [ingest-convert.sh](http://ingest-convert.sh) logstash logstash.bat [logstash.lib.sh](http://logstash.lib.sh) logstash-plugin logstash-plugin.bat ruby setup.bat stocks.conf stocks.csv system-install

root@Infowise:/etc/logstash# ls  
conf.d jvm.options log4j2.properties logstash.yml startup.options

---

<div class="post-metadata">

**Author:** ![EddieTurizo](https://avatars.discourse-cdn.com/v4/letter/e/8edcca/32.png) [@EddieTurizo](https://discuss.elastic.co/u/EddieTurizo)\
**Post date:** [August 22, 2017, 8:25pm UTC](https://discuss.elastic.co/t/no-log4j2-configuration-file-found-when-trying-to-load-test-data-from-x-pack-learning-tutorial/96574/3 "2017-08-22T20:25:22Z")

</div>

@Ferrow

> im having trouble getting data loaded for training purpose with the x-pack tutorial. (Lab 1) Im not sure where to start with this error since the files it mentions are in the correct places.  
> here is what my terminal have to say:

> root@Infowise:/usr/share/logstash/bin# cat stocks.csv | ./logstash -f stocks.conf  
> ERROR StatusLogger No log4j2 configuration file found. Using default configuration: logging only errors to the console.

It is a known issue and can be ignored as recommended in this thread.

[https://discuss.elastic.co/t/logstash-5-5-0-error-statuslogger-no-log4j2-configuration-file-found/92921](https://discuss.elastic.co/t/logstash-5-5-0-error-statuslogger-no-log4j2-configuration-file-found/92921)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 19, 2017, 8:25pm UTC](https://discuss.elastic.co/t/no-log4j2-configuration-file-found-when-trying-to-load-test-data-from-x-pack-learning-tutorial/96574/4 "2017-09-19T20:25:24Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
